15:01:04 <vuntz> #startmeeting openSUSE Project Meeting
15:01:04 <bugbot> Meeting started Wed Oct  2 15:01:04 2013 UTC.  The chair is vuntz. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:04 <bugbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:01:08 <vuntz> hey hey
15:01:10 <vuntz> so
15:01:12 <vuntz> who's here?
15:01:16 * vuntz looks around
15:01:26 <vuntz> Ilmehtar, robjo, FunkyPenguin: ping?
15:01:27 <robjo> me me me
15:02:01 <vuntz> lucky us: triple robjo for today!
15:02:04 <Ilmehtar> Half pong
15:02:18 <Ilmehtar> I'm in a lift with coffee
15:02:24 <Ilmehtar> Will be at desk shortly
15:02:58 <FunkyPenguin> vuntz: je suis ici
15:03:45 <vuntz> we have only one item on the agenda: GSoC Wrap Up
15:04:05 * manugupt1 is here
15:04:24 <vuntz> and I don't see any action item left from last meeting
15:04:28 <vuntz> Ilmehtar: is that correct?
15:05:30 <Ilmehtar> vuntz: I had an action item to contact agustin regarding the reimbursement of local materials, I did, no reply yet (vacation)
15:06:05 <Ilmehtar> apart from that, pretty sure that's correct
15:06:24 <vuntz> want to keep that?
15:06:40 <Ilmehtar> sure, good to remind us
15:06:41 <vuntz> #topic Action items review
15:07:05 <vuntz> #info Ilmehtar contacted agustin regarding the reimbursement of local materials, waiting for reply
15:07:21 <vuntz> #action Ilmehtar to keep pushing on the reimbursement of local materials
15:07:31 <vuntz> #topic GSoC Wrap Up
15:07:40 <vuntz> so let's move to our main topic
15:07:45 <vuntz> manugupt1: here's the microphone :-)
15:07:51 <manugupt1> Hi..
15:08:20 <manugupt1> gsoc got over this weekend, 2 students failed out of the 12 students we had
15:08:53 <vuntz> so 10 passed
15:08:56 <vuntz> which is quite good
15:08:57 <manugupt1> 2 mentors will go to mentor summit..
15:08:58 <manugupt1> yes
15:09:08 <vuntz> #info of the 12 students, 10 passed and 2 failed
15:09:17 <vuntz> #info 2 mentors will go to mentor summit
15:09:22 <manugupt1> we had trouble with one student, but he passed eventually.
15:09:46 <manugupt1> Also, I discussed with saurabh on possibility of creating a guidelines for next gsoc
15:09:56 <manugupt1> which are
15:09:58 <manugupt1> 1. If the student is not writing weekly reports  and the mentor fails the student, we wont accept the evaluations as PASS or go to carol for reevaluations.
15:10:00 <manugupt1> 2. GSoC is supposed to be a full time project. If the work is done earlier, it is upto the mentor to decide if he or she will get more work or not.
15:10:01 <manugupt1> 3. A student should not have a second job ( school is ok )
15:10:03 <manugupt1> 4. Students must have committed some code / package or some other form of contribution to openSUSE.
15:10:06 <manugupt1> 5. Students are expeceted to work atleast 4 hours a day (it will usually mean atleast 2 pull requests / commits as a bare minimum per week)
15:10:06 <manugupt1> 6. Students should be verified by a college professor vouching for him.
15:10:07 <manugupt1> 7. Mentors should encourage stand off meetings
15:10:46 <manugupt1> what do you guys think about it, I will put it on a discussion at opensuse-project
15:11:40 <BManojlovic> 3) does not make sense if student must pay for his rent for example...
15:12:09 <Ilmehtar> do any other GSoC participants have similar rules?
15:12:24 <manugupt1> BManojlovic: student gets paid 5000 USD in 3 months
15:12:37 <BManojlovic> but on the end of it not gradually as i remember
15:12:56 <manugupt1> Ilmehtar: some have and some dont
15:13:14 <manugupt1> BManojlovic: it is 500 usd + 22250 + 2250 but it is a guideline
15:14:14 <Ilmehtar> I'm not sure of the point of rule 3) when you have rule 5) - if the student can contribute 4 hours a day, what does it matter if they have a job or not?
15:14:29 <BManojlovic> exactly my point
15:14:41 <manugupt1> I know 2,4,7 is followed
15:15:23 <robjo> Students can have a job, I don't care if they code a night and work during the day or vice-versa
15:16:51 <manugupt1> I think we can strike off 3, but there have been a couple of cases where students have gone kaput when they had a second job
15:17:15 <manugupt1> 3 and 5 are yes similar
15:17:27 <robjo> There is no way of guaranteeing success
15:17:59 <manugupt1> agreed robjo, I want to be pretty strict on 1 and 6 though rest all it will be up to the mentor
15:18:20 <robjo> even if yo have a rule that says "no second job" how would you verify/enforce the rule
15:18:45 <robjo> if you find out and fail the student you have the same result as if the student fails because of having a job
15:18:56 <vuntz> #info GSoC admins are proposing a set of guidelines for future participation in GSoC
15:19:43 <manugupt1> robjo: Hmm.. yes.. i agreed
15:20:16 <robjo> what are you trying to accomplish with guideline 7 ?
15:21:35 <manugupt1> robjo: Well, I was going through mentor reviews, I found a few mentors mention that students were shy to ask questions in the beginning of the program, maybe this can help
15:22:36 <manugupt1> it will be upto the mentor at the end of the day on 7
15:23:01 <robjo> what you want is a kick off meeting then?
15:23:10 <manugupt1> yeah
15:23:24 <manugupt1> I will reword it.
15:23:46 <robjo> That makes sense
15:24:21 <robjo> Strike 3, reword 7 and I think we're good
15:24:25 <robjo> others?
15:25:26 <vuntz> I'm wondering how we will verify the vouching by professors
15:25:56 <manugupt1> vuntz: a professor can mail from their university's address
15:26:10 <manugupt1> university's mail address
15:26:24 <manugupt1> like vuntz@opensuse.org makes you from openSUSE
15:26:26 <robjo> that should be reasonably easy. Look up the institution and staff list, get the e-mail and send the prof an e-mail
15:27:24 <vuntz> as long as this has been thought about, I'm fine :-)
15:27:44 <robjo> In the end it is somewhat of a trust relationship. We have the opportunity to verify, but should also trust the students that they are not out to derail a project
15:28:08 <robjo> if they derail they don't get paid, thus they hurt themselves
15:29:07 <robjo> there's no work getting done for the project in that case, but that's probably work that we've lived without to begin with
15:29:27 <vuntz> okay
15:29:33 <vuntz> manugupt1: anything else for gsoc?
15:29:49 <manugupt1> vuntz: I guess that is it
15:29:54 <robjo> critical work should not be a GSoC project IMHO
15:30:21 <manugupt1> robjo: it can be.. a lot of orgs do it
15:30:31 <vuntz> manugupt1: do you want an action item to document these guidelines no the wiki?
15:30:38 <robjo> that's their problem ;)
15:30:57 <manugupt1> vuntz: Let me put it on discussion on project list and then on the wiki, I will document it
15:31:06 <manugupt1> robjo: :)
15:31:21 <vuntz> #action manugupt1 to get suggested guidelines discussed on opensuse-project@
15:31:34 <vuntz> any other topic people would like to discuss?
15:32:09 <robjo> Elections
15:32:09 * vuntz would have loved a summary of the beta pizza hackathon, but fears nobody here can report about it
15:32:29 <robjo> we need to fill out the committee or go with the people that volunteered and get that announced
15:32:49 * terrorpup couldn't make pizza hackathon work and sick kid
15:33:10 <vuntz> #topic Any other topic
15:33:19 <terrorpup> I have something
15:33:27 <vuntz> terrorpup: shoot
15:33:33 <terrorpup> we are now over 8,000 fan on Facebook
15:33:48 * manugupt1 claps
15:33:56 <terrorpup> We hit that this Sunday
15:34:29 <vuntz> woo!
15:34:38 <vuntz> #info over 8,000 fan on Facebook
15:34:54 <robjo> Anyone here willing to volunteer on the Election committee? We have 3 people so far
15:34:56 <Ilmehtar> vuntz: only thing I can say about the 'hackathon' is - while I couldn't figure out how to get involved as a community member (there didn't seem to be a google hangout or anything), there was a TON of bugs filed and fixed, and as a maintainer it was a very busy couple of days, which is good
15:35:35 <robjo> I did get an invite for a Google hangout for the hackathon
15:35:43 <terrorpup> Ilmehtar, the invite did make seem like it was google hangout
15:35:57 <robjo> considering that it started at 1 AM in my timezone I decided that I should be sleeping instead ;)
15:36:15 * DimStar confirms.. there were dozens of people hacking away and reporting bugs to close them (or so).... sad to see though that this was a 'one-day' thing (I think most of those people disappaered again)
15:36:15 <vuntz> yeah, saw lots of bugs getting closed, that was nice
15:36:42 <vuntz> #info beta pizza hackathon: a TON of bugs filed and fixed!
15:37:22 <Ilmehtar> I think part of the problem is michal (who was co-ordinating things) got sick just before the start, still overall, looks like it was a net positive, I just woulda liked to have been more involved ;-)
15:37:44 <terrorpup> I know this isn't the time to ask, but I like to be on the social media marketing for 13.1
15:38:32 <robjo> terrorpup: you probably just need to get a hold of jospoortvliet_
15:38:45 <robjo> I think jospoortvliet_ is still on vacation this week
15:39:02 <terrorpup> will do
15:40:21 <terrorpup> the current total on the opensuse project page on facebook is 8,028 members
15:41:23 <vuntz> robjo asked earlier: anyone willing to help with the election committee?
15:42:50 <terrorpup> I would like to say yes, but I am now in a middle of a data center move at work. I will not be running this year.
15:43:27 <vuntz> robjo: so I guess we should go with the 3 people we have
15:43:35 <vuntz> any last question/comment?
15:43:43 <robjo> terrorpup: if you ar enot running for the board you are a perfect candidate for the election committe ;)
15:44:12 <terrorpup> robjo, I know I just worry about time.
15:44:40 <robjo> we'll go with the volunteers we have, announcement should go out next week then
15:44:47 <terrorpup> I don't want to say yes, become a no-show-jones < refering the to country singer >
15:45:06 <vuntz> okay, then that's it!
15:45:10 <vuntz> thanks all for joining!
15:45:13 <robjo> terrorpup: no pressure we all get busy
15:45:13 <vuntz> #endmeeting