14:01:54 <AJaeger> #startmeeting "Welcome to the openFATE Screening Team Meeting"
14:01:54 <bugbot> Meeting started Thu Dec  9 14:01:54 2010 UTC.  The chair is AJaeger. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:54 <bugbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:02:25 <AJaeger> We have today the following topics:
14:02:31 <AJaeger> * Promoting features
14:02:46 <AJaeger> * openSUSE distribution features
14:02:51 <AJaeger> * Package Wishlist
14:03:11 <AJaeger> I'd like to see who's available today to participate in the meeting.
14:03:16 <AJaeger> PLease raise your hands
14:03:20 <AJaeger> ... or better say Hi!
14:04:22 <HeliosReds> Hi!
14:04:27 <AJaeger> Hi HeliosReds!
14:04:39 <digitltom> raise
14:04:56 <HeliosReds> Hi digitltom
14:05:00 * AJaeger waves to digitltom
14:06:16 <AJaeger> That's cosy meeting ;)
14:06:47 <AJaeger> Ok, let's still discuss a bit...
14:06:57 <AJaeger> But first: Any other topics you like to bring up?
14:07:52 <AJaeger> We can always add later as well...
14:07:57 <AJaeger> #topic Promoting features
14:07:58 <HeliosReds> Nothing special from me ATM.
14:08:05 <AJaeger> How can we promote features best?
14:08:12 <AJaeger> HeliosReds: You mentioned OWN
14:08:16 <AJaeger> Is this done already?
14:09:11 * mrdocs waves
14:09:22 <HeliosReds> Every week, I pick up newly added features to OWN.
14:09:42 <AJaeger> Hi mrdocs!
14:09:52 <mrdocs> Hi AJaeger
14:09:57 <AJaeger> HeliosReds: I'm just looking at issue 152 and can't find it ;(
14:10:15 <mrdocs> sorry i missed the last one.. from the mails its not clear when there is an IRC meet
14:10:43 <AJaeger> mrdocs: We try to keep the wiki page updated: http://en.opensuse.org/openSUSE:Openfate_screening#Bi-weekly_openFATE_screening_team_meeting
14:10:56 <AJaeger> mrdocs: sorry, my reminder email was very late ;-(
14:10:57 * mrdocs bookmarks
14:11:10 <mrdocs> no worries we're all busy
14:11:41 <HeliosReds> Since issue 152, the procedure of editing OWN has changed so that I could help editing only few. :-(
14:12:01 <AJaeger> HeliosReds: I found now section "openFATE Team"
14:12:32 <AJaeger> But that one only consists a list of features without explanation.
14:13:07 <AJaeger> I suggest to add some more explanation, .e.g these are the features with highest vote looking for volunteers to implement:...
14:13:51 <AJaeger> Moving forward, we could also do a separate blog post speaking about open and done features - but for 11.4 it's too late now.
14:14:21 <HeliosReds> Hmmm, OK, I'll try to do so from next issue.
14:14:31 <AJaeger> HeliosReds: Thanks!
14:14:51 <AJaeger> Any other ideas?
14:15:12 <digitltom> HeliosReds:  also the feature ids in the headline are not interesting, as it's a link anyway
14:15:12 <mrdocs> im still getting my head around some of the work flow
14:15:49 <HeliosReds> digitltom: I see.
14:16:35 <AJaeger> mrdocs: LEt's do that at the end with a topic on work flow/usage
14:16:47 <mrdocs> NP here
14:17:38 <AJaeger> #topic openSUSE distribution features
14:17:51 <AJaeger> what shall we do with the distribution features?
14:18:03 <AJaeger> I see the following tasks: Cleaning up 11.3 feature list
14:18:15 <AJaeger> Distilling 11.4 top features
14:18:29 <AJaeger> Cleaninug up 11.4 (with feature deadline next week)
14:19:09 <AJaeger> I will try to propose 10 top features for 11.4 and ask for feedback
14:19:17 <mrdocs> sounds good
14:19:31 <HeliosReds> How about having a 'FATE Day', like 'Bug Day' we had last week and are going to have this weekend?
14:19:36 <AJaeger> We should reject not done features and add the "openSUSE Distribution" generic product for that...
14:19:43 <AJaeger> HeliosReds: Good idea
14:20:11 <AJaeger> But I can't drive this since I'll be on paternal leave from 14th December to 13th February - so one of you needs to drive this.
14:20:23 <AJaeger> Any volunteers?
14:20:33 <digitltom> we also should have experts from different areas in there
14:20:36 <mrdocs> next week is not good, the week after is fine for me
14:21:03 <mrdocs> yeah even invite some of the teams to discuss feasiblity/developer effort
14:22:07 <AJaeger> digitltom: We need to recruit more experts as well
14:23:06 <AJaeger> So, who can reach out to some more teams?
14:23:14 <AJaeger> I've tried reachting out to GNOME and KDE teams
14:23:24 <gnokii> http://www.linuxnewmedia.com/Products/Events/Linux-New-Media-Award-Favourite-Linux-Distribution-2010
14:23:25 <mrdocs> i can definiely try again with Gnome/KDE
14:24:18 <AJaeger> #action: mrdocs to followup with GNOME/KDE teams to evaluate features
14:24:22 <AJaeger> mrdocs: Thanks
14:24:26 <mrdocs> NP
14:24:30 <AJaeger> #action mrdocs to followup with GNOME/KDE teams to evaluate features
14:25:06 <AJaeger> Let's ask visnov for help with YaST...
14:25:19 <AJaeger> #action visnov to figure out how to evaluate YaST features
14:25:37 <AJaeger> (he's not here, hope he's fine with me volunteering him ;)
14:26:10 <AJaeger> So, do you want to setup a FATE day now or postpone?
14:26:24 <AJaeger> #idea have a FATE day to cleanup openFATE
14:26:49 <digitltom> we should collect available times of the interested people
14:27:01 <digitltom> makes no sense for me to do it allone ;-)
14:27:35 <AJaeger> It would be a complete day, so mrdocs mentioned week of 20th of December - correct?
14:28:05 <mrdocs> yes
14:28:27 <AJaeger> any preference for a day? Weekend, workday?
14:28:33 <mrdocs> Im actually thinking the 20th
14:28:42 <digitltom> ok for me
14:28:50 <AJaeger> HeliosReds?
14:28:54 <mrdocs> that way we have the main team leaders on a work day
14:30:35 <HeliosReds> For me, weekend is better, but weekday would be OK.
14:33:19 <AJaeger> Ok, who will organize it and invite others to it?
14:33:38 <digitltom> i can do that
14:33:54 <AJaeger> #action digitltom to organize openFATE day on the 20th of December
14:33:57 <AJaeger> digitltom: Thanks!
14:33:57 <mrdocs> digitltom: 20 Dec ok with you ?
14:34:35 <HeliosReds> digitltom: Thanks. You are our hero!
14:36:06 <digitltom> everyone who participates at the 20th will be a hero ;-)
14:36:17 * AJaeger claps to our upcoming heros
14:36:41 <vuntz> AJaeger: fwiw, for the gnome team: the plan is to discuss them in the next team meeting
14:36:48 <AJaeger> vuntz: Thanks!
14:37:29 <digitltom> vuntz:  just contact me if you have questions
14:37:37 <vuntz> sure
14:37:41 <AJaeger> #topic Package Wishlist
14:38:19 <AJaeger> I propose that we start looking at the package wishlist as well and push that some more while the distribution goes into Beta phase
14:39:06 <AJaeger> So, we should review the distribution products for package wishes and move them to the package wishlist - and also ask regularly for pacakgers to pacakge them.
14:39:30 <mrdocs> yes
14:39:47 <mrdocs> and forward the requests to the respective teams/developers
14:39:47 <AJaeger> I consider a packaging task a bit easier than some of the other distribution tasks and so we can try to get the ball rolling faster this way and learn how to get people on board
14:39:59 <HeliosReds> BTW, who can decide whether features such as 'please add package A to openSUSE' or 'set B as default' should be realized or not?
14:40:22 <AJaeger> mrdocs: Yes, for example send regularly an email to opensuse-packaging with the most voted packages fro mthe wishlist...
14:40:32 <mrdocs> exactly
14:40:59 <AJaeger> HeliosReds: For please add: The process for adding packages is to propose them on the factory mailing list and then they go in.
14:41:51 <AJaeger> For making defaults: That'S something that should be discussed with all stake holder, e.g. the maintainer of the package that is currently default - and depending on the package could just announced on the packaging list.
14:42:11 <digitltom> AJaeger:  are package wishlist features done when they are in factory or when they are in the buildservice...?
14:42:25 <AJaeger> And in general: You have the power to reject these - so, if you consider something completely wrong, reject it ;)
14:42:42 <AJaeger> digitltom: My opinion is : When in factory.
14:42:49 <mrdocs> +1
14:42:50 <AJaeger> digitltom: But we can define otherwise ;)
14:43:14 <mrdocs> the reason is an app can be in OBS but not in Factory
14:43:19 <BManojlovic> AJaeger: what with YaST?
14:43:33 <AJaeger> BManojlovic: What do you mean exactly?
14:43:44 <BManojlovic> AJaeger: <AJaeger> #action visnov to figure out how to evaluate YaST features
14:43:55 <BManojlovic> so i'm asking what with YaST ? :)
14:44:02 <BManojlovic> as can i help if help is needed
14:44:32 <AJaeger> BManojlovic: We need domain experts to handle evaluating of features - and for evaluating of YaST I wanted to ask Stano Visnov since he'S an expert here and part of the openFATE team
14:44:50 <AJaeger> BManojlovic: Tell me your email and I'll CC you on my mail to him
14:45:27 <HeliosReds> BManojlovic: There are several features such as 'please add module XX to YaST'.
14:45:32 <BManojlovic> AJaeger: boris@steki.net
14:45:48 <AJaeger> BManojlovic: Thanks
14:45:53 <mrdocs> i looked at some and they are reasonable requests
14:46:02 <mrdocs> just a question of coding time/testing
14:47:44 <AJaeger> So, I suggest you put the package wishlist as topic for future discussions or the openFATE day...
14:47:58 <AJaeger> Next topic...
14:48:04 <AJaeger> #topic Questions
14:48:11 <AJaeger> mrdocs: You had questions about the workflow?
14:48:21 <AJaeger> Anybody else with questions regarding openFATE?
14:48:22 <mrdocs> no more now
14:48:37 <AJaeger> mrdocs: That was quick ;)
14:48:48 <mrdocs> i guess its new territory for developers etc, so we will learn along the way :P
14:49:04 <AJaeger> mrdocs: Yes, it's a new way of working so we have to experiment.
14:49:24 <mrdocs> only note of caution is if you reject a feature, do give a reason..
14:49:40 <AJaeger> FATE is used at NOvell but the process used there does not really work for community - so I proposed a new one. But if it does not work, fix it ;)
14:49:44 <mrdocs> the bugzilla reponse of WONTIFX will not win us any firends
14:49:54 <AJaeger> mrdocs: Indeed.
14:50:31 <mrdocs> there is also (Ihope) an option to defer to a later release
14:50:38 <AJaeger> After you have spend some more time with evaluating of features, I suggest we define better what we want to have as features so that it's clear for people what we expect to see...
14:50:45 <mrdocs> yup
14:51:22 <AJaeger> mrdocs: WE can now use the "openSUSE Distribution" feature - that way we do not neet to defer anymore...
14:52:34 <AJaeger> One more thing: I have tried moving openFATE on the process and team side forward while digitltom did this on the technical side (thanks!)
14:53:00 <AJaeger> Since I'll go on parental leave, digitltom will help with the rest as well - so if you have any questions, digitltom is the hero to contact ;)
14:53:56 <AJaeger> #info AJ on parental leave until 13th February, digitltom will help with any openFATE question
14:54:17 <mrdocs> when do you leave AJaeger ?
14:54:28 <mrdocs> and are you completely disconnecting ?
14:54:29 <AJaeger> mrdocs: Tuesday is my first day
14:54:39 <mrdocs> unplugged as we say :)
14:54:53 <AJaeger> mrdocs: I tell everybody completely - but I know I cannot resist to look in occasionaly ;)
14:55:05 * mrdocs nods knowingly
14:55:07 <AJaeger> mrdocs: So, my message is: Expect that I'm away and changing diapers ;)
14:55:23 <AJaeger> mrdocs: http://lizards.opensuse.org/2010/11/22/please-note/
14:55:28 <mrdocs> fair enough... its a fun time tho
14:55:41 <AJaeger> mrdocs: Hope so
14:55:45 <mrdocs> little Stella is 3 now.. fun age
14:56:08 <AJaeger> mrdocs: My daughter is soon 3 - yeah, really fun... my son is now 1.
14:56:12 <AJaeger> OK, anything else?
14:56:15 <mrdocs> AJaeger: Im sure we will manage... the folks here are sensible
14:56:21 <mrdocs> not from me
14:56:27 <AJaeger> mrdocs: They are - especially digitltom ;)
14:56:48 <AJaeger> OK, then bye for now!
14:56:55 <AJaeger> Thanks for participating in the meeting!
14:56:57 <AJaeger> #endmeeting