19:04:21 <suseROCKs> #startmeeting
19:04:21 <bugbot> Meeting started Wed Dec  1 19:04:21 2010 UTC.  The chair is suseROCKs. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:04:21 <bugbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:04:23 <rhorstkoetter> suseROCKs: you see. we urgently need henne
19:04:32 <suseROCKs> #chair rhorstkoetter
19:04:32 <bugbot> Current chairs: rhorstkoetter suseROCKs
19:04:36 <suseROCKs> #chair prusnak
19:04:36 <bugbot> Current chairs: prusnak rhorstkoetter suseROCKs
19:05:16 <suseROCKs> #topic openSUSE Board Meeting
19:05:35 <suseROCKs> Alrighty so let's begin, folks!
19:06:07 <suseROCKs> Today's agenda will be:
19:06:10 <suseROCKs> 1. openSUSE election / committee
19:06:10 <suseROCKs> 2. openSUSE Foundation
19:06:10 <suseROCKs> 3. Where do we need to improve ?
19:06:10 <suseROCKs> 4. Questions & Answers
19:06:22 <suseROCKs> Do we have additional items we wish to add to the agenda?
19:07:14 <prusnak> not at this time
19:07:18 <suseROCKs> ok I'll take that as a no and move on to the first topic
19:07:37 <suseROCKs> #topic openSUSE Board Meeting | Topic: openSUSE election /committee
19:08:12 <rhorstkoetter> the commitee just announced the elections and we already have two candidates
19:08:14 <suseROCKs> So we have an announcement posted about the election committee and a timeline described in the post
19:08:54 <suseROCKs> Yes, I've talked to a few people already who are interested in running.  Not sure if its the same people you're referring to
19:09:10 <suseROCKs> but whomever we have already talked to, we should be sure to poke them to submit their application pronto
19:09:15 <suseROCKs> if they haven't already done so
19:09:19 * mrdocs will stand as well
19:09:26 <mrdocs> just not sent the mail
19:09:34 <rhorstkoetter> I'm referring to sebastian kügler (sebas) & chuck payne (terrorpup)
19:09:38 <suseROCKs> poke mrdocs   :-)
19:09:55 <mrdocs> lo suseROCKs
19:10:03 <rhorstkoetter> that are the emails I read on election-officials/opensuse-project so far
19:10:08 <suseROCKs> ok there's one more to that list. but until that person actually declares it publicly, I prefer to let it stand until he/she states so
19:10:48 <suseROCKs> so I would surmise from what I'm seeing here that we can rejoice that this year we will actually have an election!  ;-)
19:11:45 <suseROCKs> As you have seen from our mailing list, I have a first draft of the board's perception of what it means to be on the board
19:11:57 <suseROCKs> I need to further re-draft it, and encourage you both to submit your comments as well
19:12:13 <suseROCKs> let's get it published no later than this week.   Cool, guys?
19:12:57 <prusnak> ack
19:12:57 <rhorstkoetter> suseROCKs: will comment
19:13:17 <rhorstkoetter> haven't had the time yet. thanks for the initial draft
19:13:28 <suseROCKs> #action suseROCKs to publish the Board's Perspective on being a Board Member with comments from other board members by end of the week
19:13:31 <rhorstkoetter> Iirc henne wrote some comments already
19:13:41 <suseROCKs> yes
19:14:06 <suseROCKs> ok so, I take it the election committee is on the ball and we have generally no concerns at this point?
19:14:24 <suseROCKs> if so, let's close this topic.  :-)
19:14:58 <prusnak> good
19:15:12 <suseROCKs> topic is closed...
19:15:31 <suseROCKs> #topic openSUSE Board Meeting | Topic openSUSE Foundation
19:15:53 <rhorstkoetter> afaik we have alan clark attending today
19:16:02 <rhorstkoetter> aclark_: ping
19:16:09 <aclark_> you sniffed me out ;-)
19:16:21 <suseROCKs> hey hey aclark_ !
19:16:26 <rhorstkoetter> aclark_: welcome to our meeting and thanks for being here
19:16:39 <aclark_> thanks
19:16:53 <suseROCKs> before we proceed, I think the biggest question we need to address is how do we proceed henceforth on interfacing here?
19:17:16 <suseROCKs> previously, michl was doing all the work on that end, which was good in some ways and other ways not so good.   It wasn't transparent enough for us.
19:17:49 <suseROCKs> so let's clear up how we communicate henceforth before we get into nitty gritty details with aclark_   :-)
19:18:07 <rhorstkoetter> most likely it has been too much 1 on 1 telecom :)
19:18:26 <suseROCKs> yes, and that left some of us out of the process
19:18:31 <rhorstkoetter> what about collaborating through board@o.o?
19:18:46 <rhorstkoetter> aclark_: would that be sufficient from your perspective?
19:18:56 <suseROCKs> I would prefer that as it gives us a nice paper trail.
19:19:04 <rhorstkoetter> +1
19:19:34 <aclark_> I'm fine with that plus henne and I have been using piratepad for docs.
19:19:45 <aclark_> i think you've all seen that?
19:19:52 <suseROCKs> except when piratepad goes down  :-)
19:19:55 <rhorstkoetter> yes, it's at http://piratepad.net/openSUSE-Bylaws
19:20:23 <rhorstkoetter> we're currently drafting the bylaws there
19:20:29 <aclark_> right
19:20:38 <rhorstkoetter> aclark_: you're fine with that approach?
19:20:46 <rhorstkoetter> I guess so
19:21:07 <aclark_> +1
19:21:34 <suseROCKs> ok so we have established the communication channel clearly now and I think we're all comfortable with that
19:22:09 <suseROCKs> so... since we've all been in and out on this process lately. let's just quickly summarize where we are at and what we need to do in the next 2-3 steps
19:22:44 <suseROCKs> 1.  We are drafting bylaws
19:22:49 <suseROCKs> 2.  ....
19:23:41 <aclark_> The next step that I am working on is meeting with Novell Legal.  I'm waiting in their queue. As you can imagine they have been consumed with a different matter
19:23:55 <rhorstkoetter> aclark_: obviously
19:24:05 <suseROCKs> I can't imagine what that other matter might be.  :-)
19:24:40 <aclark_> The purpose is to review the current plans and open questions.
19:24:47 <rhorstkoetter> aclark_: once we have the bylaws in place and you handled the process with novell legal I may help implementing the bylaws
19:24:50 <rhorstkoetter> if appreciated
19:24:56 <suseROCKs> I guess we also have some questions as to where our direction (with Novell as a partner) might go on the Foundation.  But that's the kind of question that cannot be answered at this time.
19:25:35 <suseROCKs> rhorstkoetter,   You mean like taking care of filing, etc. in Germany?
19:25:48 <rhorstkoetter> suseROCKs: thing like that, yes
19:26:01 <rhorstkoetter> investigating what we need to do in that regard
19:27:10 <suseROCKs> might I suggest you go ahead and investigate those steps now rather than wait for the bylaws to be completed?   Information on that is not wholly dependent on the final draft of the bylaws
19:27:11 <aclark_> I will suggest that to the legal team.
19:27:39 <rhorstkoetter> suseROCKs: fine by me
19:28:03 <suseROCKs> #action  rhorstkoetter to investigate procedures for filing e.V. application in Germany
19:28:04 <rhorstkoetter> I have some thick books in my bookshelf for that ;)
19:28:45 <suseROCKs> What?  You don't just go online and fill out a form that charges you $10,000 for a $25 process?  :-)
19:29:02 <rhorstkoetter> nope
19:29:04 <suseROCKs> prusnak,   any comments from you on the Foundation topic?
19:29:30 <rhorstkoetter> I read books and law papers
19:29:36 <prusnak> nothing in particular
19:29:39 <rhorstkoetter> old school approach
19:29:42 <rhorstkoetter> ;)
19:30:21 <suseROCKs> ok so, I think the final matter we should address is timeline?  Do we have a deadline for completing our draft of the bylaws?
19:30:55 <rhorstkoetter> aclark_: you currently collaboarte with henne on bylaws?
19:31:02 <rhorstkoetter> anyone else?
19:31:05 <suseROCKs> I suggest to make it more convenient for aclark_  that we impose a Dec. 26 deadline.
19:31:08 * suseROCKs ducks  :-)
19:31:14 <aclark_> haha
19:31:37 <rhorstkoetter> dec 26 sounds good to me
19:31:38 <aclark_> I'd rather get back to you on a date after I have met with Legal.
19:31:40 * rhorstkoetter hides
19:32:12 <rhorstkoetter> I should handle the filing investigation until dec 26th as well
19:32:17 <suseROCKs> lemme ask...  With Legal, is it to have them review what we've written or to seek recommendations from them on what needs to be in the bylaws?
19:32:21 <rhorstkoetter> maybe until next meeting
19:32:34 <prusnak> if we are picking deadline, i would suggest 19.12 not 26 :)
19:32:49 <rhorstkoetter> prusnak: brave man
19:32:55 <suseROCKs> prusnak,   There is no 19th month.  We only have 12 months in a year  :-P
19:33:03 <aclark_> I'm supposed to be meeting with them this week.
19:33:30 <prusnak> suseROCKs: export LC_ALL=en_GB.UTF-8
19:33:43 <suseROCKs> :-) prusnak
19:33:51 <rhorstkoetter> suseROCKs: we shouldn't miss a deadline to bring YOU back into rockstar business btw. just for the record :)
19:34:08 <suseROCKs> ok so let's wait to hear back from aclark_ after his meeting and then on our ML, we'll agree on a timeline when to finish what we need before next steps
19:34:09 <aclark_> bits of both.  It is to review the purpose of the foundation - to ensure that we are approaching the bylaws in the right manner
19:35:03 <rhorstkoetter> aclark_: so, you'll get in touch with us at board@o.o once you have it settled with novell legal? just to understand that
19:35:05 <aclark_> once I have met with them I'll email ya'll at boar@o.o
19:35:12 <rhorstkoetter> great
19:35:28 <aclark_> so I have the action item
19:36:08 <suseROCKs> aclark_,  While its probably way too early to ask...  we have seen public statements (via Conference) that Novell is in support of a Foundation.   It would be cool if Attachmate could also state such early on.   But I guess right now its still too early to ask them such a thing.
19:36:36 <aclark_> To early
19:36:44 <suseROCKs> #action aclark_ to confer with Legal team this week and reply to board@ with legal advice.   After that, board will determine timelines to complete bylaws and other items
19:36:55 <rhorstkoetter> aclark_: just wondering, would it be possible for ya to attend our meeting topic about foundation on a regular basis? it seems to me that we get forward faster that way and have an opportunity to discuss open questions in real-time?
19:37:31 <rhorstkoetter> scratch the last ?
19:37:44 <aclark_> yes, I have blocked my schedule for this meeting going forward
19:37:57 <suseROCKs> rhorstkoetter,   I think that's also a premature question  :-)   Soon enough we'll be having new board and that new board will redesignate the meeting times possibly.   Can't ask aclark_ for a commitment when we can't guarantee what time the meetings will be yet.
19:38:19 <suseROCKs> but at least for this month and next month we should be fine with our current schedule
19:38:43 <suseROCKs> ok I think we can close this topic now
19:39:01 <rhorstkoetter> aclark_: thanks for attending and taking the time
19:39:19 <suseROCKs> #topic openSUSE Board Meeting | Where do we need to improve?
19:40:03 <suseROCKs> So, I do have a topic on this matter, and wish henne and yaloki were here with their expertise on this matter, but first let's review how things are going with our product in openFATE
19:40:34 <rhorstkoetter> we already got some feedback on the news article I posted last week
19:40:38 <rhorstkoetter> see https://features.opensuse.org/statistic/product/opensuse.org
19:40:39 * warlordfff really like openFATE
19:41:23 <rhorstkoetter> particular interesting (discussed this with henne this morning) is https://features.opensuse.org/310661
19:41:53 <rhorstkoetter> IMO we should take care of that one. sounds like a very valid request to me
19:42:06 <rhorstkoetter> warlordfff: glad you like it
19:42:07 <suseROCKs> For reference everyone, our product in openFATE is here:
19:42:08 <suseROCKs> https://features.opensuse.org/query/run?search_string=&tag=&search_products[]=opensuse.org&search_status[]=unconfirmed&search_status[]=new&search_status[]=marketplace&search_status[]=implementation&search_status[]=done&search_status[]=rejected&search_status[]=duplicate&search_status[]=validation&type=find&commit=Search
19:42:44 <suseROCKs> well rhorstkoetter  before we even get into actual fixes... I think we should review a minute the functionality here
19:42:45 <warlordfff> Well make our community even more Democratic
19:43:13 <suseROCKs> as we stated in the last meeting, our initial concern would be educating people what is proper to put into this list and already I see a few that don't belong in this product list
19:43:52 <suseROCKs> left untamed, and as this feature becomes more popular to communicate to us with, this will spiral.   We should educate from the outset.   How do we approach?
19:45:40 <rhorstkoetter> suseROCKs: honestly I think this will be quite hard. I outlined very precisely what features/complaints we're interested in and where to file them but still most things show up in news.o.o, aren't valid etc
19:45:46 <warlordfff> well we could make a list of things we do with openFATE
19:45:53 <rhorstkoetter> I fear we need to live with that
19:45:58 <warlordfff> and things we don't
19:46:20 <warlordfff> in a wiki page maybe
19:46:23 <suseROCKs> warlordfff,   Well its not openFATE itself,  its the product category which is "opensuse.org" within openFATE
19:46:34 <warlordfff> ok
19:46:39 <suseROCKs> let me take a quick moment to explain our goal to warlordfff
19:46:46 <warlordfff> ok
19:47:00 <suseROCKs> We created this new topic here called "Where do we need to improve?" several months ago.
19:47:15 <rhorstkoetter> warlordfff: see http://news.opensuse.org/2010/11/23/where-do-we-need-to-improve/ for an explanation
19:47:19 <suseROCKs> And this is for "immediately fixable" stuff.  Not heavy-duty technical stuff.   More like... for example, infrastructure.
19:47:41 <suseROCKs> so that product tag "opensuse.org" serves as a suggestion box to the Board, and what we can do we try to fix it quickly
19:48:30 <rhorstkoetter> warlordfff: e.g. https://features.opensuse.org/310661 is a very good example of a valid request
19:48:31 <suseROCKs> that summarize it well?
19:49:01 <warlordfff> what I don't get is what you saw that don't belong in this product list
19:49:02 <warlordfff> ?
19:50:14 <suseROCKs> warlordfff,   Well for example earlier today (seems one of us has moved it to another product category) was a request to integrate GIMP with openOffice.
19:50:31 <suseROCKs> That's not under our purview
19:50:38 <warlordfff> oooooh
19:50:40 <warlordfff> ok
19:51:16 <warlordfff> well as rhorstkoetter we will have to live with that,but...
19:51:20 <rhorstkoetter> warlordfff: also at news.o.o comments (anyway the wrong place) there are request not fitting into what I described in the blog post
19:51:43 <suseROCKs> ok so, rhorstkoetter   back to 310661.   I agree with the argument stated as well.   So... how do we implement?
19:51:55 <suseROCKs> and openSUSE has google indexing problems elsewhere as well.
19:52:03 <rhorstkoetter> suseROCKs: we need to contact bugzilla admins
19:52:12 <rhorstkoetter> I'll take for that with henne
19:52:14 <suseROCKs> I think we need to go higher up
19:52:28 <suseROCKs> we need to do a complete birds eye overview of our indexability
19:52:37 <suseROCKs> let me give an example.
19:52:41 <rhorstkoetter> yes, but bugzilla isn't indexed at all
19:52:56 <suseROCKs> I subscribe to google alerts with several important keywords (including my own name hehe)
19:53:15 <suseROCKs> when I communicate on GNOME infrastructure, I usually see a google alert within minutes
19:53:35 <suseROCKs> when I communicate on openSUSE, I see a google alert in a few days... IF I'm lucky, but most times, not much
19:53:55 <rhorstkoetter> that maybe is due to your name
19:53:57 <rhorstkoetter> rofl
19:54:07 <suseROCKs> not just my name  :-P
19:54:24 <suseROCKs> and my name is pretty unique so it should index pretty quick
19:54:32 <rhorstkoetter> I'm just kidding
19:54:53 <suseROCKs> but you get my point that I have a long-standing belief that we generally aren't following good indexing practices.
19:55:05 <rhorstkoetter> I get your point
19:55:16 <suseROCKs> and thus a top-to-bottom approach needs to be made here rather than piecemeal per item
19:55:18 <rhorstkoetter> we certainly can improve SEO
19:55:46 <rhorstkoetter> while I second what you said, bugzilla is a special case
19:55:49 * manugupt1 would like to see that :)
19:55:59 <rhorstkoetter> robots.txt doesn't allow indexing at all
19:56:02 <suseROCKs> see which, manugupt1 ?
19:56:20 <manugupt1> SEO for openSUSE websites I have asked couple of times at opensuse-web
19:56:42 <suseROCKs> rhorstkoetter,   I wonder if thats an internal policy over at Novell because bugzilla also is used for Novell products
19:57:00 <rhorstkoetter> could be yes
19:57:03 <suseROCKs> which would serve as another argument why we want our own separate non-iChained infrastructure
19:57:06 <rhorstkoetter> we need to find out
19:57:30 <manugupt1> Even our wiki needs to be optimised better imo
19:57:42 <suseROCKs> ok so you want to take the action on this, rhorstkoetter?
19:57:43 <rhorstkoetter> the user appropraitely oulines that particularly bugzilla is important target for indexing
19:58:12 <suseROCKs> so is the wiki and so is the forum where many solutions are posted (similarly to posted on bugzilla)
19:58:20 <rhorstkoetter> everyone searches error codes in google and you'll always end up in launchpad + find quick workaround in comments of bug reports
19:58:25 <rhorstkoetter> not so for suse
19:58:36 <rhorstkoetter> that's pretty unfortunate to the user
19:58:49 <suseROCKs> sure,  i know that frustration well.  It marginalizes us
19:59:06 <rhorstkoetter> suseROCKs: it is. but wiki + forum is indexed, just bad SEO'd
19:59:09 <suseROCKs> and gives a false indicator to the world that we're going away, which we're not
19:59:15 <rhorstkoetter> as far as I can estimate
19:59:44 <suseROCKs> ok so we have two issues here:
19:59:50 <suseROCKs> 1.  bugzilla does not allow indexing
20:00:00 <suseROCKs> 2.  Overall openSUSE infrastructure is badly SEO'ed
20:00:10 <suseROCKs> that sum it up right?
20:00:14 <rhorstkoetter> that's it
20:00:32 <rhorstkoetter> let's write an email to novell admins to get feedback on 1
20:00:38 <prusnak> 1) i'm afraid we can't do anything, but there is a small chance we'll have a separate bugzilla for opensuse eventually
20:00:48 <suseROCKs> and manugupt1  has expressed his concerns in some groups about SEO.   manugupt1   What did you receive as feedback?
20:00:58 <rhorstkoetter> + post a request to opensuse-web because of (2) at first glance
20:01:16 <manugupt1> suseROCKs, I got they submitted to google analytics but nothing concrete
20:01:26 <manugupt1> but we can start it again..
20:01:37 <suseROCKs> submitting to google analytics wouldn't boost SEO
20:01:43 <rhorstkoetter> manugupt1: would you like to kick that off again
20:01:48 <rhorstkoetter> suseROCKs: +1
20:01:55 <rhorstkoetter> absolutely useless ;)
20:02:09 <prusnak> atm we are using google analytics, but we'll probably switch to some other solution
20:02:13 <manugupt1> I know that.. But yes again I can kick it off..
20:02:17 <manugupt1> quantcast
20:02:26 <suseROCKs> What we need is a team of SEO experts and I'm not sure we have any around this neck of the woods
20:02:28 <rhorstkoetter> prusnak: GA doesn't push SEO at all
20:02:39 <prusnak> i know, i noted that just for the record
20:02:49 <manugupt1> We can use keywords from GA
20:02:55 <manugupt1> as metatags
20:03:09 * rhorstkoetter looks at manugupt1
20:03:20 <prusnak> okay, but this discussion is getting offtopic
20:03:22 <rhorstkoetter> suseROCKs: you see our SEO expert next to us?
20:03:24 <rhorstkoetter> ;)
20:03:30 <suseROCKs> careful, manugupt1.   rhorstkoetter gets easily infatuated  :-)
20:03:35 <prusnak> please discuss this issue further on opensuse-web@
20:03:52 <manugupt1> Ok..
20:04:09 <suseROCKs> prusnak,   sure  it should be discussed in the proper forum.  What I wanted to get from manugupt1 was whether there was sufficient feedback on it when he talked about it before
20:04:17 <suseROCKs> whether people agreed or pushed back on it.
20:04:59 <rhorstkoetter> suseROCKs: fortunately
20:05:51 <rhorstkoetter> to get back on topic, I'll get in touch with henne what to do with bugzilla indexing
20:06:28 <rhorstkoetter> manugupt1: we'd appreciate if you'd again try to kick off SEO discussion at opensuse-web ml
20:06:31 <rhorstkoetter> ok?
20:06:53 <manugupt1> Fine with me
20:07:03 <rhorstkoetter> manugupt1: thx, apprciated
20:07:10 <suseROCKs> manugupt1,   and please let us know if there is good positive response to the issue.  If not, then we will look at how to escalate it
20:07:13 <suseROCKs> (and that's our fix!)
20:07:24 <manugupt1> Ok..
20:07:50 <suseROCKs> #action rhorstkoetter and henne to discuss how to make bugzilla indexing better and reach out to Novell admins on this matter
20:08:19 <suseROCKs> #action manugupt1 to communicate with opensuse-web@ on how to improve openSUSE infrastructure SEO and report back to us his findings.
20:09:18 <rhorstkoetter> prusnak: one more remark on GA
20:09:26 <rhorstkoetter> have you had a look at piwik?
20:09:30 <suseROCKs> ok I have a new topic under this topic but I fear you all will have to bear with me and my technical ignorance on this matter
20:09:44 <suseROCKs> rhorstkoetter,   I use piwik.  It's pretty rad in some ways and pretty sucky in a lot of ways
20:09:47 <rhorstkoetter> would be, from my perspective, a welcome FLOSS alternative to GA
20:09:53 <prusnak> rhorstkoetter: henne is investigating it, piwik is one of the options
20:10:00 <suseROCKs> and piwik development in my opinion isn't very reliable
20:10:01 <prusnak> and probably the best one
20:10:01 <rhorstkoetter> prusnak: IC
20:10:09 <suseROCKs> but I do know GNOME uses piwik
20:10:18 <rhorstkoetter> suseROCKs: I use it + like it
20:10:45 <suseROCKs> I use it in conjunction with GA
20:10:54 <suseROCKs> anyway... not for us to squabble about here
20:11:01 <rhorstkoetter> +1
20:11:08 <suseROCKs> we trust the implementers to make the best judgment
20:11:12 <rhorstkoetter> anything else on that topic?
20:11:18 <rhorstkoetter> suseROCKs: definitely
20:11:20 <suseROCKs> none from me, so I have a new one
20:11:55 <suseROCKs> the issue is in reqards to how to make proper packaging requests
20:12:27 <suseROCKs> yaloki,  and I talked about this yesterday and we were of the feeling that it wasn't very clear in our openSUSE Project how someone can request a package to be added
20:12:40 <rhorstkoetter> openFATE?
20:12:53 <rhorstkoetter> haven't done that personally
20:13:01 <suseROCKs> this can be a barrier, as I encountered yesterday, where a developer decides to use openSUSE as their development platform but only gets frustrated because packages he/she relies on are more available on other distros
20:13:18 <suseROCKs> and that person switched back to the other distro
20:13:41 <suseROCKs> and this will be a problem if our current strategy proposal goes to appeal to a broader developer community to come to openSUSE
20:14:33 <suseROCKs> rhorstkoetter,   I don't know if openFATE is the way to go
20:14:37 <suseROCKs> I don't think os
20:14:38 <suseROCKs> so
20:14:57 <suseROCKs> there's some confusion also about whether to send the email to packaging@ or to buildservice@  and both are subscription mailing lists
20:15:01 <rhorstkoetter> suseROCKs: so, I clearly see where you're coming from. what do you propose?
20:15:01 <suseROCKs> which further creates burden
20:15:36 <rhorstkoetter> I mean in order to improve the process and make it clearer to developers/requesters?
20:15:43 <suseROCKs> rhorstkoetter,   i'm not sure what to propose, other than a simple dropbox where people can say "I want this package" somewhere.   I was hopign both henne and yaloki would be here so we could properly explore as I don't package  :-(
20:16:15 <suseROCKs> everything in openSUSE now requires subscribing or logging in (iChain) and that's an additional barrier
20:16:32 <rhorstkoetter> suseROCKs: yes, I also think we need both yaloki + henne here. let's kick off a discussion about it at board@o.o
20:17:55 <suseROCKs> we probably have to do that.  unless prusnak can add some insights here?
20:19:10 <suseROCKs> Folks!  hang in there, we're about to enter the Question & Answer period...  just as soon as we finish this topic!
20:19:22 <prusnak> insights to what ?
20:19:46 <rhorstkoetter> prusnak: to the topic we're talking about :P
20:19:48 <prusnak> if you want a package then just package it
20:19:54 <suseROCKs> the matter of unclear procedure for requesting packages + the barriers that inhibit ease of request without going through "red tape" so to speak
20:20:07 <rhorstkoetter> prusnak: we talk about requesting packages
20:20:22 <rhorstkoetter> not packaging them
20:20:28 <prusnak> yes
20:20:33 <prusnak> but noone is going to do the package for you
20:20:52 <prusnak> we have had package wishlist for ages, it doesn't work that way
20:21:00 <suseROCKs> somewhere there's instructions to send the request to packaging@    but you have to subscribe to the list in order to do that
20:21:14 <rhorstkoetter> prusnak: then we urgently need to improve here
20:21:16 <suseROCKs> prusnak,   why did it fail?
20:21:22 <prusnak> (at least not now when we are struggling with manpower)
20:21:36 <rhorstkoetter> the solution cannot be to just accept the current status quo
20:21:38 <rhorstkoetter> IMO
20:22:03 <prusnak> providing a false expectation is not a solution
20:22:29 <suseROCKs> its not a question of status quo in my opinion, but how we look when we publicly implement our strategy and it implies a welcome environment for developers
20:22:31 <prusnak> there might be someone who has time, but in 99% cases it does not work unfortunately
20:22:43 <prusnak> and those who package only do care about their stuff
20:22:59 <suseROCKs> the "false expectation" is precisely the issue here
20:23:34 <suseROCKs> one thing I have said many times over the years is we *need* to educate more people on how to package
20:23:55 <suseROCKs> We have a knowledge gap here, that's for sure, and we can't close the manpower issue if we maintain the knowledge gap
20:24:22 <suseROCKs> we cannot remain a community totally dependent on Novell's resources.  That's unfair to Novell
20:24:45 <warlordfff> and to us ;-)
20:24:58 <dev001> ( a couple of real-world, written-in-noob-english, cradle-to-grave examples of OBS building would go a long way to that education )
20:25:37 <suseROCKs> dev001,   What I keep hearing (and I'm not a techie) is if you don't know how to write spec files, OBS isn't going to get you very far
20:25:54 <dev001> hence, my suggestion ...
20:26:35 <suseROCKs> so rhorstkoetter   you still there?
20:26:43 <rhorstkoetter> suseROCKs: certainly
20:26:55 <rhorstkoetter> I wait for dev001's suggestion
20:26:56 <suseROCKs> to me seems the solution here is a) first build up stronger education on OBS packaging
20:27:06 <suseROCKs> and then b) have more people available to respond to wishlist
20:27:10 <dev001> rhorstkoetter: look up ...
20:27:21 <prusnak> this all boils down to SUSE sucks in documenting things
20:27:31 <prusnak> this was and still is a big issue
20:27:42 <rhorstkoetter> dev001: I second your suggestion. we need manpower to do this
20:27:48 <suseROCKs> documenting / educating  -- tomato / to-mah-toe  :-)
20:27:58 <rhorstkoetter> tomatensalat
20:28:03 * rhorstkoetter likes that
20:28:16 <suseROCKs> That's not even a real word.  It's German!
20:28:17 * suseROCKs ducks
20:29:06 <rhorstkoetter> dev001: I fear that if such documentation isn't written in community effort it won't be there in a foreseenable future
20:29:17 <dev001> rhorstkoetter: re: manpower, agreed.  new users would be more likely to (i) learn, (i) start write-ups & contribution if we didn't treat them ... less than spectacularly.
20:29:22 <rhorstkoetter> suseROCKs: I'm German by nature
20:29:23 <suseROCKs> ok so we're not at an actual solution.  Even dev001's great suggestion isn't a solution yet unless we actually have someone to do it
20:29:52 <CarlosRibeiro> I believe we need to develop a kind of special universities/academy program to help OBS culture to reach students in the early phase of their graduations.
20:30:55 <rhorstkoetter> CarlosRibeiro: again manpower. don't get me wrong, these are brilliant suggestions and I feel just the same. question for me is "who stands up and actually does it + is able to do it"
20:30:58 <CarlosRibeiro> IMO our problem is most related with culture than skills on how to package things
20:31:01 <mrdocs> suseROCKs: one other issue is domain (sort of) experts like me who use OBS, is it also woefully behind the docs curve
20:31:28 <manugupt1> I agree with rhorstkoetter man power and to write a simple doc it takes a lot of time
20:31:45 <mrdocs> even for someone like me who uses it daily is sometimes lost... it is changing/maturing/more featurefull quickly
20:31:48 <suseROCKs> mrdocs is behind the docs curve?  :-)
20:31:53 <suseROCKs> (couldn't resist)
20:31:56 <dev001> obs is one of the most powerful tools we have, it's a unique advantage that differentiates us from *every* other distro, it's a great way to attract/retain users/contributors, once used, it benefits the ENTIER community -- and we wholly underutilize it, hiding behind "expertise".
20:31:59 * mrdocs nods and grins
20:32:24 <prusnak> so where do we get people to document OBS and packaging?
20:32:45 <mrdocs> prusnak: i've volunteered to do some this month
20:32:46 <prusnak> or how do we motivate existing members of our community to do so ?
20:32:49 <suseROCKs> I say first, focus on documenting.  Then afterward we can focus on packaging
20:32:54 <mrdocs> yes
20:32:58 <rhorstkoetter> suseROCKs: what we may try (and may fail) is get in touch with OBS people at opensuse-buildservice, explain the urgent issue, the consequences by not providing sufficient docs and the opportunities we have by providing docs
20:33:01 <suseROCKs> so maybe for now, we put a call out to have a OBS Documentation Collaboration Day?
20:33:04 <warlordfff> τηε Γρεεκ ψομμθνιτυ ψαν τακε α παρτ οφ ιτ
20:33:12 <warlordfff> sorry
20:33:22 <prusnak> rhorstkoetter: OBS team will not document anything
20:33:28 <prusnak> they have lots of other stuff on their plate
20:33:32 <suseROCKs> rhorstkoetter,  That's not something those folks haven't heard already.   As prusnak pointed out, its a resource issue for them
20:33:34 <mrdocs> prusnak: exactly
20:33:42 <rhorstkoetter> that's the only thing I can think of currently. then hope for a altruistic soul helping out
20:33:50 <warlordfff> the Greek community can take a part of documenting OBS
20:34:12 <warlordfff> I have a couple of people who are interesting in it
20:34:18 <suseROCKs> so?  Should we call out for a OBS Documentation Collaboration Day (or week or?) ?
20:34:28 <rhorstkoetter> folks, it's a hen and egg problem
20:35:01 <suseROCKs> no it isn't
20:35:03 <CarlosRibeiro> I beleive after I talk with Ricardo that is owner of one important University in Brazil, we will be able to get some students from that university to give us a hand on OBS documentations too.
20:35:04 <prusnak> suseROCKs: i like your idea
20:35:05 <rhorstkoetter> warlordfff: and a couple of people knowledged to write docs for interested parties
20:35:07 <rhorstkoetter> ?
20:35:18 <suseROCKs> Documentation first!   then let the rest of the chips fall where they may
20:35:36 <dev001> suseROCKs: b4 calling "a Day", i suggest pick ONE example.  say a server pkg, like Apache httpd.  something big-ish, and familiar.  do a complete example 'series' -- build native & opensuse-derived, @ obs-client & @ obs-web.
20:35:41 <warlordfff> yes i believe so they are programmers,I'll contact them
20:35:55 <warlordfff> but with whom I contact then?
20:35:58 <dev001> document ONT thing 1st.  do it really well.  BEFORE rinse-n-repeat ....
20:36:24 <warlordfff> give me an e-mail to give them
20:36:53 <warlordfff> and talk about it
20:36:54 <suseROCKs> CarlosRibeiro,   ok so when we have this collaboration period, please do welcome them to participate
20:37:07 <suseROCKs> but before that, now we need a volunteer to comandeer this Collaboration process
20:37:21 <rhorstkoetter> take a quick breeze to summarize please
20:37:24 <rhorstkoetter> aligned?
20:37:35 <rhorstkoetter> 1. collaboration Day
20:37:47 <suseROCKs> or week or month,  depends.
20:37:51 <rhorstkoetter> suseROCKs: any detailed explanation?
20:38:07 <rhorstkoetter> just raw details
20:38:21 <suseROCKs> Someone with a reasonable level of expertise in OBS should lead this project.   and determine the timeline of the collaboration
20:38:37 <suseROCKs> obviously it can't be me cuz I don't know all the puzzle pieces  :-)
20:38:44 <rhorstkoetter> same here
20:38:44 <warlordfff> rhorstkoetter can you give me an e-mail to give the people from the Greek community to contact for further information about writing Documentation about OBS?
20:39:05 <rhorstkoetter> warlordfff: I'll get to that in a few
20:39:08 <warlordfff> ok
20:39:09 <suseROCKs> mrdocs,  dev001   Interested in taking the lead on this?
20:39:54 <suseROCKs> this is the moment of typical silence  :-D
20:40:08 <dev001> suseROCKs: I have zero success in using OBS to build a single thing.  i have no obs-fu, apparently.  i build what i need from native source -- far simpler.
20:40:12 * prusnak has to go now
20:40:15 <prusnak> o/
20:40:25 <suseROCKs> ok prusnak   thanks man!
20:40:31 <rhorstkoetter> prusnak: thx for attending
20:40:40 <suseROCKs> then it looks like mrdocs is going to be our victim!  ;-)
20:40:52 <rhorstkoetter> looks like
20:40:55 <suseROCKs> good opportunity for you to strut your stuff mrdocs if you're running for board
20:41:13 <dev001> i'd volunteer darix, as he seems to speak in obs-tongues, at times, but he gets typically grumpy when you volunteer 'im for stuff ;-)
20:41:30 <mrdocs> dev001: no darix is too busy/important
20:41:38 <suseROCKs> darix is an extremely taxed man with his time.  I'd feel bad asking him to lead a big thing like this
20:41:46 <mrdocs> and I am a native English speaker/writer
20:41:51 <mrdocs> so sign me up
20:41:59 <suseROCKs> We have a volunteer!!!
20:42:16 <suseROCKs> #action  mrdocs to organize collaboration efforts to document OBS
20:42:24 <mrdocs> suseROCKs: i was going to work on it this month anyways.. long a promise to Adrian
20:42:30 <rhorstkoetter> warlordfff: did I get you right that you may encourage parts of the greek community to write docs on their own?
20:42:35 <mrdocs> but extra help is welcome
20:42:38 <mrdocs> and
20:42:50 <warlordfff> rhorstkoetter yes
20:42:58 <mrdocs> warlordfff: IRC is far more important for OBS than the mail list FYI
20:42:59 <manugupt1> One question
20:43:14 <warlordfff> well
20:43:28 <mrdocs> tho there is a list
20:43:30 <warlordfff> so what do I tell them?
20:43:36 <rhorstkoetter> mrdocs: but written docs urgently need to complement real-time support
20:43:57 <suseROCKs> wait for mrdocs to figure out how he wants to organize it and he'll reach out to all of us to tell us what the plans are
20:43:58 <rhorstkoetter> it cannot substitute that
20:44:06 <manugupt1> My question is while we join these collaboration thing will it be possible for people like me to learn OBS (zero experience)
20:44:26 <mrdocs> manugupt1: yes.. start simple
20:44:36 <suseROCKs> manugupt1,   again,  wait for mrdocs to figure out and organize and plan it  and he can give us the details
20:44:44 <suseROCKs> for now...  we just dropped it in his lap  :-D
20:44:47 <manugupt1> Yes...
20:45:02 <rhorstkoetter> mrdocs: do you see opportubities to get the volunteering greek community organized for writing wiki docs
20:45:04 <rhorstkoetter> ?
20:45:05 <mrdocs> read the tutorials... ask questions which are not clear.. hang in #opensuse-buildservice
20:45:15 <rhorstkoetter> I mean in complementing your efforts?
20:45:15 <mrdocs> rhorstkoetter: surely
20:45:44 <mrdocs> sometimes the issue with docs is the writer know the subject too well
20:45:45 <mrdocs> so
20:45:57 <mrdocs> assumes the reader has the same domain knowledge
20:46:19 <mrdocs> therefore real begginners can be excellent proof readers
20:46:22 <suseROCKs> ok so mrdocs will inform us, and i believe that concludes this topic
20:46:22 <mrdocs> and
20:46:28 <rhorstkoetter> mrdocs: I'd just like to take up warlordfff on his offer immediately
20:46:45 <mrdocs> rhorstkoetter: +10 from me
20:46:45 <rhorstkoetter> to you see an issue for a parallel effort by the greek community
20:46:49 <rhorstkoetter> ?
20:46:51 <suseROCKs> rhorstkoetter,   as well as the offer by Carlos to bring in those students in Brasil who know about OBS
20:47:10 <rhorstkoetter> i.e. do we need to sync or may they get immediately started without blocking your initiative?
20:47:17 <suseROCKs> CarlosRibeiro, ^^
20:47:18 <rhorstkoetter> suseROCKs: certainly
20:47:18 <warlordfff> ok so mrdocs after the meeting lets talk for a while ok?
20:47:39 <CarlosRibeiro> ;-)
20:47:47 <mrdocs> warlordfff: im here for 3+ hours
20:48:02 <suseROCKs> ok so I'm going to close this topic and move on to the final topic of the day....
20:48:02 <rhorstkoetter> warlordfff: you know, you don't need a upper entity to talk to for starting this initiative
20:48:14 <mrdocs> suseROCKs: next topic ?
20:48:20 <warlordfff> ok
20:48:23 <rhorstkoetter> just organize it and form a team to write the docs
20:48:24 <suseROCKs> #topic openSUSE Board Meeting | Topic:  Q&A
20:48:50 <manugupt1> Ok..
20:48:51 <rhorstkoetter> but as mrdocs rightly outlined, take care that it's written for people that never used OBS
20:48:59 <manugupt1> I recieved a mail right now from them
20:49:00 <suseROCKs> Does anyone have any questions in general that brilliant guys like me and rhorstkoetter can answer?
20:49:28 <manugupt1> Guys opensuse-web has repied I will put it now if you want it
20:49:54 <manugupt1> Should I put the repy over here
20:49:56 <suseROCKs> that was fast... It must have been highly SEO-ed
20:50:02 <manugupt1> ;)
20:50:04 <manugupt1> There was another discussion a few months ago that I responded on, but I haven't heard much back.  I can tell you what I have done for the wikis, and maybe someone who knows SEO can add some input.
20:50:04 <manugupt1> I have set up Google Webmaster Tools on www and all the wikis
20:50:04 <manugupt1> * I have created a cron that updates all the sitemaps daily with new and updated content for the wikis
20:50:04 <manugupt1> * The only suggestion given by the webmaster tools console is to remove duplicate titles, of which there are quite a few
20:50:06 <rhorstkoetter> ;)
20:50:06 <manugupt1> * I did just notice that robots.txt is missing out of all the wikis, so I'm fixing that now.  It shouldn't have affected anything too much.
20:50:10 <manugupt1> * -Matt
20:50:38 <suseROCKs> nah
20:50:39 <dev001> suseROCKs: What... is the air-speed velocity of an unladen swallow?
20:50:58 <suseROCKs> dev001,   i don't know.  I eat too fast to swallow properly
20:51:10 <dev001> yukyuk
20:51:18 <suseROCKs> didn't expect that answer, did you?
20:51:28 <suseROCKs> manugupt1,   That's not going to help much with SEO either
20:51:52 <suseROCKs> I use webmaster tools too, and it helps with getting pages up that aren't properly indexed.  But it still doesn't answer the SEO quesiton itself
20:51:55 <manugupt1> suseROCKs, I think we submit our site indexes to more search engines we add that
20:52:09 <manugupt1> Again metatags should be taken care of
20:52:27 <suseROCKs> remember, SEO isn't about getting indexed.  It's about being *visible* in the index
20:53:21 <manugupt1> Yes.
20:53:26 <suseROCKs> ok so we have no questions except for the one I answered properly to dev001
20:53:37 <suseROCKs> rhorstkoetter, any objections to closing the meeting?
20:53:46 <rhorstkoetter> nope
20:53:54 * rhorstkoetter talking to warlordfff
20:54:33 <suseROCKs> Thank you all for your wonderful participation in today's Board meeting.
20:54:51 <suseROCKs> We truly appreciate this very democratically open dialogue we have today.
20:54:58 <suseROCKs> See you all in two weeks at the next Board meeting!
20:55:02 <suseROCKs> #endmeeting