14:33:27 <AJaeger> #startmeeting Welcome to the openFATE screening Team meeting
14:33:27 <bugbot> Meeting started Thu Nov 25 14:33:27 2010 UTC.  The chair is AJaeger. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:33:27 <bugbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:33:42 <AJaeger> I'm very sorry that I'm 30mins late on this one ;-(
14:33:53 <AJaeger> I have written as agenda items:
14:34:00 <AJaeger> 1. How to handle openSUSE distribution (see Stano's email)?
14:34:01 <AJaeger> 2. How to handle openSUSE 11.4?
14:34:14 <AJaeger> 3. Using openFATE - questions on workflow and usage
14:34:23 <AJaeger> 4. Q&A
14:34:38 <AJaeger> Anything else to add to the agenda right now?
14:35:05 <AJaeger> #topic How to handle openSUSE distribution?
14:35:58 <AJaeger> So, should we use the Bucket idea and as such enhance openFATE that you can only create features with the generic bucket - and we then later mvoe them to e.g. openSUSE 11.4?
14:36:20 <AJaeger> Stano could you explain briefly the Bucket idea?
14:37:02 <Stano> The whole idea is to avoid 'postponing' features and better follow the real development model
14:37:24 * AJaeger is also tired of cleaning up 11.3 features now ;)
14:37:37 <Stano> This is how I see a feature lifecycle in high-level:
14:38:21 <Stano> 1) someone has a great idea - typically 2-3 sentences
14:38:40 <HeliosReds> I also think Bucket is a good idea.
14:38:59 <Stano> 2) the idea needs to be clarified, looked at from different perspectives, etc
14:39:18 <AJaeger> digitltom: can we implement in openFATE such that people request for "openSUSE distribution" and cannot add 11.4 directly?
14:39:58 <Stano> 3) it's almost clear what is needed to be done, only then we can work on the feature (in openSUSE, this is more importantnly integration)
14:40:39 <Stano> only in step 3) we can reasonably figure out which openSUSE release can have the idea implemented
14:40:43 <digitltom> AJaeger:  we can do this, but who should be able to add 11.4 and with which client?
14:41:10 <AJaeger> digitltom: Add it with openFATE in a second step?
14:41:17 <Stano> digitltom: ideally, only status Ready/Marketplace, Implementation and Done can have openSUSE 11.4
14:42:52 <HeliosReds> And there may be deadline for each release.
14:43:03 <digitltom> should be possible
14:43:12 <digitltom> deadlines are already there
14:45:16 <AJaeger> So, consensus? Then let's ask digitltom to drive implementation...
14:45:39 <Stano> yes from my side :-)
14:45:48 <HeliosReds> If the feature is just a minor enhancement, it can be for 11.4, but if it's somehow 'big', it should be for 11.5 (or 12.0?)
14:46:14 <AJaeger> HeliosReds: YEs, depending on the time we evaluate it ;)
14:48:23 <AJaeger> #action digitltom to implement product "openSUSE distribution" bucket for new features so that we do not have to postpone every feature
14:48:35 <AJaeger> ok, next topic:
14:48:40 <AJaeger> #topic How to handle openSUSE 11.4?
14:49:10 <AJaeger> WE have 200+ unconfirmed features in openSUSE 11.4 and I would like to figure out the "good" ones asap.
14:50:09 <Stano> AJaeger: well, we have to get our hands dirty
14:50:31 <AJaeger> My idea would be that we all go through them and get our hands dirty and - either postpone (put them into the bucket) or move them forward.
14:52:00 <Stano> AJaeger: can you remind me how much time we have left for features in 11.4?
14:52:49 * AJaeger just checks http://www.suse.de/~coolo/opensuse_11.4/
14:53:00 <digitltom> AJaeger:  the product database has no feature deadline yet, i need to set this
14:53:45 <AJaeger> Milestone5 is on 16th December and "feature complete" - so basically, we're already too late ;-(
14:55:46 <AJaeger> So, that's 3 weeks of development from now on since checkin deadline for M5 is the 13th.
14:58:59 <digitltom> AJaeger:  ok, i've set the feature deadline
15:00:00 <AJaeger> So, what should we do with features?
15:00:12 <AJaeger> Cleanup the list and add the generic bucket?
15:00:19 <Stano> yes, when it's ready
15:01:09 <AJaeger> There only a few we can really move forward - my proposal would be to start now the stuff for 11.5?
15:01:22 <Stano> yes, that's the only sane thing to do
15:01:43 <AJaeger> BUT: I plan to go through the complete list and cherry pick a handful that I push through for 11.4 - and if you have a handfull, add them as well..
15:02:24 <AJaeger> ok?
15:02:59 <HeliosReds> IMHO, we should review high-scored features first.
15:03:11 * Spyhawk just realized that he's one hour late :]
15:03:22 <AJaeger> Welcome Spyhawk! WE started 30mins late ;)
15:03:26 <Stano> AJaeger: definitely
15:03:32 <AJaeger> Spyhawk: so, you're only 30mins late..
15:03:36 <Spyhawk> so I'm only helf late :]
15:04:07 <AJaeger> HeliosReds: Yes, high-scored is something...
15:04:32 <AJaeger> ... to look at
15:04:56 <AJaeger> digitltom: Can I search for features with say more than 20 scores?
15:05:14 <HeliosReds> https://features.opensuse.org/preview/query/run?order=score&search_products[]=22236&type=find
15:05:20 <digitltom> AJaeger:  you can search for 11.4 and order by votes
15:05:22 <AJaeger> HeliosReds: Thanks!
15:05:37 <HeliosReds> Then click Score.
15:05:48 <AJaeger> Ok, so, I propose:
15:06:12 <AJaeger> We all try to push the features with  a score higher than 20 forward for 11.4.
15:06:44 <AJaeger> We go briefly through others and check for features to move forward (each of us only a few) for 11.4
15:06:50 <AJaeger> We move everythign else to the bucket
15:07:12 <AJaeger> We find experts that handle the features in the state new
15:07:37 <AJaeger> and have them evaluate and push to "Marketplace" - and we tell people about those features...
15:08:03 <simon123> https://features.opensuse.org/preview/310229
15:08:10 <AJaeger> Sound like a plan?
15:08:14 <simon123> that is below your radar
15:08:25 <Spyhawk> yup, souds good
15:08:34 <Spyhawk> simon123: I guess we also need to use common sense
15:08:47 <Spyhawk> or quickly find two people to vote for the feature :]
15:08:50 <AJaeger> simon123: As I've said "Go briefly through others"
15:08:55 <simon123> ok
15:09:17 <AJaeger> simon123: So, if you think that feature should be in 11.4, move it forward - just do so ;)
15:09:39 <AJaeger> simon123: But for those under the radar: Select only a handful ;)
15:10:14 <simon123> where that can be published (after the meeting)
15:10:47 <AJaeger> simon123: What do you mean?
15:11:13 <AJaeger> Anybody wants to send out a call for "domain experts" to the other teams?
15:13:08 <AJaeger> OK, then I'll do that.
15:13:21 <AJaeger> #action AJaeger to send out a call for "domain experts" to evaluate features
15:13:41 <Stano> AJaeger: how do we find out the domains?
15:13:58 <HeliosReds> For example, who can be the "domain experts" for https://features.opensuse.org/preview/310229 ?
15:14:14 <simon123> AJaeger: feature 310299 is already 11.4 , but I have strong feeling that NTFS mount must be trivial task (at least) so how to give you a note, or list of features that might be overlooked and are important
15:14:29 <AJaeger> Stano: http://en.opensuse.org/openSUSE:Openfate_screening_process#Tags
15:14:49 <AJaeger> So, we add a tag to each feature - and a domain expert looks at features with a certain tag.
15:15:15 <AJaeger> HeliosReds: That one could be base_system
15:16:11 <HeliosReds> I've just added. ;-)
15:18:09 <AJaeger> simon123: What we need is general speaking about features IMO - I don't want to push every single feature
15:18:37 <AJaeger> so, let's add further tags if we need them to the list of tags - so that we can then add "domain experts" to the tag list
15:18:57 * simon123 gives a Medal of Clear Talk to HeliosReds for http://en.opensuse.org/File:OpenFATE_feature_handling_flow.png
15:19:27 * AJaeger claps as well
15:19:54 <simon123> AJaeger: that particular one is low hanging fruit, not much work to implement
15:20:50 <AJaeger> simon123: Yep.
15:21:40 <AJaeger> simon123: Also move the feature to NEW.
15:21:49 <AJaeger> (or whoever just added the tag)
15:22:43 <Spyhawk> ok, then... anything else to discuss?
15:23:34 <simon123> AJaeger: I'm not sure that I can change anything - never applied to be a screener
15:23:53 <AJaeger> simon123: Everybody is allowed to change - like in Bugzilla.
15:23:58 <simon123> ok
15:24:19 <AJaeger> But I agree, the screeners should do it - so if you want to join us, just sign up ;)
15:24:41 <simon123> (where :D )
15:24:58 <simon123> I still don't see how to change status
15:25:05 <AJaeger> simon123: http://en.opensuse.org/openSUSE:Openfate_screening#Participants
15:25:59 <Spyhawk> simon123: "Edit products" on features.opensuse.org/preview/<number>
15:26:37 <simon123> done
15:26:48 <simon123> (both)
15:26:49 <AJaeger> ok, topic closed?
15:27:15 <HeliosReds> simon123: Then, click left yellow box.
15:27:34 <AJaeger> #topic Using openFATE - questions on workflow and usage
15:28:10 <AJaeger> Any questions comments on workflow and using the webui?
15:31:49 <simon123> obvious one: Can we have few more words more instead of icons +tooltips
15:32:26 <simon123> I didn't find how to edit feature status without help
15:34:23 <AJaeger> simon123: So, a visual guide or just words in the Webui?
15:34:46 <simon123> at least word next to icon
15:34:49 <digitltom> simon123:  don't you have the link 'edit products'?
15:34:58 <digitltom> that's 2 words ;-)
15:35:22 <digitltom> simon123:  we are talking about the new client on features.opensuse.org/preview/
15:35:30 <simon123> yes
15:35:46 <simon123> I have link  'edit products' , but after that I have only two icons with tooltips
15:36:00 <digitltom> ah ok
15:36:40 <simon123> btw, can you make /preview actual default for server /
15:36:53 <simon123> to me it looks fine
15:37:11 <digitltom> that's what we want to decide in this meeting, if it's ready yet
15:37:18 <digitltom> i think so, too
15:37:39 <AJaeger> Ok, then let
15:37:58 <AJaeger> Ok, then let's ask: Should we move /preview into production? Any blockers?
15:38:43 <simon123> It looks much better then the old one
15:39:05 <AJaeger> And we can continue improving it...
15:39:16 <AJaeger> So, any body objecting?
15:39:44 <AJaeger> If not, I suggest digitltom, jos and myself write an announcement announcing the new version and we do the switch...
15:40:30 <HeliosReds> AJaeger: +1
15:40:46 <AJaeger> #action AJaeger, digitltom: Coordinate writing of announcement of new openFATE version and put preview into production
15:41:07 <AJaeger> #topic Q&A
15:41:13 <AJaeger> Any further questions, comments, ideas?
15:41:19 <AJaeger> If not, let's push features around ;)
15:42:34 <simon123> where do we communicate after the meeting. I have a questions about particular features
15:43:30 <HeliosReds> -project list?
15:43:41 <simon123> good for me
15:43:44 <AJaeger> Should we just use a pirate pad where people can add features they have problems with? And then others clean up...
15:44:29 <Spyhawk> fine to me.
15:44:38 <simon123> what I need right now is consent what to do - pad will not solve that
15:44:56 <simon123> besides :) https://features.opensuse.org/preview/310652
15:46:39 <AJaeger> simon123: Then let's discuss on opensuse-project.
15:46:47 <simon123> ok
15:46:59 <AJaeger> And if there's too much need for discussion, we create our own mailing list...
15:47:09 <Stano> :-D
15:47:18 <simon123> (oh no)
15:48:36 <simon123> project list is fine :)   (just no another corner where no one looks at)
15:49:54 <AJaeger> ok, can we close the meeting? I try to be available on #opensuse-project if you have any questions - and digitltom is as well ;)
15:50:36 <HeliosReds> It might be helpful to add [FATE] or [openFATE] to the subject, when we post an openFATE-related email to -project list.
15:50:43 <Stano> no furher comments or questiosn from me
15:51:09 <Stano> digitltom: will you send us a mail when bucket product is ready?
15:51:33 <simon123> HeliosReds: good idea (if not forgotten)
15:52:36 <AJaeger> HeliosReds: Let'S use [openFATE]
15:53:10 <HeliosReds> OK.
15:53:31 * Stano has to leave now
15:53:47 <AJaeger> Bye STano!
15:53:48 * simon123 too (Have a fun)
15:54:02 <Stano> bye all!
15:54:03 <AJaeger> Thanks a lot for the meeting - let's meet again in two weeks!
15:54:05 <AJaeger> #endmeeting