15:08:13 <suseROCKs> #startmeeting Marketing Team Artwork Gathering Hackfest  17-June-2011
15:08:13 <bugbot> Meeting started Fri Jun 17 15:08:13 2011 UTC.  The chair is suseROCKs. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:08:13 <bugbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:08:20 <suseROCKs> #chair manugupt1
15:08:20 <bugbot> Current chairs: manugupt1 suseROCKs
15:08:34 <suseROCKs> ok manugupt1   You're in charge  :-)
15:08:44 <manugupt1> Ok.. so lets move with the topics
15:08:52 <manugupt1> suseROCKs: can you list out the topics
15:09:18 <manugupt1> please as I need to open up my mail which will take a whole lot of time
15:10:01 <suseROCKs> ok  let me go ahead and summarize the purpose of this hackfest...
15:10:14 <manugupt1> thanks
15:10:33 <suseROCKs> #info  Hackfest Purpose:  To gather up and organize our artwork related to marketing needs and organize our artwork repository
15:10:51 <suseROCKs> Areas of concern:
15:11:04 <suseROCKs> People have lots of artwork, but it is not stored centrally
15:11:17 <suseROCKs> Documentation on how to use git needs review
15:11:34 <suseROCKs> Artwork Repository needs to be reviewed and organized if necessary
15:13:05 <suseROCKs> manugupt1,   Does that sum it up well?
15:13:12 <manugupt1> suseROCKs: yes
15:14:05 <manugupt1> Anyone here and has any sort of artwork?
15:14:34 <suseROCKs> The channel is really quiet.  No one responded a few mins ago, so it looks like just you and me
15:14:41 <suseROCKs> So we have limited stuff we can do
15:14:55 <manugupt1> suseROCKs: Ok.. then lets organise the repository
15:14:59 <suseROCKs> I suggest the following
15:15:04 <suseROCKs> 1.  Organize repo
15:15:11 <suseROCKs> 2.  Review documentation on how to use git
15:15:28 <suseROCKs> 3. Send out an email asking people to follow the documentation and add their works via git push
15:15:32 <suseROCKs> (or whatever the command is)
15:15:59 <manugupt1> suseROCKs: Ok
15:16:51 <suseROCKs> I'm doing a git pull right now
15:17:06 <manugupt1> suseROCKs: same here
15:17:50 <suseROCKs> hmm  lots to pull  :-)
15:18:59 * suseROCKs should have done this before the meeting  :-/
15:19:56 <manugupt1> suseROCKs: Mine is a bit but terrible net connection
15:20:07 <manugupt1> Mine is upto date :)
15:20:34 <suseROCKs> well we can go ahead and talk while my git pull is working
15:20:56 <suseROCKs> I think we should have an archive folder to store past works for reference.
15:21:13 <suseROCKs> For example, posters made for specific events should be stored so we can look at them for ideas for future event posters
15:21:43 <manugupt1> suseROCKs: Hmm... as of now everything is generic imo
15:21:49 <manugupt1> as I see in the repository
15:22:16 <suseROCKs> Right
15:22:26 <suseROCKs> we should be all-encompassing there
15:22:36 <manugupt1> Even the artwork is generic suseROCKs
15:23:05 <suseROCKs> that's what you just said  :-)
15:23:35 <manugupt1> I mean to say they are in proper positions
15:24:01 <manugupt1> And I cannot see a poster for events
15:24:56 <suseROCKs> well what I'm saying is we should create a folder for that.   maybe call it Events folder
15:25:14 <suseROCKs> ahh my git pull is done
15:25:23 <manugupt1> Ok.. that can be done.. only that git does not offer empty gfolders
15:26:29 <suseROCKs> what is ambassadorphotosforresuse?
15:26:53 <manugupt1> suseROCKs: these are some photos for ambassasbdors
15:27:04 <manugupt1> which can be used in brochures and other places
15:27:12 <manugupt1> Some real photos
15:28:11 <suseROCKs> the title of that folder should be renamed then
15:28:14 <suseROCKs> its an unclear title
15:29:43 <manugupt1> Sure..
15:29:43 <manugupt1> Please do it
15:29:46 <suseROCKs> manugupt1,   are we able to rename folders?  If so, let's just call it ambassador-photos
15:30:07 <suseROCKs> manugupt1,   do you have administrative access to the git?
15:30:25 <manugupt1> Or suggest a name
15:30:33 <suseROCKs> I just did  :-)
15:30:45 <manugupt1> Yes
15:30:45 <manugupt1> i am doing the change
15:31:22 <manugupt1> suseROCKs: I have I guess but I cloned the read only url so I am checking it once I agein
15:31:40 <manugupt1> Did you push it too
15:31:57 <manugupt1> Push it so that I can pull it too
15:32:02 <suseROCKs> no I didn't push it
15:32:19 <suseROCKs> hmm  why isn't tigerfoot participating in this hackfest?  -)
15:32:46 <suseROCKs> git push is a confusing command for me  :-)
15:32:59 <tigerfoot> because tigerfoot has work hard all the day, and need to go to the shop
15:33:12 <manugupt1> git push origin master
15:33:18 * suseROCKs hopes tigerfoot doesn't mean he is going to photoshop
15:33:34 <manugupt1> tigerfoot: how can you go to shop after working ?
15:33:43 <suseROCKs> tigerfoot,   do you have any artwork to push?
15:33:43 <tigerfoot> nope going to bring at home my 16GB ram for the new lappy next week
15:33:49 <manugupt1> You go to home after working right?
15:34:33 <manugupt1> tigerfoot: You always make people jealous with that kind of hw
15:34:35 <tigerfoot> suseROCKs: nope ... the presentation I did for Patras is just a copy paste of existent material, and has been pushed to patras orga
15:34:54 <suseROCKs> manugupt1,   so just rename the folder and then do git push origin master?
15:34:54 <tigerfoot> manugupt1: for sure, I buy a rocket laptop ...
15:35:06 <tigerfoot> git rename has to be used
15:35:28 <suseROCKs> tigerfoot,   ok  how do you rename a git folder exactly?
15:35:36 <manugupt1> tigerfoot: there is no such comamnd
15:35:45 <manugupt1> suseROCKs: do a git status
15:35:48 <manugupt1> what does it show
15:36:22 <suseROCKs> manugupt1,   git status says  "Single and looking for LTR"
15:36:24 <suseROCKs> :-)
15:36:34 <tigerfoot> manugupt1: sorry alias here, git mv (mv         Move or rename a file, a directory, or a symlink)
15:37:16 <manugupt1> Hmm...
15:37:19 <tigerfoot> if you do it outside of git, it will be a real pain, i't like create a new one, git add + add everything in it, push, pull, delete, push
15:37:40 <suseROCKs> git sure is confusing
15:37:51 <manugupt1> Ok.. tigerfoot I got you
15:37:55 <manugupt1> suseROCKs: There are 4 steps
15:38:11 <manugupt1> that will always work for you
15:38:14 <manugupt1> git status
15:38:24 <manugupt1> It will show if there are changes to your repository
15:38:31 <manugupt1> then if there are changes do a
15:38:33 <manugupt1> git add .
15:38:35 * tigerfoot think my mirror willl suffer from that meeting :D
15:38:43 <manugupt1> tigerfoot: naa
15:38:56 <manugupt1> after that do a git commit add -a
15:38:59 <tigerfoot> comment everything, it's important to see the why/who/how
15:39:03 <suseROCKs> On branch master
15:39:03 <suseROCKs> # Changed but not updated:
15:39:03 <suseROCKs> #   (use "git add/rm <file>..." to update what will be committed)
15:39:03 <suseROCKs> #   (use "git checkout -- <file>..." to discard changes in working directory)
15:39:03 <suseROCKs> #
15:39:04 <suseROCKs> #	deleted:    ambassadorphotosforresuse/09042011011.jpg
15:39:06 <suseROCKs> #	deleted:    ambassadorphotosforresuse/1.jpg
15:39:09 * tigerfoot will be able to uncommit after :D
15:39:09 <suseROCKs> #	deleted:    ambassadorphotosforresuse/3.jpg
15:39:12 <suseROCKs> #	deleted:    ambassadorphotosforresuse/DSC_7501.JPG.html
15:39:14 <suseROCKs> #
15:39:16 <suseROCKs> # Untracked files:
15:39:18 <suseROCKs> #   (use "git add <file>..." to include in what will be committed)
15:39:20 <suseROCKs> #
15:39:22 <suseROCKs> #	ambassador-photos/
15:39:24 <suseROCKs> #	slides/11.4-release-draft.odp
15:39:26 <suseROCKs> #	slides/11.4-release.odp
15:39:27 <manugupt1> good suseROCKs
15:39:28 <suseROCKs> no changes added to commit (use "git add" and/or "git commit -a")
15:39:31 <tigerfoot> suseROCKs: did you forget susepaste ?
15:39:35 <manugupt1> lols
15:39:53 <suseROCKs> well I could have done that, but since we have very few people in today's hackfest, i wanted our log to be larger!
15:40:10 <manugupt1> Lols
15:40:39 <manugupt1> Ok.. so you need to add this file
15:40:46 <manugupt1> so to do that you will do a git add
15:40:47 <manugupt1> the command is
15:40:47 <manugupt1> git add .
15:40:50 <suseROCKs> anyway  let's keep moving cuz I need to be out of here in 1/2 hour....
15:41:25 <tigerfoot> once added you HAVE to commit it first on your local branch, then the git push will work
15:41:25 <manugupt1> Do it
15:41:25 <manugupt1> do a git add .
15:41:28 <manugupt1> so that atleast you will not ask others :)
15:42:19 <suseROCKs> tigerfoot,  y ou should know by now that I lack any commitment!
15:42:20 <manugupt1> Once you are done with adding
15:42:20 <manugupt1> do a
15:42:20 <manugupt1> git commit -a
15:42:39 <manugupt1> After doing this vim will open and you will add a description of the changes you made
15:42:43 <manugupt1> Once you save it
15:42:52 <manugupt1> you can do a git push origin master
15:42:56 <manugupt1> thas it
15:42:58 <suseROCKs> ok how do I commit?
15:43:18 <manugupt1> suseROCKs: scroll 5 lines uo
15:43:25 <suseROCKs> git origin master doesn't do a damn thing
15:43:44 <manugupt1> suseROCKs: do a git commit -a
15:44:27 <suseROCKs> uhh  that opens a vim
15:44:42 <manugupt1> yes add the description of your changes and close it
15:45:18 <tigerfoot> git commit -a -m "My highly detailled description" avoid that :-)
15:45:49 <manugupt1> Hmm.. thanks tigerfoot
15:46:33 * tigerfoot need to confirm if they use the same syntax as svn & osc ...
15:46:44 <suseROCKs> ok so think I'm done with that
15:47:29 <manugupt1> now do a git push
15:47:31 <tigerfoot> next the pull in the pool
15:47:40 <tigerfoot> oups forget the push
15:47:40 <manugupt1> tigerfoot: push
15:48:13 <tigerfoot> yeap push him in the pool, poll, pull :D
15:48:48 <suseROCKs> ok and git status is now clear
15:48:53 <suseROCKs> do you see the changes?
15:49:36 <manugupt1> suseROCKs: I am pulling it now
15:49:46 <manugupt1> Ok.. so you are educated about git now
15:49:46 <manugupt1> :)
15:49:50 <tigerfoot> manugupt1: suseROCKs http://susepaste.org/7565549
15:50:09 <tigerfoot> manugupt1: no the next step is merging a request :-)
15:50:50 <manugupt1> tigerfoot: suseROCKs does not need it as he has an access to it
15:51:18 <suseROCKs> manugupt1,   so you see my change?
15:51:37 <manugupt1> suseROCKs: there are changes but it will need time for me
15:51:38 <manugupt1> to download them
15:51:41 <tigerfoot> manugupt1: to able to do that :-)
15:51:51 <tigerfoot> suseROCKs: already here
15:52:06 <suseROCKs> awesome
15:52:19 <suseROCKs> its nice to know I have the power to destroy everything  :-)
15:52:30 <manugupt1> suseROCKs: Ha ha suseROCKs
15:52:33 * tigerfoot decide to go to shop even if it's raining frog ....
15:52:38 <manugupt1> It is git you can always revert your chenges
15:52:41 <tigerfoot> see you
15:52:56 <manugupt1> tigerfoot: bye
15:53:00 <suseROCKs> thank you tigerfoot
15:53:10 <suseROCKs> ok manugupt1   back to looking at our folders....
15:53:11 <manugupt1> tigerfoot: thanks a lot
15:53:22 <manugupt1> suseROCKs: do you see the tobesorted folders
15:53:40 <suseROCKs> yes.  which makes me think we need a logos folder
15:53:46 <manugupt1> suseROCKs: since my net is slow can you do it for me it will be faster
15:54:09 <manugupt1> also i will create the empty folders
15:54:47 <suseROCKs> ok I will do my best
15:54:56 <suseROCKs> but I'm running out of time  (15 mins to go)
15:55:00 <manugupt1> so please do not create the logos folder
15:55:16 <suseROCKs> hmm  chameleon file isn't really a logo file but a poster  (nice one though)
15:55:34 * manugupt1 creates nice things :P
15:55:57 <suseROCKs> you did that?
15:55:59 <suseROCKs> Awesome!
15:57:21 <manugupt1> suseROCKs: long ago
15:57:46 <manugupt1> suseROCKs: I am pushing some changes
15:58:22 <suseROCKs> manugupt1,   can you also create a folder called past-events?
15:59:06 <manugupt1> suseROCKs: Hmm I dont think that is necessary as usually people push things after they are done with the event
15:59:38 <suseROCKs> manugupt1,   welll do you see any of those posters here?  :-)
16:00:00 <suseROCKs> some of those posters are good to ahve as a reference for next event
16:00:06 <suseROCKs> maybe we should create "Archive" folder instead?
16:00:18 <manugupt1> suseROCKs: That is why I created a folder called events
16:00:38 <manugupt1> And we need to send a mail to the ml for all the marketing work to be pushed
16:00:40 <suseROCKs> ok
16:02:01 <manugupt1> suseROCKs: lets name that tobesorted to misc
16:03:24 <manugupt1> And suseROCKs I dont think we can do anything else on it
16:03:45 <manugupt1> Whatever changes I will make I will push it as soon as I get a faster net
16:04:11 <manugupt1> What do you say?
16:06:15 <suseROCKs> ok that's great
16:06:22 <suseROCKs> I'll do my best to reorganize what I can today
16:06:27 <suseROCKs> Do you want to send out the email to everyone?
16:07:04 <manugupt1> You send it
16:07:13 <suseROCKs> I will go ahead and end bugbot now, manugupt1 unless you have anythign else we need to record now
16:08:10 <manugupt1> #info artwork-repository reorganised
16:08:10 <manugupt1> now you can :)
16:08:15 <suseROCKs> manugupt1,   Can you review documentation about how to use git?
16:08:30 <manugupt1> Ok..
16:08:32 <suseROCKs> incorporate all that git push stuff if its not there
16:08:48 <manugupt1> suseROCKs: Its ok as I see it, people dont read it
16:08:53 <suseROCKs> manugupt1,  and let's get you added as an admin to approve new users
16:09:10 <manugupt1> It is still one of my handy references
16:09:13 <suseROCKs> you need to ask either yaloki or tigerfoot to add you as admin
16:09:37 <suseROCKs> #action manugupt1 to be added as admin to artwork repository by asking either yaloki or tigerfoot
16:09:39 <manugupt1> ok..
16:09:41 <suseROCKs> ok that's it
16:09:43 <suseROCKs> #endmeeting