19:12:55 <einar77> #startmeeting
19:12:55 <bugbot> Meeting started Sat Feb  8 19:12:55 2014 UTC.  The chair is einar77. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:12:55 <bugbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:13:13 <einar77> #meetingtopic  Welcome to the openSUSE KDE community IRC meeting! Please wait with other discussion until the meeting is over. This meeting is logged.
19:13:29 <einar77> Ok, let's start
19:13:37 <einar77> We have two topics on the agenda so far
19:13:43 <shumski> oki, shoot
19:13:47 <einar77> optimizations first
19:14:01 <einar77> and also a request by tigerfoot on the OSC packaging workshop
19:14:18 <einar77> let me alos go through the old notes
19:15:03 <shumski> ok. i missed the last one where we should have discussed kf5 status, etc. my idea is to push it asap to O:F
19:15:15 <einar77> #topic old action items
19:15:27 <einar77> shumski: we're on alpha 1 for KF5
19:15:31 <shumski> yep
19:15:41 <einar77> I'm guessing you want to push it to Factoyr?
19:15:48 <shumski> yep =)
19:16:00 <einar77> It should be released soon IIRC
19:16:04 <einar77> I have to check the schedule
19:16:06 <shumski> i've created KDE:Frameworks5 project
19:16:09 <shumski> tuesday
19:16:32 <einar77> "stable" releases for KF5?
19:16:40 <shumski> the name is open for discussion, but i need a place to push the proper tars
19:16:41 <shumski> yep
19:16:56 <shumski> and opened today security revieww for kinit
19:16:59 <einar77> shumski: I'm guessing you'll have to announce it also the ML
19:17:15 <einar77> I would say once alpha 1 is actually out
19:17:21 <shumski> einar77: yes. but i wanted to see what others think
19:17:34 <einar77> to be honest I?m not sure
19:17:44 <einar77> KDE:Unstable:Frameworks is totally distinct
19:17:50 <einar77> I would call it just frameworks though
19:17:54 <einar77> KDE:Frameworks
19:18:22 <shumski> ok. this is easily changed, as said, just needed a place to work with proper tars
19:18:39 <shumski> (and publishing is disabled anyway there)
19:18:50 <einar77> agreed that we need it
19:19:02 <einar77> shumski: still uses the /opt mechanism for now?
19:19:12 <shumski> einar77: nope. it is now in /usr
19:19:21 <shumski> 2 files left to adjust
19:19:37 <shumski> kross manpage, and a desktop file for locale
19:20:01 <einar77> but still coinstallable I assume?
19:20:22 <shumski> everything else can co-exist. depending what will happen with kactivities and plsma-framework they'll need adjustements
19:20:25 <shumski> yeo+p
19:20:29 <shumski> *yep
19:20:58 <shumski> at least my system didn't explode =)
19:21:03 <einar77> ok, it's a start
19:21:15 <einar77> I would say, notify the rest of the team first, then the mL
19:21:25 <einar77> given it's just you and me
19:21:33 <shumski> agreed =)
19:22:02 <einar77> #action shumski to mail the team about the stable KF5 repository
19:22:52 <einar77> given that SFaulken-AFK is not here, and he was suposed to pushing cloverleaf systemsettings to KUSC, I'll put action again for the future
19:23:09 <einar77> #action
19:23:11 <einar77> SFaulken to push the cloverleaf systemsettings to KUSC as a starting point
19:23:12 <einar77> for further optimizations
19:23:14 <einar77> bah
19:23:29 <einar77> #action SFaulken to push the cloverleaf systemsettings to KUSC as a starting point  for further optimizations
19:23:35 <shumski> (atm i cannot open that optimization wiiki page)
19:23:46 <einar77> I have it open
19:23:51 <einar77> in fact let's go over that now
19:24:11 <einar77> #topic openSUSE KDE packages optimization
19:24:27 <einar77> Currently we have two actions open
19:24:33 <einar77> "Make social desktop optional"
19:25:01 <einar77> I'm guessing nepomuk, but I'm wondering, given that Baloo will be the default in 4.13, whether it makes sense to work on that
19:25:04 <shumski> ok. i'd like an elaboration on that one =)
19:25:17 <einar77> my guess is semantic desktop
19:25:19 <einar77> and not social
19:25:28 <shumski> nepomuk/baloo/akonadi are already optional
19:25:39 <einar77> but as I said, Baloo makes the point kind of moot
19:25:40 <shumski> so i am not sure what should be worked on
19:26:11 <einar77> The other is "simplification of KDE systemsettings"
19:26:35 <einar77> I would say we need other people to discuss on this
19:26:51 <shumski> einar77: wrt first item. i've splitted baloo package to components, so one can choose between them, or all, or none
19:26:55 <shumski> yep
19:27:06 <einar77> so that means we already handled it sort of
19:27:14 <einar77> also baloo is considerably lighter on resources than neopmuk
19:27:23 <shumski> (e.g. baloo-file, baloo-pim, etc) libraries cannot be ommited
19:27:31 <einar77> so I'm hoping it will get less flak
19:27:32 <shumski> also true
19:27:43 <einar77> (I'll say a bit more once we switch topics)
19:27:51 <einar77> for the rest, discussion is deferred to next meeting
19:27:58 <shumski> +
19:28:07 <einar77> #info Discussion on optimizations deferred to next meeting, need more people present
19:28:24 <einar77> #topic Q&A, misc
19:28:39 <shumski> there's already one important thng that happened meanwhile
19:28:45 <einar77> that i?
19:28:47 <einar77> is?
19:28:48 <shumski> 13.2 is in November
19:28:52 <einar77> right
19:29:00 <shumski> so, no 4.13 =) more 4.15
19:29:15 <einar77> I would say, use the latest stable version available at the time
19:29:24 <einar77> provide KF5 for the corageous
19:29:31 <einar77> KF5 + Plasma Next
19:29:35 <einar77> corageous and developers, that is
19:29:46 <shumski> if they go on schedule, we should have something like that
19:30:20 <shumski> and as said, we should be able to squeeze in 4.15. but, there's time for that now
19:31:10 <einar77> I would suggest after Plasma Next release to try and test it in parallel with traditional 4.x
19:31:19 <einar77> so we get a feel of how it is
19:31:29 <shumski> (and from my end to report - > i'll submit Qt 5.2.1 today/tommorow likely)
19:31:31 <einar77> but for sure, offer it optionally
19:31:35 <shumski> yes
19:31:57 <einar77> KF5 / Plasma Next would be considered again for 13.2+1
19:31:59 <einar77> IMO
19:32:21 <shumski> considered again?
19:32:23 <einar77> we can always provide repositories if things go exceptionally well but I wouldn't want to push it on users
19:32:24 <shumski> as?
19:32:28 <einar77> well
19:32:35 <einar77> I have no idea what upstream will do
19:32:46 <einar77> workspace is LTS for 2 years
19:33:02 <einar77> we're getting close to one IIRC
19:33:38 <einar77> also once KF5 opens up for features again, we'll likely see some more movement by app developers
19:33:42 <einar77> so to sum up
19:34:02 <shumski> was Thu Aug  8 when 4.11.0 was uploaded
19:34:10 <einar77> 1. 4.x default for 13.2 + KF5/Plasma Next as option
19:34:25 <shumski> +1 from me =)
19:34:40 <einar77> 2. Re-evaluate if keep (1) or switch places for 13.2
19:34:47 <einar77> er
19:34:49 <einar77> 132.2+1
19:34:51 <einar77> 13.2+1
19:34:53 <shumski> correct
19:35:07 <shumski> ok, sorry, need to run now =(
19:35:45 <einar77> #info For 13.2, keeping 4.x (latest version available) and KF5 / Plasma Next as option, for 13.2+1 re-evaluate which use as default
19:35:48 <einar77> no problem
19:35:56 <einar77> Let's end it here
19:36:09 <einar77> #endmeeting