18:00:36 <bmwiedemann> #startmeeting
18:00:36 <bugbot> Meeting started Mon Nov  7 18:00:36 2011 UTC.  The chair is bmwiedemann. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:36 <bugbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:00:50 <bmwiedemann> Hello everyone
18:00:50 <bmwiedemann> As always, today's agenda is on http://en.opensuse.org/openSUSE:Testing_meeting
18:00:50 <bmwiedemann> You can still add to the agenda on the wiki while the meeting is in progress
18:01:10 <bmwiedemann> #topic RC2 experience
18:01:27 <bmwiedemann> Larry, want to start?
18:01:31 <Holgi> rc2 running fine on my workstation
18:01:33 <LWFinger> Sure.
18:02:25 <LWFinger> I have installed RC2 using 'zypper dup' from RC1 on 3 real and one virtual machines.
18:03:15 <LWFinger> The VM and 2 real machines (1 x86_64 and 1 i686) have no problems.
18:03:38 <LWFinger> Only minor problems with my main laptop (64-bit).
18:04:20 <LWFinger> On rebooting, Thunderbird dies the first time it runs. After restart it is OK.
18:05:23 <LWFinger> Once in a while, I get the KDE plasmoid networkmanager waiting for authorization, but no login screen visible.
18:06:06 <LWFinger> Once every 5 or 6 reboots, systemd does not go to completion. I still need to find out why.
18:06:14 <LWFinger> Done.
18:06:16 <bmwiedemann> I also had the thunderbird crash on first start
18:06:50 <LWFinger> I send the crash report to Mozilla every time.
18:06:58 <bmwiedemann> I didn't file it on bnc yet, though.
18:07:12 <LWFinger> Me neither.
18:07:59 <Holgi> new thunderbird profile or already there?
18:08:14 <LWFinger> Already there.
18:08:22 <Holgi> ok
18:09:07 <bmwiedemann> I triggered a reproducible kernel panic on my desktop when writing to a (possibly faulty) USB-stick. tried to capture it with netconsole, but did not capture the full backtrace.
18:09:49 <LWFinger> What component was indicated in the part you got?
18:10:50 <LWFinger> I do not run openSUSE kernels, but I have not had problems writing to good sticks.
18:12:10 <bmwiedemann> http://susepaste.org/22137508
18:12:47 <bmwiedemann> that is what was captured, but in messages before, it had sys_write and aio below
18:14:08 <bmwiedemann> I will organize a RS232 cable tomorrow and retry there. Is lkml the right place to send this?
18:14:31 <Holgi> we have several
18:14:36 <bmwiedemann> (after reproducing with vanilla kernel)
18:14:53 <Holgi> just collect one!
18:15:36 <bmwiedemann> OK
18:16:19 <LWFinger> Yes, lkml is the correct place. I don't know why you got a CPU lockup, but someone there will know.
18:17:40 <bmwiedemann> most of my machines still run RC1 or some intermediate version, as I was away this weekend. installed RC2 now on my desktop (not rebooted yet).
18:18:46 <bmwiedemann> openQA results look mostly OK with the xorg/kexec bug still breaking some 30-50% of tests
18:19:28 <bmwiedemann> done
18:20:44 <LWFinger> How does the xorg/kexec bug show?
18:21:54 <bmwiedemann> install ends in such a screen http://openqa.opensuse.org/viewimg/opensuse/testresults/openSUSE-NET-i586-Build0030-lxde/livecdreboot-1.png
18:22:40 <bmwiedemann> when you do ctrl-alt-f2 and cat /var/log/Xorg.0.log you see a segfault message and
18:22:40 <bmwiedemann> ctrl-alt-delete works to make it boot the fully installed system
18:22:56 <bmwiedemann> so not too bad
18:23:15 <LWFinger> A little nasty for newbies.
18:23:52 <LWFinger> Is this workaround in the release notes and/or the most annoying bugs list?
18:24:04 <bmwiedemann> on the most-annoying list
18:24:31 <LWFinger> Good. Now if anyone reads it.
18:25:07 <bmwiedemann> I know many who don't (even within SUSE)
18:26:41 <bmwiedemann> possibly, people will learn that it can make their life easier.
18:27:04 <bmwiedemann> anyone has more RC2 experience to share?
18:27:42 <bmwiedemann> tigerfoot jradzuweit  ^ ?
18:28:58 <LWFinger> For the record, I have been running 12.1 exclusively since MS5, and I find it to be the best pre-release cycle of any.
18:29:02 <Holgi> the new tester from italy did not show up!?
18:30:03 <bmwiedemann> LWFinger: yay!
18:32:14 <LWFinger> Anyone here have any USB3.0 hardware?
18:32:16 <bmwiedemann> I found one more thing: my firefox eats memory. I always have ~200 tabs open, but does it really need 3.2GB virtual (1.1GB for "heap-unclassified")
18:33:01 <LWFinger> How does one get that number?
18:33:37 <bmwiedemann> about:memory shows some details
18:35:06 <bmwiedemann> I also crashed my firefox by viewing a huge image at wikipedia (but later found that it had a warning to that at the associated HTML page)
18:36:09 <LWFinger> I've got only 6 tabs open. Mine shows 104 MB total and 50 MB as unclassified heap. That seems reasonable.
18:38:11 <LWFinger> Oh, the above is not right. vsize is 870 MB with 145 resident.
18:38:20 <tigerfoot> ok I'm in late :D
18:38:29 <Holgi> jo tigerfoot
18:38:38 <bmwiedemann> tigerfoot: better late than never :) did you test RC2?
18:39:00 <tigerfoot> I actually yesterday and today migrated two working 11.4 computers
18:39:27 <tigerfoot> one laptop on a full / in lvm encrypted which work after minus bug 728656
18:39:56 <tigerfoot> the other one is my QA testing machine (will become) with fglrx inside and the upgrade was smooth
18:40:23 <tigerfoot> I've just find that systemd is excellent to detect wrong fstab & crypttab params :D
18:40:43 <tigerfoot> now I'm using a factory rsynced local mirror ...
18:40:53 <tigerfoot> so it will start to be more 12.2 :D
18:41:22 <bmwiedemann> 12.2 will not really start before December ;)
18:41:29 <tigerfoot> I mostly think we will have questions about systemd, or people finding it can stuck ...
18:41:54 <tigerfoot> and we will have to inform them that systemd has timeout, and never crash (tm)
18:42:13 <tigerfoot> so waiting most of the time resolve the case ( non shutdown etc )
18:42:32 <tigerfoot> and then admins have to check their configuration about what's wrong ...
18:42:42 * tigerfoot add another point
18:43:28 <LWFinger> How long is the timeout?
18:43:40 <tigerfoot> On the testing virtual server I have, apparmor is just full pain in ass .... absolutely not working : stuck with distant virt-manager+ssh connexion
18:43:50 <bmwiedemann> I think 1 or 3 minutes
18:43:53 <tigerfoot> LWFinger: could take > 98 secondes
18:44:30 <tigerfoot> I've put all profiles in complaint mode ... but I can't really trust even the new packaging ...
18:44:39 <LWFinger> OK, net time mine hangs on boot, I'll go get a beer. :)
18:45:10 <tigerfoot> and on real production I've tried it with dovecot2  = just plain wrong, and that one will get a bug entry once I've found the time....
18:45:11 <bmwiedemann> tigerfoot: I had trouble in the past with virsh over ssh from policykit (which is default since 11.3 or so)
18:45:36 <tigerfoot> bmwiedemann: now the new libvirtd impose apparmor :-(
18:45:52 <tigerfoot> in term of require rpm
18:46:49 <tigerfoot> My other concern is that ipv6 get not ready quickly and then you get stuck or even get nfs services and all your nfs mounts crash
18:47:15 * tigerfoot think could be my setup of radvd too
18:48:01 <tigerfoot> hopefully the good news, is after fighting a bit, ipv4 + ipv6 by radvd,dhcp on a bridge work as expected ...
18:48:20 <bmwiedemann> I had trouble with IPv6 privacy addrs, when I sshed to another machine and when the temp addrs were dropped after some minutes, the connection would hang
18:49:03 <LWFinger> My NFS mounts are OK. Do you have the problem on the machine that runs radvd?
18:49:39 <tigerfoot> LWFinger: nope clients of the nfsv3 ipv6 server
18:50:15 <tigerfoot> if I start them manually once the ipv6 is distributed everything are ok ...
18:50:29 <tigerfoot> but with ifup it take loong time to get it  ...
18:50:44 <tigerfoot> my laptop with networkmanager works pretty well ...
18:51:05 <tigerfoot> and I've setup the sysctl configuration excatly the same ...
18:51:41 * tigerfoot knows that ~1% of people will use ipv6 ... so we can postpond to 12.2 :D
18:52:16 <bmwiedemann> with IPv4 pools gone dry this year, this figure could increase soon
18:53:06 <tigerfoot> bmwiedemann: too costly for ISP , they will nat us even twice if they need ... which is just a big shame on them ....
18:53:39 <bmwiedemann> spanish ISPs did that for years, but it sucks, if you need incoming ports
18:53:58 <tigerfoot> Otherwise, in the last 10 days I've tested cups 1.5 client on 1.4 server, everything work pretty much fine, just a trouble with one epson and fifthLegs
18:54:18 <tigerfoot> bmwiedemann: orange too you get a 10x ip ...
18:54:42 <bmwiedemann> UMTS didn't get IPv4 space years ago, so they had to
18:55:11 <tigerfoot> And they can't tell us that doesn't work, cause it works in Japan, but I understand there some trap to tunnel your internal ipv6 traffic to ipv4 only hosts outside ...
18:55:43 * tigerfoot should decrete ipv4 dead on 1st January 2012 :D
18:56:14 <tigerfoot> or is that what Mays called the end of world on 21st Decembre 2012 ?
18:56:19 <tigerfoot> :D
18:56:28 <bmwiedemann> hehe
18:56:29 * tigerfoot back on track
18:56:52 <tigerfoot> Flash 64 and FF now seems stable and work nicely without too much trouble here.
18:57:04 <LWFinger> That theory makes more sense than any other explanation I've heard.
18:57:21 <tigerfoot> on the kde side, people will suffer with kmail2 due to mainly trouble in the migration process.
18:57:41 <bmwiedemann> had a collegue hit the kmail2 trouble
18:57:53 <tigerfoot> If you start from scratch and setup correctly your akonadi things, it works at 80%
18:58:06 <LWFinger> Are there any work-arounds for the Kmail problem?
18:58:32 <tigerfoot> bmwiedemann: I was in the process to move from thunderbird to kmail2, but the non working imap sort order for folder is just a no go for me actually ...
18:59:00 <tigerfoot> LWFinger: if you have offline imap server, you can remove all pim references
18:59:09 <Holgi> tigerfoot: move from thunderbird ...?
18:59:22 <tigerfoot> then setup them new as fresh akonadi ressources
19:00:06 <tigerfoot> once that done, it start working well. but from what I've seen, you will mostly have to redownload all your imap emails to get them offline ....
19:00:13 <tigerfoot> in my case 8.4GB :D
19:01:08 <tigerfoot> Holgi: yeap cause I'm using all the rest of the kde pim stack ... so kmail would facilitate things between todo, contacts, schedule, bookmarks etc ...
19:01:19 <Holgi> tigerfoot: I see
19:01:32 <tigerfoot> but I'm not sure it will work before SLES13 :D
19:01:40 <Holgi> tigerfoot: I just know people moving away from kde stack
19:02:01 <tigerfoot> Actually yes, that what I saw on ML too ....
19:02:25 <bmwiedemann> I know two KDE devs who were rather impressed with GNOME3 :)
19:02:27 <tigerfoot> I think old users of kmail know better than me
19:02:54 <tigerfoot> bmwiedemann: I agree, until you have a ati/amd card that are not supported by radeon :D
19:03:39 <bmwiedemann> then there is still fglrx
19:03:53 <tigerfoot> fglrx even the 11.10 and Gnome3 lead just to crash actually, Sebastian Siebert tell me that a patch is on the way, but not before december for Gnome 3.4, and then backported to 3.2
19:04:43 <tigerfoot> bmwiedemann: on my unofficial repository I get ~18000 unique ip pro month for a total of 130GB
19:04:58 <tigerfoot> so yes a certain number of people want & use it :D
19:05:31 <bmwiedemann> it=kmail ? or fglrx?
19:05:45 <tigerfoot> flgrx
19:05:47 * tigerfoot as conclusion to RC2 experience
19:05:59 <bmwiedemann> it is good that it is there
19:06:45 <bmwiedemann> so that's it for our RC2 experience topic
19:06:46 <tigerfoot> I've seen more bugreport coming in bugzilla after RC1 and RC2, which (I don't have exact numbers) that we need to develop our effort to get more users involved during the factory life
19:07:46 <bmwiedemann> #topic Next Meeting
19:08:06 <bmwiedemann> so when shall we meet again?
19:08:19 <bmwiedemann> there will be no more RCs before 12.1-GM
19:08:21 <LWFinger> What is the new date for GM?
19:08:40 <bmwiedemann> 2011-11-11
19:09:11 <LWFinger> So, Nov. 14?
19:09:28 <bmwiedemann> no, 11th
19:09:38 <LWFinger> I meant for the meeting.
19:09:54 <bmwiedemann> ah
19:10:20 <bmwiedemann> fine with me
19:10:48 <bmwiedemann> though GM will only be publicly released on 17th
19:10:51 <bmwiedemann> 16th
19:11:00 <Holgi> really next week?
19:11:28 <LWFinger> Do we want to meet between GM and public release?
19:11:36 <tigerfoot> and when would be the next bug hunting
19:11:45 <bmwiedemann> we could update the most-annoying list
19:12:51 <bmwiedemann> bug hunting was happening all week now
19:13:01 <LWFinger> bmwiedemann: That should be done before public release.
19:13:34 <bmwiedemann> yep. could help things.
19:14:13 <LWFinger> If we want more testing time, the meeting does not need to be on a Monday.
19:14:44 <bmwiedemann> 15th then?
19:14:54 <tigerfoot> I mean bmwiedemann could prepare some nice query on bugzilla
19:15:29 <LWFinger> The 15th does not work for me.
19:15:37 <tigerfoot> 15 @ 7pm CEST for me is better than 14th ...
19:15:43 <tigerfoot> :D sorry LWFinger
19:16:35 <bmwiedemann> or we don't do IRC meeting, but just discuss those things on ML (or on IRC whenever someone is there to talk to)
19:16:51 <bmwiedemann> will get more visibility on ML
19:17:15 <bmwiedemann> and be easier to participate as more people know how to write email
19:17:30 <LWFinger> The 14th is the only day I could be here next week. ML is likely better.
19:18:14 <Holgi> so next meeting 21st then and rest per ml?
19:18:29 <bmwiedemann> Holgi: I can't on 21st
19:18:34 <bmwiedemann> 27th?
19:18:55 <Holgi> also ok
19:19:02 <bmwiedemann> err 28th
19:19:29 <LWFinger> The 28th is OK for me.
19:20:02 <bmwiedemann> we could do a retrospective of our testing efforts. what worked, what didn't, things we should have done etc
19:21:33 <Holgi> tigerfoot?
19:21:41 <Holgi> 28th?
19:22:35 <tigerfoot> 28th okay for me too
19:22:54 <bmwiedemann> #agreed next meeting 2011-11-28 18:00 UTC
19:23:19 <bmwiedemann> anything else?
19:23:32 <LWFinger> Nothing here.
19:23:40 <pla_> hi, here I am:-)
19:23:57 <bmwiedemann> pla_: want to share your RC2 experience?
19:24:11 <pla_> yes
19:24:40 <pla_> I installed rc2 yesterday
19:25:01 <pla_> what have to test ?
19:25:39 <bmwiedemann> did it boot up? could you log in and do what you wanted?
19:25:46 <Holgi> I read your mail - what machine did you use?
19:26:50 <Holgi> pla_: dell latitude e6510, but how slow/fast is it? what memory?
19:26:57 <pla_> dell latitude e6510, do you need I start with rc2?
19:27:34 <pla_> 4gb of ram and intel i7
19:28:06 <tigerfoot> pretty much the same as my Precision M4600
19:28:10 <tigerfoot> Sysinfo for 'c-3po.vellerat.ioda.net': Linux 3.1.0-1-desktop running KDE Development Platform 4.7.3 (4.7.3), CPU: Intel(R) Core i7-2820QM CPU @ 2.30GHz at 800 MHz (4588 bogomips), HD: 278/700GB, RAM: 14865/16100MB, 327 proc's, 10.6h up
19:28:22 <Holgi> pla_: and it took such a long time?
19:28:30 <Holgi> tigerfoot: even for you?
19:28:33 * tigerfoot has forget : we need the alps touchpad fix as soon as possible ...
19:29:30 <LWFinger> tigerfoot: Is that patch suitable for backporting to stable?
19:29:34 <bmwiedemann> part of the touchpad issues is that clicking by tapping is disabled in xorg for a while
19:30:00 <pla_> yes, I don't know why
19:30:05 <tigerfoot> Holgi it take something like 45 secondes minus +/- 12 secondes (due to my entry of passphrase for unlocking encryption )
19:30:15 <LWFinger> I cannot use tapping, thus I'm happy it is disabled. Saves me time.
19:30:31 <pla_> yes, scrolling don't works
19:30:33 <tigerfoot> and I have raid 0 encrypted, + lvm on top of it ... ~14secondes to get them up ...
19:31:22 <tigerfoot> The Alps / elantouch patches available in what ismael have propose in his kernel work like a charm here ...
19:31:52 <tigerfoot> otherwise the touchpad is not recognize as touchpad, only a stupid ps2 mouse which is really annoying ...
19:32:20 <LWFinger> tigerfoot: I have heard they work, but GregKH hates to carry patches that are not in stable.
19:34:31 <tigerfoot> LWFinger: I understand ... but it will goes in upstream, and if we don't have it as patch once release billions of future openSUSE users have to wait 12.2
19:34:51 <tigerfoot> or need tumbleweed, which is a kind of auto-promotion :-)))))))))9
19:35:23 <tigerfoot> I can survive without ... 6 months more not a big deal
19:35:32 <LWFinger> Or the kernel-of-theday.
19:36:21 <LWFinger> What is the holdup for those patches?
19:37:06 <pla_> ok, I'm running rc2 now
19:37:20 <pla_> the network is ok today
19:37:40 <pla_> when I installed networkmanager didn't start
19:38:12 <bmwiedemann> pla_: it does not start on first boot (know&fixed bug)
19:38:24 <bmwiedemann> but should work on second boot
19:38:40 <pla_> yes, this is the second boot
19:39:07 <pla_> do you think it will be corrected in the final release?
19:40:21 <pla_> I was thinking about how much time it take to install here
19:40:32 <pla_> could be a slow disk?
19:40:57 <pla_> have you some test to check the speed of hard disk?
19:41:20 <LWFinger> By the way, you will not have to install from scratch to get the final release. A 'sudo zypper dup' in a terminal will work.
19:42:15 <bmwiedemann> pla_: for speed-check try: hdparm -t /dev/sda
19:42:15 <LWFinger> Are all your CPUs running? How many does 'cat /proc/interrupts' show?
19:42:40 <bmwiedemann> (as root)
19:42:50 <pla_> to install rc2 I used the old laptop hard disk I changed for need of room wit another
19:44:51 <LWFinger> Have you checked /var/log/messages for disk errors? A few bad sectors will really slow the system down.
19:45:30 <LWFinger> You can also do the long test with smart.
19:46:00 <pla_> cat /proc/interrupts shows CPU0 ... to CPU7
19:46:22 <LWFinger> OK, you got them all.
19:46:48 <LWFinger> Do those extra 4 hyper-threaded CPUs really help?
19:47:45 <bmwiedemann> at most some % from saved context-switches
19:48:38 <pla_> I think the hyper threaded don't help much
19:48:51 <LWFinger> I've always considered them an Intel scam. Since I tried my first one, I've bone to AMD exclusively.
19:49:03 <LWFinger> s/bone/gone/
19:51:06 <pla_> I have another desktop with amd, with 6, there I noticed the difference
19:51:49 <LWFinger> Yes, but all 6 are full processors.
19:52:15 <pla_> I checked cat /var/log/messages | grep disk but no errors, did I the right command?
19:52:48 <tigerfoot> it help ... when you use compile ...
19:52:59 <tigerfoot> a make -j8 is really powerfull ...
19:53:58 <bmwiedemann> pla_: disk error looks like
19:53:58 <bmwiedemann> [ 2476.452936] Buffer I/O error on device sdb, logical block 917765
19:54:30 <LWFinger> Yes, but the rule of thumb is that you should make the number be 2X the number of CPUs. Would -j16 be faster than -j8 for HT?
19:55:00 <LWFinger> I use make -j4 for my dual core CPU.
19:55:25 <tigerfoot> LWFinger: didn't try ...
19:55:49 <tigerfoot> pla_: in case of disk error , smartctl -t long /dev/sdb
19:55:49 <bmwiedemann> chances are, disk is the bottleneck with high -j
19:55:58 <tigerfoot> then you will have clue about ...
19:56:36 <tigerfoot> after depending on the disk and full erase could help it to remap correctly the bad sector ... otherwise each mfg has tool for that ...
19:56:45 <tigerfoot> but need a restore after ...
19:56:53 <LWFinger> On my desktop, I can push my dual core CPU to -j5, but TV breaks due to disk throughput issues.
19:58:56 <pla_> with grep sda, there isn't error or buffer in the output
19:59:59 <LWFinger> With smartctrl, you can dump the recent history, and you should run the long test.
20:00:14 <LWFinger> I have to leave now. Bye.
20:00:55 <bmwiedemann> Ciao
20:01:18 <tigerfoot> bye ...
20:01:39 <pla_> ciao:-)
20:01:53 <Holgi> cu
20:02:56 <bmwiedemann> we should end our meeting (with the option to discuss some more afterwards)
20:03:31 <bmwiedemann> Thanks everyone for attending. I will add links to the logs on http://en.opensuse.org/openSUSE:Testing_meeting
20:03:38 <bmwiedemann> #endmeeting