18:16:04 <henne> #startmeeting openSUSE Project Meeting
18:16:04 <bugbot> Meeting started Wed Aug 10 18:16:04 2011 UTC.  The chair is henne. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:16:04 <bugbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:16:15 <henne> #meetingtopic openSUSE Project Meeting
18:16:22 <henne> The agenda is
18:16:28 <henne> 1. Contributor Gifts
18:17:05 <henne> 2. Proposal from Manu Gupta on Google Code-In"
18:17:20 <henne> lets roll
18:17:36 <henne> #topic Contributor Gifts
18:18:05 <Goku283> What is Contributor gifts?
18:18:24 <cboltz> a present to people that contribute to openSUSE
18:18:33 <Goku283> Am i allowed to just ask questions like this? or should i keep quite?
18:18:34 <cboltz> (in various ways - development, bugreports, marketing, ...)
18:18:54 <cboltz> yes, questions are of course allowed ;-)
18:19:21 <cboltz> I hope everybody has read http://en.opensuse.org/openSUSE:Contributor_gifts
18:19:22 <simon123> cboltz: wiki link?
18:19:33 * cboltz was faster *eg*
18:19:36 * henne has
18:19:45 <Goku283> I have contributed to this OpenSuse meeting, do i get a present?
18:19:55 <Goku283> No i havnt read, will  do now
18:19:55 <AlanClark> cboltz, yes. Thanks for creating the list
18:20:11 <henne> yeah thanks
18:20:15 <cboltz> Goku283: that's one of the questions - who should receive a gift
18:20:19 <henne> but how do you plan to go forward from here?
18:20:43 <cboltz> the answer probably depends on which type of gift we choose
18:20:46 <Goku283> Wheres the funding come from ?
18:21:06 <cboltz> for example a "contributors" file on the FTP server doesn't have a real limit, but sending something physical has
18:21:36 <cboltz> Goku283: there's some sponsoring from SUSE - at least there was in the past, and I hope there will be again ;-)
18:21:36 <suseROCKs> so  virtual vs. physical
18:21:44 <henne> virtual?
18:21:55 <henne> this was never really the scope imho :)
18:22:19 <suseROCKs> so cboltz  should focus directly on physical options?
18:22:26 <henne> i don't know
18:22:34 <henne> virtual opens another can of worms :)
18:22:44 <henne> the goal is to choose a gift and to choose a method of choosing contributors that receive one :)
18:22:51 <Goku283> The idea of giving someone a certificate of appreciation and an official letter is good
18:22:55 <cboltz> I'd indeed prefer the physical options
18:23:13 <Goku283> They can add it to their accomplishments and porfessional CV
18:23:31 <cboltz> my basic idea is to have something special/exclusive for contributors
18:23:56 <cboltz> and while I really honor the things we hand out at conferences, they don't fulfill this requirement
18:23:59 <Goku283> The hard part would be selecting the people and verifying there contributions?
18:24:04 <henne> cboltz: that basic idea was already in the task formulation ;)
18:24:20 <cboltz> as Alan wrote today: some people see it as a trophy
18:25:01 <AlanClark> cboltz, from the list, which item do you feel fits the criteria best?
18:25:04 <Goku283> Trophies of your achievemnets is much better than an item which is won as a prize so to speak
18:25:14 <suseROCKs> cboltz,   would it be possible to propose to have 2-3 things as sort of a catalog selection and allow someone who is to be awaded the chance to pick one item of their choosing?
18:25:25 <cboltz> what about a quick copy&paste round? Everybody chooses his favorite 3 ideas from the list and pastes them here ;-)
18:25:33 <henne> so people order their trophy?
18:25:39 <suseROCKs> e.g. I have no interest in getting a boxed edition.  but I might be interested in choosing the flashlight.    someone else would want the box
18:25:39 <henne> sounds perverted....
18:25:52 <Goku283> lol
18:26:19 * suseROCKs shifts in his chair while sitting naked and says... what's perverted???
18:26:32 <cboltz> I'd say the same item for everybody (but maybe something else for the next release)
18:26:47 <cboltz> otherwise handling will be too difficult ;-)
18:26:50 <Goku283> lol
18:26:53 <henne> cboltz: the real question is: which item
18:26:54 <AlanClark> I feer the complexity of choosing items
18:27:16 <henne> come up with an item that is doable
18:27:21 <cboltz> henne: that's why I proposed that everybody pastes his favorite 3 items here and now ;-)
18:27:26 <henne> come up with a method of choosing people that is doable
18:27:41 <suseROCKs> there's never going to be an item that makes everyone satisfied
18:27:51 <henne> yes thats why cboltz has to choose one :)
18:28:00 <suseROCKs> I literally toss my boxes into a corner and feel guilty that SUSE has spent so much money shipping it to me
18:28:01 <henne> we already failed at a group decision 3 times
18:28:17 <cboltz> ok, then I choose "get your favorite bug fixed"
18:28:22 * cboltz counts the bugs assigned to henne
18:28:23 <suseROCKs> no I'm proposing something different
18:28:25 <Goku283> openSUSE business cards (with the recipient name). Not very expensive, rewarding and useful for promoting openSUSE.  distinguished award to put on shelf/wall to show others what/something to put on   add a "thank you" letter
18:28:41 <Goku283> there the 3 i choose
18:28:53 <suseROCKs> I'm proposing that we create a mechanism where cboltz chooses 3 items of equal value and when the recipient is notified can go to some web page and select the item they want
18:29:11 <suseROCKs> seems to me having to choose exactly one item to fit everything is what is dragging us down most
18:29:22 <henne> cboltz: this is not lalalula land and I'm not your fairy ;)
18:29:41 <cboltz> henne: you said I should choose *eg*
18:29:50 <Goku283> I reckon the award, the thank you letter and the card,  then one choice of item from selectable list?
18:29:59 <henne> cboltz: i was counting on your intelligence...
18:30:06 <cboltz> seriously: would the "get a bug fixed" idea work, or is this impossible to handle?
18:30:28 <henne> thats impossible to handle because we don't control the people that can fix bugs
18:30:30 <suseROCKs> henne,   I'll bite.  Whose fairy are you?
18:30:40 <henne> suseROCKs: yermoms
18:31:02 <cboltz> henne: more or less - there are lots of assignees @suse.com which you can control
18:31:30 <henne> nobody controls assignees with @suse.com
18:31:31 <suseROCKs> cboltz,   I'm not sure we want to do that.   That umm..  puts a lot of pressure on things for what is simply a "thank you"
18:31:32 <simon123> suseROCKs: some companies here offer catalogues with items of similar value that can be used as presents
18:31:46 <suseROCKs> if we go by membership as the gift recipients that's nearly 500 people
18:31:51 <henne> cboltz: not even I ;)
18:31:53 <Goku283> What is 2. Proposal from Manu Gupta on Google Code-In" ?
18:31:59 <suseROCKs> simon123,   exactly what I'm thinking here
18:32:08 <henne> Goku283: thats the next topic. stay tuned
18:32:10 <suseROCKs> Goku283,   wait until the topic has changed  :-)
18:32:20 <Goku283> ok
18:32:35 <Goku283> i request a topic change....
18:32:38 <Goku283> lol
18:32:38 <AlanClark> The problem with multiple items is the staff required to work the list and ship the items
18:32:51 <henne> cboltz: did you have a look at the do-ability of items on your list?
18:32:56 <henne> or is that brainstorming?
18:33:11 <cboltz> both ;-)
18:33:28 <henne> AlanClark: we can automate this with connect
18:33:30 <Goku283> Are all the people invovled in OpenSuse doign this for free?
18:33:39 <cboltz> that's why I added the "should be doable in 2 hours" to the bugfix idea for example
18:33:53 <cboltz> but some items are just brainstorming ;-)
18:34:05 <henne> Goku283: how about you explore en.opensuse.org/Portal:Project for a while?
18:34:21 <Goku283> sure
18:34:22 <suseROCKs> the item about free air trave to the yet-to-be-purchased openSUSE Island in the South Pacific is do-able
18:34:31 <henne> cboltz: the bugfix thingee is simply not doable
18:34:53 <suseROCKs> especially if the contributor is a bugfixer him/herself  :-)
18:34:55 <henne> so what do you think is the best doable thing from your list?
18:35:11 <cboltz> ok, then I'll move it to a "impossible ideas" section ;-)
18:35:44 <cboltz> henne: what do you think about the other ideas from the "things money can't buy" section?
18:36:14 <simon123> I guess the easiest doable is the same as it is now:"Do nothing"
18:37:05 <cboltz> simon123: I know, but "do nothing" does not encourage contributors too much ;-)
18:37:29 <suseROCKs> you know... cboltz hss done quite a bit of work here coming up with a list and rather than just unilaterally dieciding everything for himself, he's welcoming feedback on ideas
18:37:34 <simon123> cboltz: right
18:37:39 <suseROCKs> and then he'll proceed further on the doability of the items
18:37:50 <suseROCKs> please do not insert this discouraging tone on him after all the work he put into this
18:38:08 <henne> cboltz: i think the stuff coupled to a date (conference etc) is not really tangible
18:38:17 <suseROCKs> all cboltz is hearing right now is discouragement.
18:38:23 <henne> cboltz: if you are unlucky you have to wait 12 months for it
18:38:56 <henne> all cboltz is hearing now is that he should decicde :)
18:39:25 <cboltz> henne: IIRC you didn't like my decision ;-)
18:39:34 <henne> cboltz: have you decided?
18:40:04 <cboltz> yes, I said I want to have a bug fixed
18:40:20 <cboltz> and then you probably checked your bug list for bugreports from me and hated the idea ;-)
18:40:21 <henne> okay then try to get that done
18:40:27 <henne> see you in 2034 :)
18:40:44 <cboltz> The bugfix idea would need some support from management
18:40:50 <henne> management?
18:40:55 <cboltz> there could be a bugfix day similar to the hackweek
18:40:56 <suseROCKs> c'mon henne  be a bit more positive occasionally
18:40:56 <henne> this is an open source project
18:41:01 <henne> there is no management
18:41:09 <simon123> this about bugs is good as idea, bug fixing bugs can be quite expensive
18:41:38 <cboltz> s/management/the people who say "forget your normal work, do whatever you want to do this week/
18:42:23 <henne> cboltz: this is simply not feasible and you know it
18:42:53 <AlanClark> not sure I follow how you would implement this in the community
18:42:55 <henne> cboltz: because you will have a nice time convincing yalokis manager to give him time
18:43:04 <henne> or my wife
18:43:20 <henne> or AJaegers kids
18:43:36 <henne> or whoever decides with random community people how time is spend
18:43:52 <cboltz> henne: I understand the problem - that's why I said it could it could be handled similar to hackweek
18:44:03 <suseROCKs> can we ask henne's wife to come to next meeting so we can convince her?
18:44:51 <henne> cboltz: how does hackweek work for people not employed by SUSE?
18:45:03 <simon123> it seems that we better forget bug fixing for now
18:45:12 <suseROCKs> ok seems this has totally devolved
18:45:13 <cboltz> henne: known bug ;-)
18:45:14 <suseROCKs> let's step back a bit
18:45:42 <cboltz> suseROCKs: agreed
18:45:51 <henne> cboltz: so you release a decision with a bug. sounds not like you ;)
18:45:58 <suseROCKs> cboltz,   this task was about finding a viable/affordable solution to distributing gifts to known contributors of openSUSE.  Let's not come up with solutions that require time on other people
18:46:15 <Goku283> delegation
18:46:17 <suseROCKs> something that is as close as "push-button-able" as possible
18:46:18 <henne> and come up with a solution how to identify contributors
18:46:23 <AlanClark> Also it's about recognition more than reward
18:47:06 <henne> both are 90% done and just need a decision
18:47:10 <Goku283> Public recognition
18:47:11 <cboltz> so we are more or less on the "things you can touch" list, right?
18:47:32 <henne> i could decide: we send pins to all members
18:47:34 <cboltz> henne: I think selecting the people is the easier part of my proposal ;-)
18:48:07 <Goku283> Then it comes down to the organizational and time spent in carrying all of this out
18:48:14 <cboltz> creating the list of people manually is nearly impossible
18:48:18 <cboltz> therefore I'd propose:
18:48:49 <Goku283> We all already know what are good gifts and awards, some of you know already who deserves it, but how to do it?
18:49:07 <cboltz> * members - but they have to verify their postal address in connect. That would already filter out inactive members.
18:49:11 <Goku283> delegate people to perform this?
18:49:17 <cboltz> * add GSoC students and mentors
18:49:32 <Goku283> GSoC ?
18:49:58 <cboltz> * and add a way to manually add/propose someone who is not member (yet), but did a large contribution
18:50:13 <simon123> Goku283: Google Summer of the Code
18:50:14 <cboltz> (but "add manually" should be an exception)
18:50:25 <Goku283> ok
18:50:47 <suseROCKs> cboltz,   I suggest you ping AJ or whomever it was that coordinated that info int he past to send out gifts and see how they gathered and processed the mailing information
18:51:14 <henne> this option is not available anymore
18:51:21 <henne> thats why we stopped the process
18:51:23 <cboltz> suseROCKs: AFAIK the list of people was maintained manually in the past
18:51:39 <cboltz> but that means it gets outdated - some people are inactive in the meantime
18:51:48 <cboltz> and new contributors are missing on the list
18:52:01 <henne> yes. thats why we stopped this process too
18:52:06 <simon123> cboltz: : updating connect would be an option, but what about privacy
18:52:44 <cboltz> simon123: the shipment address fields should be only visible to the person who handles the shipment
18:52:54 <cboltz> I don't see a real privacy issue with that
18:53:24 <simon123> cboltz: as long as it is kept that way is good, but visible to anyone with login, no thanks
18:53:37 <suseROCKs> ok guys, we're getting bogged down on nitty-gritty details that don't have a place in a general meeting
18:53:47 <cboltz> but before we go into that details - does everybody agree with my proposal how to choose the people?
18:53:51 <henne> and all we need is just a decision...
18:54:02 <suseROCKs> all we should be concerned with is general overview status and progress
18:54:29 <henne> cboltz: yes I think this is great
18:54:37 <suseROCKs> cboltz,  +1
18:54:51 <simon123> suseROCKs: privacy is not a detail that should be left out
18:55:22 <simon123> cboltz: agree
18:55:44 <AlanClark> cboltz,  I like the  proposal; some details to work out - we can do that through the wiki.
18:56:19 <cboltz> ok, that means one problem solved :-)
18:56:21 <suseROCKs> simon123,   please tell me that privately  :-)
18:56:28 <simon123> suseROCKs: :D
18:56:55 <henne> cboltz: now just choose an item and tell AJ where to order it
18:58:43 <henne> cboltz: and get the changes into connect. if you need help with this, let me know
18:58:56 <suseROCKs> ok so can we move on to second topic?   manugupt1 is here and its 1 a.m. in his area
18:59:11 <suseROCKs> and he's a guy that needs as much beauty sleep as we can give him.  Poor guy
18:59:38 * suseROCKs notices mrdocs logged in and wonders if he's actually present
18:59:40 <Goku283> lol
18:59:54 <cboltz> henne: I never looked at the connect source code, so I can't even guarantee that I can provide a working patch ;-)
19:00:11 * manugupt1 gives a blank and bland stare at suseROCKs wiping his eyes
19:00:15 <cboltz> but that are technical details - if everything else fails, I can still write a PHP webform ;-)
19:00:21 <henne> cboltz: its simple php. there is a workshop at the conference
19:00:41 <simon123> nitty gritty details cboltz :)
19:00:53 <henne> okay next topic
19:01:07 <cboltz> ok - I'll sort out the list and contact AJ then
19:01:17 <henne> #topic Proposal from Manu Gupta on Google Code-In
19:01:26 <henne> manugupt1: go ahead :)
19:01:44 * suseROCKs splashes cold water on manugupt1  to keep him awake
19:01:52 <manugupt1> Hi I like gsoc google organizes google code in
19:02:02 <manugupt1> Code in is meant for under 18 kids
19:02:18 <manugupt1> And usually involves translation, documentation and other stuff
19:02:35 <manugupt1> Sometimes even code for exceptionally bright students
19:02:59 <manugupt1> We can organize it to get our docs and other stuff to be better for 12.1 release
19:03:16 <manugupt1> usually starts in november / decemebr and lasts for 2 months I guess ( not sure)
19:03:31 <manugupt1> Thats it
19:03:57 <AlanClark> manu, what would be required from the community? mentors?
19:04:05 <suseROCKs> manugupt1,  can you give us some details like what it takes to be a mentor in this program and if there are any details liek deadlines?
19:04:18 <manugupt1> AlanClark: Mentors people who are already working on stuff
19:04:47 <manugupt1> Deadlines and stuff I am not sure suseROCKs did not research much
19:05:02 <Goku283> Hey thanks guys for letting me be apart of this.  im signing off now.  it is 4.35am here and i want to watch my matrix now and get some beauty sleep :)
19:05:18 <Goku283> Thanks simon123 for the help with the codec issue :P
19:05:19 <suseROCKs> ok we may not be able to mentor in time for 12.1 but we most certainly could use such help on documentation and wiki translations as an ongoing process
19:05:27 <manugupt1> Yes..
19:05:35 <manugupt1> suseROCKs: I mean after that
19:05:45 <suseROCKs> Goku283,   thanks for coming by and please do come by often.  We meet here every two weeks
19:05:47 <manugupt1> But the working methodology is this
19:05:55 <AlanClark> manugupt1 do you have a URL?
19:05:57 <manugupt1> We have a list of tasks
19:06:12 <manugupt1> AlanClark: One sec
19:06:23 <manugupt1> AlanClark: http://www.google.co.in/url?sa=t&source=web&cd=1&ved=0CCsQFjAA&url=http%3A%2F%2Fcode.google.com%2Fopensource%2Fgci%2F2010-11%2Findex.html&rct=j&q=google%20code%20in&ei=odZCTuCfNs7LtAag7t3yBw&usg=AFQjCNH3Wyls7bOR-ADVc0rU3MeFv3YV4w&sig2=aXHD58gdFAerNBWw2xZLLQ&cad=rja
19:06:30 <manugupt1> Oops
19:06:37 <manugupt1> http://code.google.com/opensource/gci/2010-11/index.html
19:06:48 <suseROCKs> :-)
19:06:57 <suseROCKs> ok folks I'd like to say one thing here
19:07:26 <suseROCKs> we seriously dragged our feet on getting GSoC organization for this year, and manugupt1 did an awesome job kicking asses and we now have a very successful GSoC season
19:07:40 <tian2992> :D
19:07:58 <suseROCKs> he has proven that we benefit greatly from such programs and we should most indeed not ignore such an opportunity to further engage students with our Project through such programs
19:08:42 <suseROCKs> And I move that the board takes a look at this closely and determines how to poke and encourage the Project to get involved in this
19:09:08 <suseROCKs> I would not want to rest all the hard work on Manu as we did last timie for GSoC.   He has more than enough on his plate and has done fabulously well and we shouldn't expect him to always do all the work
19:09:44 <henne> so you propose the board is trying to find someone that does it?
19:09:53 <suseROCKs> yes
19:10:07 <henne> okay +1
19:10:44 <suseROCKs> does one of us want to take the AI to follow through on this or shift it to me?
19:10:49 <AlanClark> I like this idea; am looking through the website for more details
19:11:18 <AlanClark> suseROCKS - go for it
19:11:32 <suseROCKs> AlanClark,   So do I.   I haven't looked at the details yet, but manu's summary sounds very promising
19:12:35 <suseROCKs> ok
19:12:40 <simon123> Participating Open Source Projects is list of dead links
19:13:11 <suseROCKs> #action suseROCKs to investigate Google Code-In and make plan of action for finding someone to organize and lead it
19:13:28 <AlanClark> let's continue discussion on this through email
19:13:35 <suseROCKs> yes
19:14:05 <cboltz> suseROCKs: do you need/want an AI in bugzilla?
19:14:36 <suseROCKs> cboltz,  yes
19:14:42 <suseROCKs> and /yes   :-)
19:14:44 <AlanClark> thanks manugupt1 for introducing this
19:14:59 <manugupt1> welcome
19:15:18 <suseROCKs> if mrdocs can wake up we can add topic of the trademark requests.  Seems we have something come in just a little while ago?
19:15:37 <AlanClark> the trademark request on the list was covered last time
19:15:57 <cboltz> suseROCKs: bug 711572 filed
19:16:00 <bugbot> openSUSE bug 711572 in openSUSE.org (Action Items) "[AI] Google Code-in" [Normal,New] https://bugzilla.novell.com/711572
19:16:00 * AlanClark failed to remove it from the wiki
19:16:39 <henne> okay do we have any other topic to cover then?
19:16:41 <suseROCKs> grassy-arse cboltz
19:17:01 <suseROCKs> AlanClark,   there was some "2nd request" come in just in the last couple of hours
19:17:08 <suseROCKs> I haven't opened it yet....  /me goes to open it
19:17:23 <AlanClark> I haven't looked at it.  Let's save that for next time.
19:17:24 * cboltz searches for a bottle of sparkling wine to celebrate his 1000th (open)SUSE bugreport
19:18:07 <AlanClark> henne, I think that covers today's agenda
19:18:25 <henne> okay
19:18:32 <henne> thank you all for participating
19:18:34 <suseROCKs> wait  I have a new topic
19:18:53 <suseROCKs> topic:  Can we share cboltz's 100th bug wine celebration?
19:18:54 <henne> yeS?
19:19:05 <suseROCKs> err 1,000th
19:19:19 <AlanClark> no wine bugs for me
19:19:38 <suseROCKs> AlanClark,   haven't you seen Napa Valley's latest creation?  Root Beer Wine!
19:20:00 <AlanClark> I'm waiting for henne to come up with a SUSE Breu root beer for me
19:20:26 <cboltz> suseROCKs: someone here in germany sold a mix of beer and wine in the past
19:20:26 <suseROCKs> I'll drink to that
19:20:41 <cboltz> it was named "impossible" - and that describes the taste very well :-/
19:20:49 <AlanClark> lol
19:21:01 <henne> AlanClark: the only thing I can give you is the Rod ;)
19:21:12 <henne> okay we're done
19:21:19 <henne> #endmeeting