18:36:23 <tittiatcoke> #startmeeting
18:36:23 <bugbot> Meeting started Tue Feb  5 18:36:23 2013 UTC.  The chair is tittiatcoke. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:36:23 <bugbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:36:56 <tittiatcoke> #meetingtopic Welcome to the openSUSE KDE community IRC meeting! Please wait with other discussion until the meeting is over. This meeting is logged.
18:37:22 <tittiatcoke> Ok. Our agenda for tonight is:
18:37:31 <tittiatcoke> 1) Action Items
18:37:36 <tittiatcoke> 2) Status Report
18:37:46 <tittiatcoke> 3) Final validation before Pre-release 12.3. Do we need any improvements/fixes for 12.3 ?
18:37:54 <tittiatcoke> 4) KDE 4.10.0 status.
18:38:01 <tittiatcoke> 5) KDE:Release:410 repository.
18:38:07 <tittiatcoke> 6) Q&A, misc
18:38:11 <tittiatcoke> Any other topics ?
18:38:42 <tittiatcoke> Ok. First topic then.
18:38:47 <tittiatcoke> #topic Action Items
18:39:03 <tittiatcoke> Action: tittiatcoke keep the discussion apper/kupdateapplet on the actionlist until we know what happens with the PackageKit zypp backend.
18:39:34 <tittiatcoke> This one can be closed as that the Zypp backend was migrated to the new PK 0.8 and we have also a new apper in KDF/12.3/Factory
18:39:46 <rabauke> cool
18:40:11 <rabauke> out of curiosity. migrated by who?
18:40:21 <tittiatcoke> rabauke: coolo :-)
18:41:01 <rabauke> so he is the new zypp maintainer :p
18:41:16 <tittiatcoke> I guess he had enough of zypp and PK after this one :)
18:41:58 <cb400f> well, RH will break api again next week.. that's a given
18:42:30 <tittiatcoke> Target for the Zypp team is still to make a real rewrite of the zypp-backend to take advantage of the pk 0.8 possibilities and to enable that certain actions can be executed in parallel
18:42:37 <rabauke> we can only complain about that if at least everything zypper related has been done. which was not the case in the past.
18:42:57 <rabauke> complain about RH breaking the api.
18:43:18 <tittiatcoke> :-)
18:43:28 <cb400f> maybe the zypp team could find the resources if RH didn't make them start from scratch every other week... but we digress
18:44:43 <tittiatcoke> Maybe. But for now we are safe :-)
18:44:59 <rabauke> as if they ever started. :)
18:45:18 <tittiatcoke> Ok. Guys. Next action point. :-)
18:45:21 <tittiatcoke> Action:  wstephenson will work on ksuseinstall (bug#671578)
18:45:44 <tittiatcoke> Ok. Will check with Will tomorrow on this one.
18:46:07 <tittiatcoke> Action tittiatcoke ask llunak if he is willing/interested to support ksuseinstall. If not then ksuseinstall will be dropped
18:49:20 <tittiatcoke> On this I can report that I had contact with llunak and he was a little surprise that we are willing to drop ksuseinstall as that it was a much wanted topic back then. However he also indicated that he doesn't really have the time to help out on this.
18:50:13 <rabauke> well, of course ksuseinstall would be very wanted. If it was maintained and worked as expected.
18:51:02 <tittiatcoke> Unfortunately we don't have the feedback from will on the indicated bug
18:51:21 <rabauke> then leave it on the action list for next time
18:51:34 <cb400f> it'd be excellent if the packman repo was default ;-) ... but without that, I'm not sure of the value, even if bugs are fixed
18:52:08 <cb400f> also, cuz of bugs and spam in the mime db apparently, which we are defenseless against
18:52:21 <tittiatcoke> rabauke: Ok.
18:52:31 <tittiatcoke> cb400f: That is also correct
18:54:08 <tittiatcoke> Let's leave it for the next meeting, then we can discuss with Will if he can provide some more support on this. It is too late to make this kind of change for 12.3 anyway.
18:55:02 <tittiatcoke> Next action item.
18:55:05 <tittiatcoke> Action:  tittiatcoke check the updater/packagekit situation in Gnome and validate open bugreports for Apper
18:55:40 <tittiatcoke> This one can be closed due to the update to PK 0.8 and Apper 0.8. Existing bug reports for Apper were validated against the new version and closed.
18:56:30 <tittiatcoke> Also 12.3 will bring a solution in libsolv where the zypp backend would prefer to install an update despite that this would cause a downgrade of other applications (e.g. KDE)
18:57:22 <tittiatcoke> Next action:  alin to push simon to KDE:Extra
18:57:30 <alin> tittiatcoke: done...
18:57:41 <tittiatcoke> alin: Thanks
18:57:51 <alin> tittiatcoke: only licenses are the issue as they are not listed in spdx... or whatever is the official list
18:58:19 <tittiatcoke> Ok. Did you contact legal for that one ?
19:00:28 <tittiatcoke> alin: Can I put an action for you to contact legal about those licenses ?
19:01:03 <alin> tittiatcoke: ok
19:01:17 <alin> tittiatcoke: I think I will open bugs in bugzilla
19:01:22 <tittiatcoke> #action alin contact Legal with regards to the licenses for Simon.
19:01:25 <tittiatcoke> alin: Ok
19:01:42 <tittiatcoke> Last action item:  cb400f Check with the evergreen maintainers if they are willing to maintain KUA for 11.4. If not, then drop the repo
19:02:17 <cb400f> oh, it was decided to just drop 11.4 for kua.. but hasn't been done
19:02:19 * cb400f kjots
19:02:25 <tittiatcoke> cb400f: Ok :-)
19:02:35 <tittiatcoke> #action cb400f Drop 11.4 for KUA
19:02:52 <tittiatcoke> Ok. Those were the action items
19:03:03 <tittiatcoke> #topic Status reports
19:03:16 <tittiatcoke> Anybody wants to give an update ?
19:03:34 <rabauke> I saw KR410 was ready. :p
19:04:56 <tittiatcoke> Yeah :-)  Last Friday evening I pushed KDE 4.10.0 (official) tarballs into KDF, got it build for Factory and pushed it on Monday to Factory. It has been accepted and forwarded to 12.3. So hopefully we will get the RC1 with KDE 4.10.0. Based on the status in KDF, I created KR410 and had it build for 12.2. So once the announce is made, we can announce the KR410 repo.
19:06:06 <tittiatcoke> shumski: Any updates on the artwork ?
19:06:24 <shumski> tittiatcoke: it is finished as i'm concerned
19:06:46 <shumski> i only need to push kdelibs branding
19:07:20 <shumski> and we need a video for the greeter
19:08:10 <tittiatcoke> jos promised to work on that one this week
19:08:25 <shumski> ok
19:08:40 <shumski> just to have it for final
19:08:54 <tittiatcoke> :-)
19:09:20 <tittiatcoke> Anybody else for a status update ?
19:10:35 <tittiatcoke> Ok. Next topic then.
19:10:39 <tittiatcoke> #topic Final validation before Pre-release 12.3. Do we need any improvements/fixes for 12.3 ?
19:11:29 <tittiatcoke> We started this already during the status report. What are still outstanding items ?
19:11:29 <rabauke> nepomuk is crashing if indexing lots of files due to a Qt bug. https://bugreports.qt-project.org/browse/QTBUG-18934
19:11:32 <alin> tittiatcoke: I would like shumski to have a look at greeter and do the final arrangements for the last row
19:11:50 <alin> tittiatcoke: also we need to be sure we sync with Jos for the video
19:12:13 <shumski> rabauke: i experienced that alot during beta2/rc1 phase, but it is gone for me
19:12:56 <alin> shumski: rabauke was not that fixed by some qt patch you pushed during hackaton
19:12:58 <alin> ?
19:13:12 <shumski> alin: no, that's a differnet thing
19:13:17 <rabauke> shumski: the Qt developer stated that he is not going to fix it. So either it was not that bug or it stopped because nepomuk does not index that much anymore.
19:13:35 <cb400f> we still have the indexer off by default right?
19:13:35 <rabauke> shumski: and I still get it with KDF
19:14:37 <rabauke> having this bug would be one argument in the discussion whether to leave it off. and it helps to understand users complaining if one knows that there is a bug which is not going to be fixed upstream.
19:14:40 <shumski> rabauke: ok, i don't have it with master, and with most files at index level #2. probably the second then
19:15:17 <tittiatcoke> rabauke: I will also validate this with vhanda to see if there is something he can do within the fileindexers.
19:15:35 <tittiatcoke> #action tittiatcoke talk to vhanda about https://bugreports.qt-project.org/browse/QTBUG-18934 and the fileindexers
19:16:25 <rabauke> there is even a bko bug. but I can't remember which one. will tell you when I am on the other computer. krop might know.
19:16:38 <shumski> https://bugs.kde.org/show_bug.cgi?id=310777
19:16:38 <tittiatcoke> ok.Thansk
19:16:38 <bugbot> KDE bug 310777 in nepomuk (fileindexer) "Crash -  QProcess::waitForFinished - Running out of file descriptors" [Crash,Unconfirmed: ]
19:16:50 <tittiatcoke> :-)
19:16:53 <shumski> one of most duplicated lately for nepomuk
19:17:10 <rabauke> in KDEPIM 4.10 there are apparently a few regressions. :( kdepim-devel is discussing them and a kolab dev mentioned that he gets some body losses again… :(
19:17:22 <rabauke> shumski: yep. that's the one
19:17:49 <rabauke> I could add several dups per day. and the problem is that after that crash virtuoso-t goes berserk
19:17:53 * krop vanishes
19:18:08 <tittiatcoke> krop: Thanks
19:18:35 <shumski> i'm subscribed to nepomuk-bugs so i get spammed a lot :-)
19:19:06 <tittiatcoke> ok
19:20:43 <tittiatcoke> Ok. Anything else what we need to follow-up on ?
19:21:12 <rabauke> is migrating to kdepim2 still an issue?
19:21:15 <shumski> tittiatcoke: and about systemd patch?
19:21:26 <tittiatcoke> shumski: Which systemd patch ?
19:21:27 <shumski> is it the latest version in KDF?
19:21:36 <shumski> for kde-workspace
19:21:47 <tittiatcoke> shumski: As far as I know, yes
19:21:52 <shumski> ok :-)
19:22:11 <tittiatcoke> rabauke: I don't know. I migrated long time ago :-)
19:22:36 <cb400f> I suspect it becomes a bigger issue every release... but who is still on <= 4.6 ?
19:23:14 <tittiatcoke> cb400f: I guess only a very few, but I also saw messages about people still being on 11.4 :-)
19:23:34 <cb400f> but those prolly had all kinds of kr4x stuff going on :-)
19:23:39 <tittiatcoke> :-)
19:24:23 <rabauke> there is now even someone build kmail1 against KDE4
19:24:39 <shumski> debian style
19:24:49 <tittiatcoke> :-)
19:25:17 <rabauke> main issues still are, collecting email from a spool mailbox and slow when building up the DB on first import with lots of emails, i.e. > 10000
19:25:41 <rabauke> and filters not working reliably.
19:26:18 <shumski> i have switched to server side filters, but i remeber it was an issue before, don't know the current status
19:27:05 <alin> rabauke: they kind of work for me
19:27:36 <rabauke> kind of, yes. better for imap than for pop3 as it seems.
19:28:05 <alin> rabauke: I have no pop3
19:29:51 <ctrippe_> filters with pop3 are still annoying
19:30:00 <cb400f> hrmpf
19:30:12 <ctrippe> Sorry for being late for the meeting
19:30:26 <rabauke> https://bugs.kde.org/show_bug.cgi?id=286793 is the bug about /var/spool/mail
19:30:27 <bugbot> KDE bug 286793 in Akonadi (MBox Resource) "kmail2 cannot spool mail from /var/spool/mail/$USER to inbox" [Normal,Confirmed: ]
19:30:45 <tittiatcoke> ctrippe: No problem. We are just discussing open topics that would need some kind of action for 12.3
19:32:08 <rabauke> what about having kio_mtp in the default installtion since that protocol becomes more and more popular.
19:32:14 <rabauke> probably too late I guess.
19:32:22 <rabauke> but then for next time. :)
19:32:57 <ctrippe> tittiatcoke: I did not have the time to update to Factory but KDF on 12.2 looks good for me and also the bug reports don't look to bad for me.
19:33:01 <shumski> it is in for 12.3, don't know about default. tittiatcoke?
19:33:04 <tittiatcoke> rabauke: As far as I know it is in factory and in 12.3
19:33:13 <tittiatcoke> shumski: It is not part of the default installation
19:33:15 <rabauke> tittiatcoke: ah. nice.
19:33:38 <cb400f> ctrippe: did you check if the nepomuk indexer is disabled by default for new users? :-)
19:34:01 <cb400f> if that is disabled, I guess nothing can go totally wrong
19:34:30 <shumski> that hasn't changed since 12.2
19:35:00 <cb400f> ah, good, I feared it might, since apparently strigi was replaced with something nepomuk
19:35:04 <ctrippe> cb400f: no, I did not check but it even works for me at the moment :-)
19:35:31 <shumski> [Service-nepomukstrigiservice] --> autostart=false
19:36:01 <cb400f> hm, so it's still strigi? .. or they just call it that?
19:36:14 <shumski> service is still called like that
19:37:04 <shumski> cb400f: i'll check with another user tlater
19:37:54 <shumski> cause my nepomukserverrc has Service-nepomukfileindexer
19:39:27 <ctrippe> I would say it file-indexing is on, as it is like this with a new user with KDF on 12.2 :-(
19:39:53 <tittiatcoke> Ok, then we should update the rc to switch this one off as well.
19:40:01 <cb400f> yep
19:40:14 <tittiatcoke> #action tittiatcoke switch off the new nepomukfileindexer by default and push to 12.3
19:40:44 <shumski> and how about akonadi?
19:41:15 <cb400f> I guess the workspace still starts it.. but at least akonadi won't act crazy unless you actively load data into it
19:41:48 <cb400f> personally of course I think it's a bad mistake for the default workspace to start akonadi.. but we've discussed that before :-)
19:42:32 <shumski> kdebase4-workspace-plasma-calendar is split, and i0m not sure it's there by default
19:42:59 <cb400f> oh, but there are also a couple of krunners which might start it
19:43:09 <cb400f> (contacts, events iirc)
19:43:17 <ctrippe> I think the default workspace does not have akonadi. There was even a bug report that kdebase4-workspace-plasma-calendar was not installed by default
19:43:21 <shumski> those are disabled in rc's
19:44:06 <cb400f> hm, that sounds awesome to me if true.. should shave off some seconds of kde startup and quite a few megs of memory for most users
19:44:39 <ctrippe> cb400f: But be aware that thunderbird recommends tracker :-(
19:44:44 <cb400f> also, people get quite confused when they don't have kmail running, and still are asked for kwallet passwd and such
19:44:45 <shumski> this is the list http://paste.opensuse.org/55637251
19:45:15 <einar77> ugh
19:45:24 <rabauke> firefox might also recommend tracker, at least I do not have TB but got tracker
19:45:25 <einar77> I was on the phone 40+ mins
19:45:27 <cb400f> wth? ... is that a suse packaging thing? .. or has upstream TB gone mad?
19:45:28 <einar77> sorry for being this late
19:46:02 <shumski> rabauke: i think that's true, when i installed 12.2 for testing, i got the miner
19:46:26 <ctrippe> I am not really sure that it was TB but I was really shocked by finding it on my wifes 12.2 box
19:46:28 <tittiatcoke> einar77: Welcome :-) We are discussing topics that still needs to be done for 12.3
19:46:56 <rabauke> get rid of tracker for KDE installs would be an item then.
19:47:13 <shumski> yup
19:47:21 <einar77> it gets installed through indirect deps, I assume?
19:48:24 <cb400f> we're not sure what pulls it.. but apparently something does
19:48:44 <einar77> can't rpm generate a dependency graph or something?
19:49:07 <tittiatcoke> cb400f: I can't find anything tracker related in Thunderbird
19:49:34 <rabauke> tittiatcoke: and firefox?
19:50:06 <cb400f> einar77: I don't think there's any easy way to get an overview of recommdends though
19:51:01 <einar77> hmm
19:51:07 <einar77> I wonder if it's tracker-miner-firefox?
19:51:32 <tittiatcoke> rabauke: Also nothing.
19:52:56 <rabauke> einar77: sounds reasonable
19:53:10 <einar77> however I have no way to check if it's that one
19:54:15 <tittiatcoke> einar77: Question is why that one gets installed ?
19:54:19 <shumski> only thing firefox recommends is libcanberra
19:56:08 <tittiatcoke> einar77: the tracker-miner-firefox has this one Supplements:    packageand(%{_name}:MozillaFirefox},  but that would mean that tracker also need to be installed
19:56:47 <einar77> before installing firefox, you mean?
19:56:53 <tittiatcoke> yup
19:57:21 <ctrippe> I think I made a false report. I always thought it was thunderbird which triggered the installation of tracker with my update for 12.2. But it seems it was evince (no idea why a pdf viewer should recommend a file indexer maybe via branding)
19:57:23 <tittiatcoke> the tracker-miner-firefox will be suggested if you want to install both tracker and firefox. Only firefox should not trigger this supplement
19:57:50 <einar77> evince?
19:57:57 <ctrippe> tittiatcoke: +1 (as said false alarm by me)
19:58:41 <ctrippe> einar77: evince=gnome-pdf viewer (sometimes helps if okular fails)
19:58:48 <einar77> on the larger topic of "needs to be done for 12."
19:58:50 <einar77> 12.3
20:00:06 <einar77> let's review what we have
20:00:24 <tittiatcoke> ctrippe: I checked evince, but I don't find anything in there either that would explain tracker :-)
20:00:27 <einar77> I think apper needs widespread testing just in case
20:00:50 <cb400f> yep, both for updates.. and clicking locally downloaded rpms
20:01:08 <einar77> cb400f: I would stress it somewhere (docs?) that's supported for these things
20:01:10 <tittiatcoke> einar77: I guess this will come with the release of 4.10.0 :-) Then the 12.2 users will upgrade to apper 0.8
20:01:22 <einar77> cb400f: but nothing else
20:02:07 <shumski> cb400f: it behaves rather nice with local rpms, had no issues with the latest PK/apper
20:02:10 <cb400f> ideally the name should be changed in systemsettings I guess... but too late now with translations and everything
20:02:23 <einar77> we can thikn about it for 12.3+1
20:02:31 <einar77> I think translators wouldn't be too happy
20:02:35 <cb400f> some people manage to get the crazy idea that it's intended as the main package manager
20:03:00 <einar77> cb400f: that's why I wanted to stress what's supported for
20:03:12 <cb400f> but noone reads docs ;-)
20:03:32 <cb400f> if people read opensuse-guide.org they'd know what tools to use for what
20:03:35 <cb400f> ;-)
20:03:38 <einar77> "Read the docs? What a RADICAL concept!"
20:03:58 <einar77> A tagline I had in 1992ish... looks like it's still actual ;)
20:04:22 <cb400f> more than ever I think :-)
20:04:35 <einar77> nevertheless, we can at least document it somewhere
20:04:37 <einar77> if possible
20:05:13 <cb400f> maybe we should consider writing some wiki page
20:05:29 <einar77> yes
20:05:45 <tittiatcoke> Ok. To whom can I assign this action ?
20:06:09 <cb400f> I can write up something for starters
20:06:15 <tittiatcoke> Ok :-)
20:06:30 <cb400f> if nothing else, I can throw the link at people in #suse
20:06:36 <tittiatcoke> #action cb400f Make a start with a wiki page for apper
20:06:40 <tittiatcoke> cb400f: Ok. Thanks
20:06:46 <cb400f> "see, the wiki says it's only for updates, so that makes it official" :-)
20:06:59 <einar77> I think theming and visuals are settled?
20:07:00 <tittiatcoke> :-)
20:07:02 <cb400f> .. cuz usually the crackpots won't take my word for it
20:07:04 <einar77> (to move on in the list)
20:07:32 <tittiatcoke> einar77: as far as I know, yes
20:07:43 <einar77> shumski: any opinion?
20:07:49 <shumski> einar77: yup
20:08:03 <shumski> i mean, it's settled :-)
20:08:53 <einar77> we're rather close to upstream atm
20:09:30 <einar77> do we have word of true packaging bugs?
20:09:34 <einar77> I mean serious ones
20:10:14 <tittiatcoke> einar77: Not that I know of
20:10:25 <einar77> FYI (for most of people who don't hang here daily), we have developed a habit of poking upstream
20:10:39 <einar77> recently it worked quite well
20:10:54 <tittiatcoke> cb400f: Quick update. Just updated kdebase4-openSUSE with the new default setting for the nepomukfileindexer and pushed it to factory.
20:11:03 <tittiatcoke> einar77: Building 4.10.0 went fine
20:11:05 <cb400f> koolness
20:11:05 <einar77> tittiatcoke: setting being? disabled?
20:11:11 <tittiatcoke> einar77: Yup
20:12:09 * javier is wondering about the new removable media icon (it looks like a beer cup)
20:12:34 <alin> javier: cool.. that was a joke.. is fixed now...but you can send us beer if you want
20:12:39 <alin> javier: to shumski
20:12:40 <shumski> javier: ah, that's old already
20:14:17 <alin> shumski: probably he tried and old reloaded
20:14:43 <einar77> who here is using factory?
20:14:44 <einar77> I mean
20:14:51 <einar77> how do you perceive the overall experience?
20:15:39 * cb400f has downloaded the beta live iso.. but will prolly only have time to test it live :-(
20:15:59 <einar77> because that is IMO what makes us think that's still needed for 12.3
20:16:10 <einar77> (strictly speaking of what *we* do, unrelated to upstreaM)
20:16:17 <javier> Ah, I see :)
20:16:34 <javier> I tred a Factory image
20:17:12 <javier> last time I tried I couldn't get Factory to install on VirtualBox
20:18:12 <shumski> that was due to virtualbox service/drivers, no?
20:18:41 <javier> I don't know
20:18:49 <shumski> https://build.opensuse.org/request/show/149422
20:20:43 <einar77> got to run, looks like today's not my day... I'll check back later
20:21:40 <tittiatcoke> Ok. Anything else in this area ?
20:23:27 <tittiatcoke> Next topic :-)
20:23:36 <tittiatcoke> #topic status KDE 4.10.0 and KDE:Release:410
20:24:38 <tittiatcoke> I joined the two agenda points as that they are closely related. As indicate in the status report 4.10.0 was build in both KDF and KR410
20:25:19 <tittiatcoke> KR410 is currently building for 12.2 (Finished) and 12.3. KDF is building also for 12.2, 12.3 and Factory. After release of 12.3, the 12.2 repo will be deleted from KDF
20:25:58 <tittiatcoke> Nothing else to report on this topic.
20:27:05 <tittiatcoke> Next topic ?
20:27:09 <cb400f> sounds good
20:27:23 <tittiatcoke> :-)
20:28:31 <tittiatcoke> #topic Q&A, misc
20:28:50 <tittiatcoke> Ok. Last round :-) Any questions, comments or AOB's ?
20:29:59 <shumski> nope :-)
20:30:10 <tittiatcoke> :-) Going once
20:30:19 <tittiatcoke> .....twice....
20:30:44 <tittiatcoke> Ok. then I will close the meeting.
20:31:19 <tittiatcoke> Thanks everyone for participating. I guess we are in a good shape with KDE for 12.3 :)
20:31:50 <cb400f> we'd better be, cuz 4.8 is starting to feel reeeeeally old ;-)
20:32:16 <tittiatcoke> cb400f: Well, I guess we have now a headstart on other distro's. I believe we are the first one with 4.10 :-)
20:32:28 <cb400f> true
20:32:48 <cb400f> should have about a month or so on kubuntu.. and 2-3 months on fedora
20:33:17 <shumski> mageia?
20:33:29 <shumski> i don't know how they release
20:33:41 <tittiatcoke> Yup. And this time with the new maintainance process we should be able to provide the minor-release updates to 12.3 users :-)
20:33:45 <cb400f> it seems to not be time based
20:34:17 <shumski> that will go through KR410?
20:34:24 <tittiatcoke> shumski: yup
20:35:15 <shumski> ok :-)
20:35:24 <dh64> I blinked and missed 4.10 topic
20:35:41 <tittiatcoke> :-)
20:35:50 <dh64> will be built / avail for 12.1?
20:36:24 <tittiatcoke> dh64: Nope. As agreed in previous meetings each release will only be build against the current (in this case 12.3) and the previous one (12.2)
20:36:42 <dh64> :-(
20:37:02 <shumski> dup time :-)
20:38:09 <tittiatcoke> Ok. I will end the meeting now.
20:38:11 <tittiatcoke> #endmeeting