18:31:06 <tittiatcoke> #startmeeting
18:31:06 <bugbot> Meeting started Tue Jan  8 18:31:06 2013 UTC.  The chair is tittiatcoke. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:31:06 <bugbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:31:23 <tittiatcoke> #meetingtopic Welcome to the openSUSE KDE community IRC meeting! Please wait with other discussion until the meeting is over. This meeting is logged.
18:31:34 <tittiatcoke> The agenda for tonight is:
18:31:49 <tittiatcoke> 1. Should we remove things which were maintained by SUSE before and are basically unmaintained now, e.g. kio_sysinfo (ctrippe)
18:31:56 <tittiatcoke> 2. Status KDE 4.10 release
18:32:02 <tittiatcoke> 3. Status KDE 4.9.x releases
18:32:08 <tittiatcoke> 4. Artwork (openSUSE KDE Desktop theme, lightdm-kde-greeter, etc)
18:32:16 <tittiatcoke> 5. Include KDE Telepathy in openSUSE 12.3
18:32:32 <tittiatcoke> 6. Validation/Status of the items on our KDE Improvement page.
18:32:40 <tittiatcoke> 7. Remove old repositories (krop) concerned: KR46, KR47(?), K:U:P/(KR47,KR48,KR49_12.1)
18:33:27 <tittiatcoke> Any other topics ?
18:33:39 <alin> 8. Other issues
18:33:45 <rabauke> 8. Misc :p
18:33:46 <tittiatcoke> :-)
18:33:46 <alin> simon...  there
18:34:00 <tittiatcoke> I didn't want to list the standard topics :-)
18:34:10 <tittiatcoke> Ok. Let's start with the old action items
18:34:25 <tittiatcoke> #topic Action Items
18:34:35 <tittiatcoke> items from the last meeting:
18:34:45 <tittiatcoke> tittiatcoke shumski update the kdebase4-openSUSE github repo with the new plasma-theme and submit to factory
18:34:48 <tittiatcoke> This one is done
18:35:04 <tittiatcoke> tittiatcoke keep the discussion apper/kupdateapplet on the actionlist until we know what happens with the PackageKit zypp backend.
18:36:09 <tittiatcoke> Status here is that the zypp backend is not adjusted so far, but it seems we found a new volunteer that is willing to port the zypp backend to the new PackageKit version. Dantti has offered his help here as that he is interested in getting the new apper version released/shipped
18:36:36 <rabauke> what a shame for the zypp maintainers
18:36:36 <tittiatcoke> next action tittiatcoke set out an actionplan to decouple KR49 from KDF and then to update KDF with the 4.10 packages
18:37:25 <tittiatcoke> rabauke: I know. I send out an email to the ML to get feedback on what they wanted to do, but almost no feedback. It seems that they lost interest in the new PackageKit (or they do not have the time)
18:38:09 <tittiatcoke> The decoupling of KR49 from KDF has been done. And KDF contains 4.10 RC2 atm. (see also separate agenda point)
18:38:27 <tittiatcoke> adra push kde-gtk-config to KDF for inclusion in Factory.
18:38:38 <tittiatcoke> adra: afaik, this is done, right ?
18:38:53 <adra> yes
18:39:08 <tittiatcoke> wstephenson & einar77 create a patch-formatter to add the kde standard headers.
18:39:20 <tittiatcoke> wstephenson: Any status on this one ?
18:39:40 <wstephenson> no, sorry
18:39:50 <tittiatcoke> No problem :-)
18:39:59 <tittiatcoke> einar77, ctrippe Organize a bug squashing for the KDE bugs in 11.4.
18:40:24 <tittiatcoke> I believe this was done. At least there was a week of cleaning up bugs, etc :-)
18:40:42 <shumski> yup, few moths ago :-)
18:40:44 <wstephenson> we discovered that having 2 kids is more work than 1...
18:41:08 <alin> wstephenson: can't you return the second?
18:41:15 <tittiatcoke> :-) I know. But believe me it will get better eventually :)
18:41:16 <alin> wstephenson: customer rights...
18:41:52 <wstephenson> i could ask my wife but i wont be able to code if she knocks me out
18:42:37 <tittiatcoke> Let's not do that :-) We don't want anybody getting hurt :p
18:42:53 <tittiatcoke> ctrippe_: Are you there ?
18:42:58 <krop> have to leave, sorry.
18:43:11 <tittiatcoke> krop: Ok.
18:43:32 <ctrippe_> tittiatcoke: yep, sorry.
18:43:35 <tittiatcoke> #topic Should we remove things which were maintained by SUSE before and are basically unmaintained now, e.g. kio_sysinfo
18:43:41 <ctrippe_> The bug squashing happend
18:43:59 <tittiatcoke> ctrippe_: Ok :-) But you raised also the indicated topic about kio_sysinfo.
18:44:05 * plinnell waves
18:44:28 <tittiatcoke> ctrippe_: Could you explain ?
18:45:25 <ctrippe_> We have severel things packaged which were maintained by suse before and are to my knoledge no unmaintained, e.g. sysinfo
18:45:46 <ctrippe_> You will find several bugs about it which nobody cares to fix
18:46:20 <rabauke> what about moving them upstream into their unmaintained folder?
18:46:26 <cb400f> I also tend to think sysinfo is doing more harm than good these days
18:46:45 <cb400f> dunno if there are any other examples though
18:46:53 <rabauke> their = KDE
18:46:59 <tittiatcoke> rabauke: I believe that sysinfo is already somewhere on KDE git
18:47:30 <tittiatcoke> wstephenson: do you know what happened with sysinfo ?
18:47:37 <rabauke> tittiatcoke: then it can be removed IMHO if it causes trouble.
18:47:40 <ctrippe_> cb400f: We have other patches like ksuseinstall..
18:47:55 <wstephenson> it is upstreamed, but there are distro specific backends
18:47:57 <cb400f> true.. that one prolly does more harm than good too
18:48:26 <tittiatcoke> wstephenson: Ok.
18:48:38 <tittiatcoke> ctrippe_: But do we have bugs reported for ksuseinstall ?
18:48:48 <cb400f> I have at least one
18:48:49 <wstephenson> cb400f: details?
18:49:09 <cb400f> https://bugzilla.novell.com/show_bug.cgi?id=671578
18:49:13 <bugbot> openSUSE bug 671578 in openSUSE 12.2 (KDE4 Workspace) "ksuseinstall does not respect "don't ask again"" [Normal,New]
18:50:22 <cb400f> wstephenson: it'll install weird gnome apps for handling things cuz of issues with .desktop files/mimetypes I guess.. and prompt people about missing stuff which is not available in their repos anyway
18:50:22 <wstephenson> trivial to fix
18:50:29 <cb400f> yet noone has done it in years
18:50:50 <tittiatcoke> wstephenson: You will take that one ?
18:51:21 <wstephenson> bigger problem that we dont wontfix bugs we wont fix..
18:51:25 <wstephenson> tittiatcoke: sure
18:51:29 <tittiatcoke> Ok :-)
18:52:10 <tittiatcoke> #action wstephenson will work on ksuseinstall (bug#671578)
18:52:34 <ctrippe_> cb400f: about installin mimetypes. It searches for apps supporting the mimetype and installs the fist one. ANd 'g' comes before 'k'
18:52:39 <tittiatcoke> wstephenson: But the wontfix bugs, I guess is a global issue and not just for KDE bugs ?
18:53:30 <wstephenson> tittiatcoke: yes
18:53:35 <tittiatcoke> Ok :-)
18:53:52 <einar77> ok sorry
18:53:58 <einar77> I managed to arrive at last
18:54:21 <tittiatcoke> einar77: hi. We are at the first agenda item with regards to suse specific tools.
18:54:40 <einar77> quikcly checking the backscroll
18:55:22 <tittiatcoke> What would be the opinion for kio_sysinfo ?   Drop it or try to fix it ?
18:55:36 <einar77> tittiatcoke: point 1. does it work?
18:55:44 <einar77> point 2. does it have outstanding issues?
18:56:19 <tittiatcoke> einar77: both points is yes. I am not sure what outstanding issues we have
18:56:52 <einar77> I would argue for dropping then
18:56:53 <cb400f> people always click on internal filesystems and expect them to be mounted/accessed... and it doesn't happen
18:58:18 <einar77> My rationale for not dropping "custom" tools is: a. be self-maintaining (i.e. trivial stuff, stable for years etc) b. have someone (from the community?) maintain it
18:58:33 <einar77> but I'd rather go for a.
19:00:13 <wstephenson> me too
19:00:40 <einar77> and then the follow-up question is, do we have tools which fulfill the "a" requirement?
19:00:47 <einar77> kio_sysinfo does not look like one
19:00:53 <cb400f> it's dead weight.. with little added value over what kde provides.. and bugs and no maintenance
19:01:03 <einar77> my vote goes for axing
19:01:06 <cb400f> I'd vote to drop the greeter too now that we're at it
19:01:09 <wstephenson> +1
19:01:13 <einar77> cb400f: which greeter?
19:01:26 <cb400f> the one with all the outdated information on first login
19:01:26 <wstephenson> SUSEgreeter
19:01:28 <shumski> SUSEgreeter
19:01:28 <einar77> the stuff that appears at startup?
19:01:35 <tittiatcoke> cb400f: Why that one ?
19:01:36 <einar77> hmmm
19:01:43 <einar77> cb400f: how can that be updated?
19:01:56 <cb400f> I think it's a html file in git somewhere
19:02:11 <shumski> afaik ctrippe_ fixed that link ?
19:02:30 <einar77> cb400f: if it's just HTML, it should be just fixed
19:02:50 <cb400f> nah, cuz next release it won't be updated again.. and users don't read it anywho
19:02:56 <ctrippe_> It's html + a bit of code
19:03:19 <rabauke> pull it out of git and put it into the package so everybody with access to obs' webgui or more can update it
19:03:57 <einar77> hmmm perhaps
19:05:04 <tittiatcoke> rabauke: At this moment it is in the kdebase-opensuse github repo, where we also have the other KDE defaults (plasma, etc). We have access to that one and we are building the package (kdebase4-openSUSE)
19:05:35 <shumski> and the link now points to userbase.kde.org
19:05:40 <rabauke> but apparently it is too hidden for "casual" contributors
19:05:52 <einar77> userbase.kde.org is quite active wrt end-user docs
19:05:54 <einar77> so it's ideal
19:06:20 <tittiatcoke> rabauke: Then we can agree that the package kdebase4-openSUSE can be maintained on OBS and on regular basis we are updating the git repo.
19:06:53 <rabauke> whatever helps to give easy access to the text that needs to be updated.
19:06:53 <einar77> I would rather do the other way, proper source control is ++
19:07:05 <einar77> (no, OBS isn't a proper VCS)
19:07:17 <tittiatcoke> einar77: true
19:08:03 <einar77> tittiatcoke: perhaps better connections between obs and the repo
19:08:15 <einar77> I have no idea how it is built from there (source service?)
19:08:31 <einar77> in any case, before drifting too far from the topic, I'd say the greeter should not be drpped
19:08:32 <tittiatcoke> einar77: Nope. somebody has to download the git-repo and make the tarball :-)
19:08:38 <einar77> ugh
19:08:47 <tittiatcoke> einar77: :-)
19:09:03 <tittiatcoke> einar77: I guess some optimization can happen there :-)
19:09:23 <tittiatcoke> And no source services allowed in Factory :-) So we need a tarball
19:09:35 <einar77> bleh, yes, requires some thought
19:09:41 <rabauke> what sources should be lost? they are outdated and close to being dropped because of that.
19:09:46 <tittiatcoke> I guess that we reached an alignment to drop kio_sysinfo ?
19:09:49 <einar77> yes
19:09:51 <einar77> I think
19:10:09 <einar77> not sure instead on susegreeter (personally -1 on dropping)
19:10:20 <tittiatcoke> #agreed Drop kio_sysinfo from the KDF/Factory repo's.
19:10:37 <tittiatcoke> Who is in favor to drop the SUSEgreeter ?
19:10:43 <cb400f> o/
19:11:03 <ctrippe_> If we drop sysinfo now, we have to modify a few patches
19:11:39 <tittiatcoke> ctrippe_: Let's see indeed where we have to make adjustments. Maybe we can do this together with RC3.
19:11:44 <plinnell> +1 dropping suse greeter
19:11:54 <plinnell> sysinfo is ok for now
19:12:19 <ctrippe_> I would say: keep the greeterfor now
19:12:38 <tittiatcoke> wstephenson: alin rabauke any preference ?
19:12:56 <tittiatcoke> shumski: ^^
19:13:09 <shumski> i would drop it, but no strong opinion about it
19:13:09 <alin> tittiatcoke: keepit
19:13:09 <rabauke> keep the greeter and make its content easily available, i.e. without git. sysinfo, drop it, if there are major issues.
19:13:15 <rabauke> I do not use it so I cannot tell.
19:13:25 <tittiatcoke> :-)
19:13:42 <alin> the greeter is nice... tohave if not too much trouble I can maintain
19:13:57 <tittiatcoke> #agreed Keep the SUSEgreeter, but make the content easily available for updates.
19:13:58 <alin> at the end there is jsut some text with two links
19:14:03 <ctrippe_> rabauke: There is the tarball in kdebase4-opensuse which also contains the greeter
19:14:21 <tittiatcoke> alin: Yup :-)
19:14:26 <rabauke> ctrippe_: no need to access any git repo?
19:14:59 <ctrippe_> rabauke: Sure you can patch kdebase4-opensuse like any other package
19:15:09 <tittiatcoke> rabauke: That is what I initially indicated. You can update the tarball and then we have to update the git repo from the tarball
19:15:19 <ctrippe_> The question is if tittiatcokeaccepts such submissions or sents you to git :-)
19:15:51 <rabauke> ok, I will write that down somewhere in the wiki so we can point people to it next time somebody asks how to jhelp
19:15:52 <tittiatcoke> I might easier and faster accept SR's then git pull requests :-)
19:16:02 <tittiatcoke> rabauke: Ok.
19:16:24 <tittiatcoke> Ok. I guess the last one in this area is the ksuseinstall. Dtop it or keep it ?
19:16:38 <cb400f> drop
19:17:27 <tittiatcoke> anybody else ?
19:17:32 <einar77> drop
19:17:43 <alin> tittiatcoke: what is that for?
19:17:45 <ctrippe_> drop it because of the mimetype stuff and keep because of working kaffeine + libxine-codecs -> no vote from me
19:18:25 <remur_030> alin: it hooks into a few mimetypes to grab codecs when they are not available
19:18:37 <rabauke> ping llunak whether he wants to take care of his baby. if not drop it
19:18:54 <cb400f> also if you click on a .php it
19:18:54 <alin> rabauke: I was rhetoric...
19:18:54 <ctrippe_> alin: http://help.opensuse.org/ksuseinstall/
19:19:03 <wstephenson> in theory packagekit should offer the same functionality
19:19:04 <cb400f> 'll suggest to install gedit or something like that
19:19:13 <alin> from me drop it...
19:19:35 <tittiatcoke> wstephenson: There is a big difference between theory and practice when it comes to packagekit :-)
19:19:35 <alin> just let us hope gnome does not have something like that that takes over the computer
19:19:50 <wstephenson> the value add ksuseinstall offers should be doing a better job, eg letting you add community repos
19:20:24 <einar77> wstephenson: this value drops like 1/n for n-> inf, if it does not work
19:20:28 <wstephenson> cb400f: that happens because gedit pollutes the mimetype database with excessive capabilities
19:21:09 <cb400f> I can imagine :-) .. but I guess there's no feasible fix for that
19:22:24 <tittiatcoke> So far we have a majority for dropping ksuseinstall.
19:22:55 <shumski> drop it, from me also
19:23:09 <remur_030> I agree with rabauke, maybe llunak has time to maintain it? it's the best opensuse can offer legalwise for 'newcomers'
19:24:16 <tittiatcoke> Ok. Then lets agree that I will ask llunak if he has time/willingness to maintain ksuseinstall. If not, then we drop it. Decision should be made latest by the end of the month (due to 12.3)
19:24:25 <cb400f> he clearly doesn't.. maybe he could be bullied into fixing one or two bugs, and then leave it to bitrot again
19:24:58 <wstephenson> i don't know how interested llunak is in kde at all these days
19:25:20 <wstephenson> he still joins the channel, but i suspect he's just using kor and hacking on libreoffice
19:25:55 <tittiatcoke> wstephenson: Let's see. I think that we owe it to ask him if he is interested to support ksuseinstall or not.
19:26:00 <wstephenson> agreed
19:26:36 <tittiatcoke> #action tittiatcoke ask llunak if he is willing/interested to support ksuseinstall. If not then ksuseinstall will be dropped
19:26:39 <wstephenson> i am looking at that code and the 'don't show again' checkbox should work, the config key is set
19:26:49 <tittiatcoke> ctrippe_: Any other suse specific programs ?
19:26:58 <einar77> do we have others?
19:27:06 <tittiatcoke> einar77: I don't know :-)
19:27:10 <ctrippe_> einar77: sure
19:27:11 <tittiatcoke> I guess not.
19:27:28 <ctrippe_> reduced menu depth in kickoff
19:27:30 <wstephenson> well there was a discussion to use a native updater applet again ;)
19:27:44 <einar77> wstephenson: that's as bad as the "remaining battery time in plasma"
19:27:47 <tittiatcoke> You mean the YOU ?
19:27:59 <ctrippe_> Has one long standing bug but otherwise works, so I amfro keeping it
19:28:20 <einar77> wstephenson: to be honest, I'd prefer that the zypp backend for pk would get some interest, but it's clearly not a priority
19:28:36 <tittiatcoke> ctrippe_: Maybe we should discuss it with the upstream maintainer of kickoff if he/she is willing to take this upstream ?
19:28:48 <cb400f> that guy working on that appstore thingy for gsoc must be really pleased
19:28:57 <rabauke> I thought dantii would take over
19:29:03 <cb400f> but I guess he should have seen it coming
19:29:06 <tittiatcoke> einar77: Dantti offered to help with porting the zypp backend to the new pk
19:29:12 <ctrippe_> tittiatcoke: Sounds good
19:29:36 <einar77> tittiatcoke: it mostly depends on how big of an endeavor is
19:29:45 <cb400f> with some sed scripts
19:29:49 <tittiatcoke> Let's hope that it is as easy as that it sounds :-) But then we get the question if coolo is going to accept a new PackageKit or not for 12.3
19:29:49 <einar77> tittiatcoke: there's no "maintainer" for kickoff
19:30:02 <einar77> also upstream will switch it to a c++/qml hybrid for 4.11
19:30:08 <tittiatcoke> einar77: Ok.
19:30:41 <einar77> (at least, that's the intention)
19:31:08 <tittiatcoke> I guess that all are in favor of keeping the kickoff patch for the reduced menu depth ?
19:31:25 <wstephenson> yes, if it works
19:31:26 <einar77> tittiatcoke: until upstream will diverge (in ~6 months after 4.10)
19:31:29 <rabauke> I have no issues with it
19:31:31 <remur_030> sure, keep it till its broke
19:31:40 <remur_030> erm broken ;-)
19:31:42 <wstephenson> i thought it was broken for a long time? was it fixed?
19:31:47 <cb400f> I prefer the submenus over the upstream model too
19:32:20 <ctrippe_> wstephenson: Yes but only if you start to move thigs in a "bad" way
19:33:05 <ctrippe_> For refernce https://bugzilla.novell.com/show_bug.cgi?id=356553
19:33:08 <tittiatcoke> alternatively we could drop kickoff and switch to homerun :-)
19:33:09 <bugbot> openSUSE bug 356553 in openSUSE 12.2 (KDE4 Workspace) "Creating New KMenu Submenu Makes Single Sub-Menu Items Invisible in K-Menu and Kickoff" [Normal,New]
19:33:34 <einar77> tittiatcoke: weshould consider it for 12.3+1 by starting early and switchign perhaps
19:33:37 <einar77> IF it's viable
19:34:08 <wstephenson> i'm a bit disappointed by homerun tbh. can't seem to keyboard navigate it
19:34:24 <einar77> wstephenson: haven't tested yet (I use only krunner)
19:35:23 <einar77> but I agree on keeping the patch
19:35:27 <tittiatcoke> wstephenson: Correct. The menu's can not be chosen by the keyboard.
19:35:29 <einar77> till it breaks, why not?
19:35:35 <wstephenson> the places category is cluttered
19:35:59 <cb400f> the keyboard thing alone sounds like a shipstopper to me
19:36:10 <ctrippe_> cb400f: +1
19:36:22 <cb400f> none of the 15 fulltime developers bluesystems have on it like to use their kb?
19:36:23 <tittiatcoke> #agreed keep the kickoff patch for reduced menudepth
19:36:39 <tittiatcoke> ctrippe_: Any other that you want to bring up ?
19:36:44 <ctrippe_> no
19:36:46 <cb400f> or maybe it's just intended for touch screens
19:36:49 <einar77> no
19:36:56 <rabauke> no
19:37:08 <tittiatcoke> #topic Status KDE 4.10 release
19:37:27 <einar77> tittiatcoke: what in particular about 4.10?
19:37:43 <wstephenson> cartman approved it for 12.3
19:37:59 <tittiatcoke> I just wanted to give a quick update :-)
19:38:05 <einar77> good, so nightmares about having to rediff my patches are over
19:38:31 <tittiatcoke> I am not sure if everybody knows that we have a 2 week delay in the official release of KDE 4.10 and that this goes over the pre-release freeze for 12.3.
19:38:56 <tittiatcoke> wstephenson: Question is if coolo is fine with it :-)
19:39:58 <tittiatcoke> Based on the delay, I have asked the Release managers if we could have an exception and push 4.10 Final just before the pre-release freeze (4 - 5 February). So far we have a green light from cartman with support from wstephenson.
19:39:58 <rabauke> didn't coolo leave for suse? or was that somebody else?
19:40:04 <cb400f> coolo wrote something about updates on -factory ml today :-)
19:40:09 <tittiatcoke> cb400f: Yup
19:40:13 <wstephenson> especially as we talked about generally enforcing version freeze more strictly this release
19:40:26 <wstephenson> coolo: are you ok with it?
19:41:34 <cb400f> http://lists.opensuse.org/opensuse-factory/2013-01/msg00083.html
19:41:46 <rabauke> while we are waiting. when will kr410 be created?
19:41:48 <cb400f> he says packages with little risk are allowed.. I guess that includes kde sc ;-)
19:42:43 <tittiatcoke> I am planning to create KR410 when RC3 is released.
19:42:53 <rabauke> ok
19:43:10 <alin> wstephenson: tittiatcoke but kde 4.10 would be  out before at least the tar balls
19:43:24 <alin> so technically at the moment we are still before the freeze
19:43:34 <einar77> the tarballs are out 1 week before
19:43:37 <tittiatcoke> alin: I know, but we can not publish the packages officially
19:43:37 <alin> we will simply not publish them on 5
19:43:51 <einar77> alin: it's a bit sophistic, I'd say
19:44:24 <einar77> I mean since we will not publish before the release day
19:44:38 <einar77> (as upstream I'd kill you all if you did ;)
19:44:59 <tittiatcoke> I am sure that we can work things out. :-) Have faith. In the worst case we ship 12.3 with KDE 4.10 RC3 and have a maintenance update ready  when 12.3 is released :-)
19:45:03 <einar77> yes
19:45:24 <rabauke> indeed
19:45:40 <einar77> upstream has also started the testing initiative
19:45:46 <tittiatcoke> So whatever happens the user will get 4,10 final :-) Either with 12.3 or directly as maintenance release.
19:46:19 <tittiatcoke> Ok. I will keep all of you posted on the progress and status of getting 4.10 final into 12.3
19:46:32 <tittiatcoke> With this I would like to switch to the next topic
19:46:40 <tittiatcoke> #topic Status KDE 4.9.x releases
19:47:10 <einar77> I think upstream wants to do one more release
19:47:18 <einar77> but I'm not that up to date
19:47:26 <tittiatcoke> einar77: They do  ?  I thought that 4.9.5 would be the last one.
19:47:30 <einar77> ok
19:47:34 <cb400f> I think so too
19:47:36 <einar77> then we're already at 4.9.5 ;)
19:47:42 <einar77> that was what I was missing
19:48:31 <tittiatcoke> Yup. KR49 got 4.9.5
19:49:48 <tittiatcoke> any questions on KDE 4.9.x ?  Most of the repo's are now disabled from building. And I am wondering if we should keep on providing rebuilds purely based on changes with libqt4
19:50:22 <cb400f> would there be any significant fixes in libqt4 at this point?
19:50:43 <cb400f> sounds like a waste of buildpower and bandwidth to me.. rebuilding that stuff
19:51:04 <tittiatcoke> cb400f: KR49 has already got Qt 4.8.4, so I guess we can keep it that way and not to rebuild it
19:51:37 <tittiatcoke> So for now let's keep them disabled
19:51:49 <tittiatcoke> Next topic :-)
19:51:52 <tittiatcoke> #topic Artwork (openSUSE KDE Desktop theme, lightdm-kde-greeter, etc)
19:52:08 <tittiatcoke> shumski: can you give an update on your work ?
19:53:00 <shumski> shumski: well, i guess we should wait for Beta to get a broader feedback, so far i'm left in a dark wether is this any good :-)
19:53:26 <tittiatcoke> Did everybody saw the new plasma theme ?
19:53:31 <einar77> shumski: more blogging needed? ;)
19:53:50 <shumski> einar77: nope, more testers :-)
19:54:03 <cb400f> I saw screenies.. is it intended as the default?
19:54:14 <tittiatcoke> cb400f: Yup
19:54:40 <marcus> i am currently working on KDM and Ksplash
19:54:43 <shumski> well, my current plan is to fix some icons, and polish the dark colorscheme
19:54:47 <cb400f> just for the record I'm very much against any dark theme as default
19:55:09 <marcus> i think we are not going to stick with a dark color scheme as default cb400f
19:55:33 <cb400f> does the plasma theme follow kde color scheme?
19:55:56 <marcus> it is quite transparent
19:56:01 <shumski> cb400f: we have 3 colorshemes, 2 lighter ones, and one darker which uses the plasma colors
19:56:03 <marcus> but has some noice overlays
19:56:26 <marcus> but i guess we could remove the noice from the plasma theme, as it's now on the wallpaper
19:56:46 <marcus> and yes cb400f the wallpaper will be a mix of dark gray and green.
19:59:43 <tittiatcoke> shumski: Maybe we can make the colorscheme and the plasmatheme seperately available as tarballs ?
20:00:03 <einar77> do we want a lightdm theme? I'm not sure as lightdm is still not suitable for normal usage with systemd
20:00:06 <shumski> tittiatcoke: as in separate packages? sure
20:00:17 <tittiatcoke> then more people can try out at least the colorschemes and maybe also the plasma-theme
20:00:40 <tittiatcoke> einar77: At this moment lightdm can not be used without consolekit
20:00:54 <tittiatcoke> at least not reliable for end-users
20:01:21 <shumski> tittiatcoke: i can make the packages, it's just the question where?
20:01:30 <tittiatcoke> cb400f: Maybe when shumski publish the schems, you can have a look at them, try them out and provide feedback ?
20:01:36 <marcus> tittiatcoke, the plasma theme requires at least a current kde setup and won't fully work on 12.2 but i guess everyone here is up2date ;)
20:02:09 <shumski> marcus: well, will work, just maybe not in a way as with 4.10
20:02:09 <tittiatcoke> marcus: Don't bet on that :-)  I am sure the majority is using 4.9.x :-[)
20:02:20 <cb400f> and I'm on 4.8 even
20:02:22 <marcus> hehe,, ok
20:02:45 <cb400f> but I should get my act together and set up a virtual machine for KDF
20:02:58 <tittiatcoke> :-)
20:03:19 <tittiatcoke> shumski: do we build your theme also for 12.2 in KDF ?
20:03:20 <cb400f> also I'll install 12.3 beta on my testpartition
20:03:27 <tittiatcoke> great
20:03:35 <cb400f> (unless I hear rumours about grub2 messing things up)
20:03:39 <shumski> tittiatcoke: nope, just for Factory
20:03:50 <tittiatcoke> shumski: Maybe we should also make the changes for 12.2 :-)
20:04:05 <shumski> tittiatcoke: good idea :-)
20:04:24 <shumski> it is KDF after all
20:04:24 <tittiatcoke> cb400f: grub2 works :-)
20:04:37 <tittiatcoke> Ok. anything else about the KDE artwork ?
20:04:38 <marcus> it just does not look good ;)
20:04:53 <cb400f> I'm sure grub2 works decently.. it's actually more the yast bootloader setup that worries me a little bit
20:05:02 <tittiatcoke> ;-)
20:05:09 <tittiatcoke> cb400f: Have faith :p
20:05:31 <tittiatcoke> Ok. next topic :-)
20:05:37 <tittiatcoke> #topic KDE Telepathy
20:05:56 <einar77> tittiatcoke: aside the issues with haze, I think it's mature enough to replace kopete
20:06:07 <alin> einar77: what issue with haze?
20:06:15 <einar77> er
20:06:17 <einar77> not haze
20:06:19 <einar77> farstream
20:06:23 <einar77> too many things
20:06:24 <alin> einar77: but that is solved...
20:06:29 <einar77> already?
20:06:39 <alin> einar77: there is a compat package
20:06:44 <shumski> alin: we still don't have call-ui working
20:06:54 <shumski> it's just that it built
20:06:55 <alin> shumski: what do you mean?
20:07:04 <alin> shumski: I can see myself...
20:07:28 <shumski> alin: ok, i tried with a few people, didn't work
20:07:33 <alin> shumski: plus I think that is on top of kopete's capabilities...
20:07:36 <alin> shumski: what did not work?
20:07:46 <shumski> alin: video didn't work
20:07:59 <alin> shumski: strange...
20:08:32 <alin> shumski: does kopete provide video?
20:08:37 <einar77> yes, for some
20:08:39 <einar77> protocols
20:08:42 <shumski> alin: for gtalk afaik
20:08:44 <einar77> not sure if it *works* now
20:08:46 <tittiatcoke> Ok. Despite if things are working or not, I really wonder if we should push it to KDF/Factory now as that it is a new feature. And we have past the 12.3 Feature freeze.
20:08:58 <einar77> tittiatcoke: a little late
20:09:06 <tittiatcoke> Yup
20:09:07 <einar77> offer it in outside repos
20:09:14 <einar77> but more widely advertised
20:09:17 <alin> tittiatcoke: i think we shall have it not install
20:09:20 <cb400f> tittiatcoke:  sflphone wasn't packageable?
20:09:27 <alin> tittiatcoke: as default...
20:10:00 <tittiatcoke> We have KTP in KDE:Extra, so it is available for people and after 12.3 we should move it to KDF so that we can move it to Factory.
20:10:26 <einar77> +1
20:10:32 <shumski> +1
20:10:47 <tittiatcoke> cb400f: sflphone is packaged somewhere in network:telephony
20:11:01 <tittiatcoke> Seems to be an old version however.
20:12:42 <cb400f> yeah, and no kde frontend, right?
20:13:05 <tittiatcoke> cb400f: There is sflphone-client-kde package there (as well as a gnome client)
20:13:34 <tittiatcoke> cb400f: You have the common package and then a package for the kde client and a package for the gnome client
20:13:38 <cb400f> oh, nice.. wonder why it didn't  appear in my webpinstant search
20:14:00 <tittiatcoke> but it seems somehow unmaintained at the moment :-(
20:14:24 <tittiatcoke> I will create an update to the latest version and submit. Let's see if we can take over maintainership there :-)
20:14:53 <tittiatcoke> Anything else on KDE Telepathy ?
20:15:22 <tittiatcoke> #topic Validation/status of the items on the KDE improvement page.  https://en.opensuse.org/openSUSE:KDE_improvements
20:15:25 <alin> tittiatcoke: I am for including it... we may get more people to test
20:15:45 <tittiatcoke> alin: noted. Let's see.
20:16:46 <tittiatcoke> Looking at our improvement pages, I see the following items without a real status:
20:16:55 <cb400f> ktp should definitely be included if possible, but maybe not default.. don't the kubuntu familia already use it as default?
20:17:06 <alin> cb400f: yes
20:17:12 <alin> cb400f: and fedora too
20:17:16 <tittiatcoke> cb400f: I will talk to coolo to see if we still can get KTP in there :-)
20:17:49 <alin> tittiatcoke: knights was ont he list
20:18:03 <tittiatcoke> yup. But nobody picked that one up.
20:18:10 <shumski> tittiatcoke: and check wiith DimStar will he accept compat package. or don't ship call.ui
20:18:14 <alin> tittiatcoke: it is in extra... all it needs is a sr
20:18:16 <cb400f> game of kings needs to be in the distro for kings ;-)
20:18:17 <tittiatcoke> Same goes for Kamoso :)
20:18:25 <cb400f> :-|
20:19:04 <alin> tittiatcoke: I discovered vlc is better to take pictures witht he camera
20:19:10 <tittiatcoke> :-)
20:19:36 <cb400f> initially kamoso used vlc as a backend ;-) .. until it went with always fun gstreamer
20:19:48 <shumski> it has this bug currently https://bugs.kde.org/show_bug.cgi?id=307147
20:19:49 <bugbot> KDE bug 307147 in kamoso (general) "Build failed against libkipi 2.0.0" [Normal,Resolved: fixed]
20:19:58 <alin> tittiatcoke: cb400f https://build.opensuse.org/package/show?package=knights&project=KDE%3AExtra
20:20:02 <alin> say it and I will sr it
20:20:17 <shumski> (it's fixed, but seems kipi plugins don't work)
20:20:19 <alin> I think is already at the last version
20:20:35 <coolo> moin
20:20:43 <tittiatcoke> coolo: Hi :-)
20:21:02 <einar77> evening
20:21:13 <alin> einar77: time is relative.. and persona
20:21:14 <alin> l
20:21:15 <coolo> how are the ladies?
20:22:52 <tittiatcoke> coolo: we have two questions. First one is regarding my email to be able to update KDE 4.10 to Final just before the pre-releaes freeze (packages would be submitted somewhere around 3-4 February. (That is the email that I send to you).
20:23:47 <coolo> yep, ismail already ACKed
20:24:05 <tittiatcoke> coolo: second one is if you still would accept some side packages into 12.3 coming from KDE. We are then talking about KDE Telepathy and Knights (Chess frontend)
20:24:18 <cb400f> kamoso! :-)
20:24:24 <coolo> tittiatcoke: as soon as the apper situation is green I'm open to talk about updates
20:24:34 <coolo> I don't want to talk about chess games if we have no working update applet
20:24:45 <rabauke> or zypper backend
20:24:52 <tittiatcoke> coolo: understood.
20:26:48 <rabauke> nice, kde being bound to the faith of zypp people caring.
20:27:09 <tittiatcoke> let's hope that dantti can do some miracle work
20:27:15 <einar77> rabauke: if dantti manages to fix it, it's a non issue
20:27:20 <einar77> we need to wait at the moment
20:27:38 <cb400f> is there a problem sticking with the old packagekit? .. it has been working better than ever lately
20:27:45 <alin> cb400f: are you using vlc?
20:28:01 <alin> cb400f: no need of kamoso...
20:28:01 <rabauke> if he does the job it will be even more embarrasing for the opensuse zypp devs
20:28:10 <cb400f> sometimes.. I'll need to try the webcam feature.. it's new to me that it exists
20:28:12 <tittiatcoke> cb400f: Actually I have been using apper and don't really have issues
20:28:23 <rabauke> me neither
20:28:23 <einar77> rabauke: but that's not our interest at the moment, we're interested in a working update applet
20:28:26 <cb400f> people often ask about such stuff.. and install cheese on kde systems
20:28:51 <tittiatcoke> alin: Also vlc is not offered by openSUSE repositories
20:28:53 <wstephenson> i am not too optimistic dantti will be able to get a production quality zypp backend done. he is too distant from opensuse
20:28:59 <coolo> rabauke: "the opensuse zypp devs" is about one guy from what I gather on the zypp-devel list
20:29:11 <coolo> rabauke: and that guy is paid from suse to do maintenance work
20:29:33 <alin> cb400f: the png is broken.. for the one in packman but the idea is like this cvlc -I dummy v4l2:// --video-filter scene -V dummy --scene-ratio 5 --scene-format jpg --scene-prefix img --scene-path $HOME --no-scene-replace --run-time 10 vlc://quit
20:29:43 <rabauke> coolo: and opensuse is the test rabbit for suse, which makes it only fair to pay at least some of its contributors
20:29:57 <rabauke> and its still a shame
20:30:04 <shumski> alin: will that be in guide ;-)
20:30:25 <alin> shumski: I know more tricks...
20:30:26 <tittiatcoke> I wonder which update applet Gnome is using
20:30:39 <rabauke> something integrated into gnome afaikl
20:30:50 <plinnell> FYI, I need to leave, but scribus 1.4.2 is very very soon :-)
20:30:52 <cb400f> packagekit based surely?
20:30:55 <rabauke> but it should rely on packagekit as well
20:30:58 <tittiatcoke> plinnell: Ok. Thanks
20:31:00 <plinnell> out before freeze methinks
20:31:21 <cb400f> and knowing gnome.. that means it prolly requires pk 0.8 too
20:31:30 <tittiatcoke> :-)
20:31:51 <tittiatcoke> but I guess that their client currently works ok with the current pk
20:31:55 * plinnell wishes we could have kde for SLES 12
20:33:06 <plinnell> o/
20:33:14 <tittiatcoke> Ok. Let's agree the following. I will check with Gnome what their plans are and if they have any issues. I will also check the bug reports on what we have open for Apper to see if this is still valid or not.
20:33:42 <alin> tittiatcoke: ok... ifyou want me I can test...
20:33:44 <cb400f> don't take their word for it if they say "no issues"
20:33:50 <tittiatcoke> cb400f: :-)
20:34:00 <einar77> ok guys, I need to sign off
20:34:01 <cb400f> they always claim it works... no matter how many bugs are in the zypp backend
20:34:07 <einar77> I'll check later the rest of the meeting
20:34:15 <tittiatcoke> einar77: Ok. Thanks
20:34:44 <tittiatcoke> #action tittiatcoke check the updater/packagekit situation in Gnome and validate open bugreports for Apper.
20:34:57 <tittiatcoke> krop: Are you there ?
20:35:11 <krop> partially yes
20:35:17 <tittiatcoke> Ok. It's your topic :-)
20:35:20 <tittiatcoke> #topic Remove old repositories (krop) concerned: KR46, KR47(?), K:U:P/(KR47,KR48,KR49_12.1)
20:35:53 <cb400f> I would like to add a discussion about KUA for 11.4 for this topic
20:35:54 <rabauke> +1
20:35:55 <krop> So, we have 1/many obsolete repositories, 2/ many rebuilds when updating any package in KUP
20:36:19 <rabauke> +1 for dropping the repos that is
20:36:26 <remur_030> are there any download stats available? sounds like a niche market honestly
20:36:28 <krop> that takes a lot of space and a lot of build power
20:37:23 <tittiatcoke> I can understand KR46 and KR47, but why would you drop KUP for KR49/12.1 ?
20:37:36 <alin> remur_030: niche market for whom? I donot think one would like to consider niche the part that never updates
20:37:43 <krop> KR46 is built for 11.4, KR47 is built for 11.4 & 12.1, and KUP builds for many repos
20:37:49 <rabauke> one issue I could see though is that those still using these repos will not get any updates not even officials anymore because apper does not skip on error but stops to check. so people will have to know that they have to remove a repo.
20:38:25 <krop> was a typo, we have KR47/12.1, KR48/12.1, I'm not sure people using these KDE flavours are interested in unstable packages
20:38:27 <cb400f> if they use KUP they are no longer civilians
20:38:36 <shumski> i would axe all 11.4 repos
20:38:40 <remur_030> alin: I was more thinking about KUP, who uses this with outdated opensuse?
20:38:43 <cb400f> kr46 does not make sense on any supported distro (except possibly evergreen)
20:38:45 <rabauke> Playground should certainly go. KR46 as well. the others somebody might call for evergreen, but then they should have taken them over a long time ago.
20:38:56 <remur_030> alin: the other ones shouldn't rebuilt that often no?
20:39:49 <remur_030> can we maybe split that up into KR and KUP? Because I think KUP might be way more expensive for the OBS infrastructure
20:39:53 <alin> it is 2y old software... why should we bother?
20:40:14 <remur_030> KR doesn't really need any rebuilds no? so it's just hosting old stuff
20:40:17 <alin> krop:  thougght kup is build only for stable + factory...
20:40:57 <alin> we had this discussion some time ago... somebody wants crazy things on stable -1 one... then it is his problem
20:41:26 <krop> for KUP, in order to limit the used space and power, I'd like to limit the build to O:F+ current opensuse version
20:41:47 <alin> krop: +whatever it needs to go on
20:41:52 <cb400f> including relevant KR4x for current opensuse version?
20:42:07 <krop> yes
20:42:14 <cb400f> and KDF+current opensuse
20:42:17 <remur_030> why not KDF?
20:42:32 <remur_030> actually I guess somebody running KUP will be using kdf not kr?
20:42:34 <krop> https://build.opensuse.org/project/repositories?project=KDE%3AUnstable%3APlayground that's the current repos
20:43:02 <cb400f> remur_030: you might have some guy who just wants the amarok beta or calligra beta on an otherwise fairly stable system
20:43:24 <cb400f> or testing kscreen .. or sumfink
20:43:37 <krop> the KR47,48 and 12.1 repos should be wiped imo
20:43:52 <remur_030> cb400f: might as well have sombody who wants to do this on his opensuse - 1 release :-/
20:44:35 <alin> krop: we keep the first 5? and the supported kde?
20:44:45 <cb400f> sure.. but if we need to limit build power wastage I think krop's suggestion is fair
20:45:17 <cb400f> also it matches the KDF policy more or less
20:45:36 <cb400f> which also isn't built for stable -1 anymore
20:45:42 <remur_030> hmm, right
20:46:24 <alin> ok.. so we shall vote on this? kup remains with factory plus stable
20:46:29 <alin> ?
20:46:53 <alin> tittiatcoke: wake up
20:46:54 <rabauke> stable = current release?
20:46:55 <remur_030> stable as in current opensuse plus current stable kr?
20:47:00 <alin> remur_030: yes
20:47:04 <tittiatcoke> alin: I am here :-)
20:47:11 <rabauke> then +1
20:47:23 <alin> tittiatcoke: so we give to krop the knife to prune the kup?
20:47:24 <krop> so, as a more generic rule:  (Factory + current opensuse version)*KDE flavors (KRxy, KDF, KUSC)
20:47:33 <shumski> yup
20:47:40 <alin> krop: +1
20:47:52 <tittiatcoke> #agreed KUP to be build for  (Factory + current opensuse version)*KDE flavors (KRxy, KDF, KUSC)
20:48:01 <tittiatcoke> #agreed to delete KR46 and KR47
20:48:19 <alin> tittiatcoke: and 48
20:48:30 <tittiatcoke> #agreed to delete KR48
20:48:37 <alin> tittiatcoke: as  4.8 would come via 12.2
20:48:40 <alin> perfect
20:48:56 <remur_030> hm, what about 12.1 users still running 4.8? 12.1 is still supported
20:49:08 <remur_030> and again, not much build power required for non touched kr
20:49:13 <cb400f> yeah, better keep kr48 for 12.1 only
20:49:23 <alin> remur_030: is supported but not in kup
20:49:27 <krop> one may wonder why we still have KDE:Qt45/46/47 but we're missing Dirk for this topic
20:49:54 <remur_030> alin: err I thought this was about KR repos in general, not the KUP ones
20:49:54 <tittiatcoke> :-) KDE:Qtxx is dirk's territory
20:49:55 <alin> krop: let us add that for next time..
20:50:04 <alin> tittiatcoke: or send him an email
20:50:15 <alin> as I do not remember seeing him lately
20:50:32 <tittiatcoke> alin: indeed.
20:50:33 <alin> dantti_laptop: was here...
20:50:48 <tittiatcoke> guys, can we finish this. I really have to run :-)
20:50:56 <dantti_laptop> ?
20:50:57 <alin> tittiatcoke: yes
20:51:03 <alin> next point...
20:51:14 <tittiatcoke> #topic Misc, Q&A
20:51:21 <tittiatcoke> Any other topics or questions ?
20:51:22 <alin> dantti_laptop: something related about apper
20:51:31 <alin> tittiatcoke: I want to add simon
20:51:46 <tittiatcoke> alin: I am fine to add simon in KDF, but you heard coolo :-)
20:51:56 <alin> tittiatcoke: anyone interested in? http://simon-listens.blogspot.co.at/2012/12/simon-040.html
20:52:05 <dantti_laptop> alin: ok, I can't find anything usefull on backlog, am I still useful?
20:52:25 <cb400f> danish team put in a huge effort over christmas to translate the thing :-)
20:52:37 <alin> cb400f: cool...
20:52:39 <tittiatcoke> dantti_laptop: Not for the meeting :-)
20:52:52 <cb400f> and people tend to complain about kde accessibility.. so it'd be cool to have it I think
20:52:53 <dantti_laptop> ok :)
20:52:54 <tittiatcoke> alin: I would say push it to KDF and then we will see :-)
20:53:29 <alin> tittiatcoke: I will push it to extra and then from there we see next week
20:53:44 <tittiatcoke> #action alin to push simon to KDE:Extra
20:53:48 <tittiatcoke> anything else ?
20:54:19 <alin> tittiatcoke: no
20:54:21 <wstephenson> not from me
20:54:29 <ctrippe_> not from me
20:54:35 <rabauke> no
20:54:45 <tittiatcoke> Oki :-) Apologies for rushing the ending :-)
20:54:50 <rabauke> thanks for hosting!
20:54:51 <cb400f> I have a bit
20:54:58 <tittiatcoke> cb400f: go :-)
20:55:06 * wstephenson blames jospoortvliet for turning on the work tractor beam
20:55:08 <cb400f> any opinions if kua/11.4 should be dropped?
20:55:18 <wstephenson> but we now have a nice article about chromebooks published: https://news.opensuse.org/2013/01/08/opening-the-can-initial-support-for-opensuse-on-the-arm-chromebook/#comments
20:55:21 <rabauke> drop
20:55:27 <jospoortvliet> +1 wstephenson
20:55:31 <tittiatcoke> cb400f: I would drop it
20:55:34 <cb400f> I tend to think it should go.. but I feel a bit bad for the evergreeners
20:55:41 <jospoortvliet> just tuned it a bit and gave it the spotlight on the front page as well as on G+, facebook and twitter :D
20:55:59 <rabauke> cb400f: then ask them whether they are going to maintain it. if not, drop
20:56:34 * jospoortvliet goes again, sorry to interrupt the meeting. Hugs for all :D
20:56:40 <tittiatcoke> #action cb400f Check with the evergreen maintainers if they are willing to maintain KUA for 11.4. If not, then drop the repo
20:56:43 <cb400f> ok, I think I'll just clean it.. :-) think I know the answer to the question
20:56:49 <tittiatcoke> :-)
20:57:16 <tittiatcoke> Ok. guys. Next meeting in two weeks. (22 January same time, same channel) :-)
20:57:25 <tittiatcoke> #endmeeting