16:26:22 <javier_> #startmeeting
16:26:22 <bugbot> Meeting started Thu Aug  5 16:26:22 2010 UTC.  The chair is javier_. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:26:22 <bugbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:26:45 <llunak> javier_: I need to update the howto ; right now, it's just #topic, #action
16:27:02 <javier_> yes, there's little info about the commands or I am not finding it
16:27:18 <javier_> old action items
16:27:31 <remur_030> javier_: make it #topic Old AIs
16:27:40 <remur_030> so the meetbog will pick it up =)
16:27:47 <javier_> #topic Old AIs
16:28:05 <javier_> now I suppose I have to copy and paste
16:28:32 <llunak> well, there's no minutes for the last meeting, so only finding them in the transcript
16:28:42 <javier_> wstephenson to add a start nepomuk button to the akonadi warning dialog -> Work-in-Progress
16:28:54 <wstephenson> still work in progress
16:29:06 <javier_> ok
16:29:06 <wstephenson> fixed an underlying bug that we mispackaged nepomuk itself
16:29:21 <javier_> good
16:29:39 <javier_> next one
16:29:46 <javier_> reddwarf to collect some informations about the default applications and once we have the list we will know if the problem triggers for 11.2 -> Done, Posted to the list
16:29:50 <javier_> that one is done :)
16:30:06 <llunak> where are you reading these from?
16:30:19 <javier_> http://en.opensuse.org/openSUSE:KDE_Meeting_20100624
16:30:31 <javier_> oops
16:30:36 <javier_> wrong one
16:30:48 <llunak> will haven't done the last minutes yet
16:30:54 <javier_> sorry
16:30:55 <llunak> http://community.opensuse.org/meetings/opensuse-kde/2010/opensuse-kde.2010-07-22-16.09.log.html , seach for "AI:"
16:31:02 <javier_> here's the good one
16:31:03 <javier_> * llunak will post the conclusion around repository reorganization to the list
16:31:15 <llunak> done, was it?
16:31:19 * llunak is not sure :)
16:31:28 <javier_> me neither
16:31:39 <javier_> let's see
16:31:44 <llunak> oh, done
16:31:49 <llunak> 'KDE repositories status' mail
16:32:06 <javier_> ah right
16:32:17 <javier_> this one is done
16:32:21 <javier_> next
16:32:32 <javier_> * All think about correct naming for KKUD and Playground
16:32:44 <javier_> this is done I think
16:33:07 <javier_> KKUD -> KUS
16:33:22 <llunak> are you perhaps still reading some old AI?
16:33:26 <javier_> KDE:Unstable:SC
16:33:46 <javier_> i'm reading it in order
16:33:55 <javier_> the next line reads "will be discussed as one topic"
16:34:14 <llunak> oh
16:34:22 <llunak> those were old AIs the last time
16:34:32 <FL1SK> what is the meaning of KKUD
16:34:40 <javier_> oh there are AIs
16:34:42 <javier_> wait
16:34:45 <llunak> "16:13:52 <llunak> AI: javier run a bug triage" is the first one I see
16:34:52 <javier_> llunak: got it
16:35:04 <javier_> FL1SK: KDE:KDE4:Unstable:Desktop
16:35:14 <FL1SK> ok
16:35:32 <javier_> I announced the bug triage
16:35:43 <javier_> I asked for a date
16:35:54 <javier_> but no dates where given iirc
16:36:06 <javier_> I think some work should be done on the wiki first
16:36:14 <javier_> that would help running a bug triage
16:36:24 <wstephenson> so new AI, setup wiki for bug triage prep
16:36:29 <ctrippe> I think the wiki is in place for the bug triage
16:36:50 <javier_> ok, good
16:36:51 * Ramblurr is here fyi, just lurking
16:36:59 <ctrippe> At least I do not know what is missing
16:37:05 <javier_> me neither
16:37:13 <javier_> I know that you worked on it
16:37:19 <wstephenson> updated bug ranges for people to 'own'?
16:37:33 <ctrippe> Yes but now one week old again
16:37:44 <javier_> yepp :(
16:37:49 <wstephenson> good enough, we can add on
16:38:18 <javier_> so run a bug triage as AI
16:38:23 <javier_> the thing is the date
16:38:47 <wstephenson> 14th or 15th?
16:38:49 <javier_> do you guys have any preference?
16:38:59 <wstephenson> not 20-22 as llunak and i are at froscon
16:39:04 <javier_> ok
16:39:07 <llunak> 14-15 I'm also away
16:39:24 <llunak> but you do not strictly need us for the triage
16:39:33 <javier_> I know
16:39:43 <javier_> but I would need some "leaders"
16:39:54 <javier_> if you know what I mean
16:40:14 <ctrippe> On the weekend I am usually only available in the evening because of my kids
16:40:49 <javier_> ctrippe: when is it better for you? (which day)
16:41:03 <llunak> the triage can be a whole week, not so "packed", if that's a preferred format
16:41:21 <javier_> yes, also that way it covers more timezones
16:41:22 <llunak> or maybe weekend+2 more days, or so
16:41:50 <wstephenson> +1
16:41:58 <ctrippe> +1
16:42:37 <ctrippe> javier_: During the week is mostly fine for me at the moment
16:42:48 <javier_> ok
16:43:19 <javier_> what about 13-16?
16:43:25 <javier_> from friday to monday
16:43:37 <wstephenson> sounds good
16:43:45 <javier_> ok
16:44:16 <FL1SK> what are we looking for here
16:44:26 <javier_> #action Announce bug triage 13th-16th of August
16:44:33 <FL1SK> ah
16:44:46 <wstephenson> javier_: add your name to the #action
16:44:51 <wstephenson> or whoever it is assigned to
16:45:12 <javier_> #action Announce bug triage 13th-16th of August (javier_)
16:45:18 <javier_> sorry for that
16:45:27 <wstephenson> np
16:45:30 <javier_> next one...
16:45:41 <llunak> "#action javier announce bug triage 13th-16th of August" is actually the proper format, but I'll fix that in the minutes
16:46:08 <javier_> llunak: you typed a "
16:46:10 <javier_> is that intended?
16:46:16 <llunak> that was quoting
16:46:20 <javier_> ok
16:46:31 <llunak> #action llunak update meeting howto (meetbot, etc.)
16:46:46 <javier_> AI: llunak move wiki pages about maintaining Extra/UpdatedApps repos
16:46:47 <javier_> 16:16:50 <wstephenson> not done here
16:47:17 <llunak> done, linked e.g. from http://en.opensuse.org/openSUSE:KDE_repositories_maintaining
16:47:43 <javier_> okies
16:47:44 <wstephenson> llunak: nice
16:47:53 <javier_> yepp
16:48:10 <javier_> less red links and more content :)
16:48:26 <javier_> I don't see more old AIs
16:48:59 <javier_> so now it's time for the status report
16:49:06 <javier_> #topic status report
16:49:17 <llunak> "AI: llunak take care of removing KDE:KDE4:Community as appropriate"
16:49:33 <llunak> "AI: update KDE:Extra docs to suggest explicit package maintainers"
16:49:48 <llunak> "AI: llunak arrange renaming of unstable repos"
16:49:58 <llunak> "AI: llunak lead discussion about KDE:45 repo on opensuse-kde list"
16:50:04 <javier_> oops
16:50:08 <llunak> "AI: wstephenson investigate details about creating repository symlinks"
16:50:09 <javier_> well, there you go
16:50:19 <llunak> bad wstephenson , for not creating last minutes :)
16:50:24 <wstephenson> yeah, sorry guys
16:50:30 <javier_> np
16:50:45 <apachelogger> ^^
16:50:51 <llunak> ok, so community repo is a topic for today
16:50:59 <llunak> explicit maintainers done
16:51:10 <llunak> renaming of unstable repos was done by Beineri
16:51:27 <javier_> <applauses>
16:51:28 <llunak> and KDE:45 repo is today's topic, but no discussion on the list
16:51:30 <wstephenson> symlinks was about zypp services
16:51:45 <wstephenson> and they are not what i thought they were, they are lists of repos
16:52:43 <wstephenson> i'll poke duncan again about that though
16:52:55 <wstephenson> the original idea seemed worthwhile (http://duncan.mac-vicar.com/blog/archives/351)
16:53:24 <llunak> so we've renamed the repos and people have to deal with it, I guess?
16:53:46 <wstephenson> atm yes
16:53:54 <llunak> well, later it doesn't matter
16:54:06 <wstephenson> when we have the KDE:45 repo we could introduce a stable zypp service pointing to it
16:54:19 <wstephenson> it matters when 11.4 is released
16:54:32 <javier_> repository dependencies
16:54:45 <javier_> interesting idea
16:54:54 <FL1SK> i want community repo
16:55:20 <wstephenson> the more interesting idea is having an unchanging service that means users don't have to juggle repos when we rename again
16:55:38 <llunak> ok, but that's for later then
16:55:43 <javier_> repositories as services?
16:55:53 <dirk> didn't we want to do the KDE:45 when we switch to 4.6?
16:55:56 <wstephenson> javier_: lets discuss it later
16:56:02 <javier_> ok
16:56:13 <wstephenson> dirk: at the latest, yes, there is demand for a clear way to find 4.5 now though.
16:56:46 <llunak> 4.5 is an extra topic for today
16:56:49 <dirk> wstephenson: offer a 11.3 + KDE 4.5 respin?
16:56:56 <wstephenson> dirk: already working on it
16:57:12 <wstephenson> the upstream one is done and lurking at ~kdelive
16:57:23 <wstephenson> i will put the 11.3 branding back on it and there's your respin
16:57:34 <FL1SK> is 4.5 released
16:57:35 <wstephenson> then alin__ will be happy again
16:57:42 <remur_030> FL1SK: one week postponed
16:57:43 <wstephenson> FL1SK: next tuesday
16:57:48 <FL1SK> bummer
16:58:03 <wstephenson> FL1SK: dolphin crash bugs are a worse bummer
16:58:08 <alin__> wstephenson: thanks...
16:58:12 <FL1SK> no kidding
16:58:19 <javier_> that's good news... we'lll have enough time to fix the live cd
16:58:30 <FL1SK> Cool
16:58:49 <wstephenson> javier_: IMO not much left to realistically fix besides the 64 bit build
16:58:58 <wstephenson> maybe the NM icon scaling problem.
16:59:05 <wstephenson> anyway we're OT
16:59:19 <javier_> good to know
16:59:23 <javier_> ok next AI
16:59:46 <llunak> out of old AIs now :)
17:00:36 <javier_> where are the AIs when I look for them? :/
17:00:53 <javier_> so now it's time for the status report?
17:01:37 <llunak> yes
17:02:01 <javier_> anything to report? :)
17:02:09 <remur_030> javier_: #topic =)
17:02:25 <javier_> I changed it before ;)
17:02:38 <llunak> 4.5.0 is not out yet, as said
17:02:51 <remur_030> whops =P
17:03:10 <wstephenson> i've been fixing upstream 4.5.0 stuff discovered on the livecd and their related packaging problems
17:03:17 <javier_> remur_030: it's the first thing i do correctly :D
17:03:24 <wstephenson> and giving myself an ulcer reading opensuse-project
17:03:30 <javier_> half-correctly ;)
17:03:37 <llunak> and I've spent quite some time reading mailing lists :-/
17:03:57 <javier_> opensuse-project traffic is growing
17:03:59 <llunak> speaking of which, I'd like to ask you that do try not to make the flamewars and useless discussions longer
17:04:05 <remur_030> yeah boys try to relax with the lists
17:04:16 <wstephenson> yeah, i'm tired of fighting opensuse@ too now.
17:04:31 <wstephenson> but i will respond to stupidity on -project
17:04:38 <llunak> if there's an idiot on opensuse@ , give a firm answer once (to his real problem, or pointing to the netiquette if it's really bad)
17:04:52 <llunak> if that doesn't help, leave it to the list admin
17:05:11 <llunak> that is, point the admin there
17:05:25 <remur_030> actually any topic involving kde and gnome dwindles into flamewars on any suselist
17:05:33 <llunak> which actually may be me, I think :)  (I need to figure out details)
17:06:08 <llunak> that's why you should not help to grow bigger, instead stay firmly on topic, not post if not necessary, calm it down by pointing to the netiquette if needed
17:06:31 <remur_030> that's why i personally dislike the kde proposal, I am all for making kde inside opensuse stronger but not to the disadvantage for gnome and the rest
17:07:12 <llunak> there are trade-offs for everything
17:07:29 <remur_030> it's not like novell will change it's priorities here anyway based on what happens with opensuse
17:07:41 <llunak> remur_030: it's not like opensuse is meant to be novell's
17:07:49 <remur_030> and this is what it looks like to me, tell novell where opensuse needs manpower
17:08:15 <llunak> #action remur_030 read llunak's mail on -project about what a strategy is about
17:08:23 <wstephenson> :)
17:08:35 <remur_030> llunak: sure it isn't, but the proposals look to me like 'we will invest manpower here' without having another place to get them from except novell
17:08:52 <remur_030> I'll try to find it, i mostly just glanced over them because most are very tiresome
17:08:52 <llunak> hmm ... you need to read my second mail there too :)
17:09:15 <remur_030> nvm they just got in k =)
17:09:16 <llunak> the newest mails, at the moment
17:09:28 <llunak> javier_: I think we can move
17:09:47 <javier_> allright
17:10:12 <javier_> #topic new items
17:10:38 <javier_> * repositories specific for KDE SC versions (e.g. 4.5.x)
17:11:04 <llunak> hmm, was 'new items' the agenda item nobody remembers what is it for?
17:11:47 <wstephenson> so what about this KDE:45 repo?
17:11:49 <javier_> not exactly
17:11:56 <llunak> javier_: I'll remove that one from the howto as well, let's just go with "#topic repositories specific for KDE SC versions (e.g. 4.5.x)"
17:12:08 <llunak> javier_: or you know what that one is about?
17:12:10 <remur_030> the demand for 4.5 after factory moves to 4.6 is there
17:12:20 <javier_> #topic repositories specific for KDE SC versions (e.g. 4.5.x)"
17:12:23 <wstephenson> are we going to establish it, update it with every upstream point release separately to K:D:F
17:12:40 <wstephenson> or will it contain links to K:D:F until we go 4.6 there?
17:12:45 <llunak> the first question should be "who will do it?"
17:12:58 <javier_> llunak: having repos for each KDE SC release ie: KDE450, KDE451 I suppose
17:13:10 <remur_030> wstephenson: least work required should be it, does it really need to be upstream SC?
17:13:20 <wstephenson> llunak: 'it' has to be defined
17:13:40 <wstephenson> remur_030: i don't think so
17:13:54 <remur_030> javier_: ugh, please just a single kde45 repo
17:13:56 <wstephenson> when i say 'upstream point release' i don't mean 'unpatched'
17:14:03 <javier_> remur_030: +1
17:14:09 <wstephenson> yeah nobody needs 450 when 451 is out
17:14:12 <remur_030> okidoki, then we can just link to kfd till it's pushed up
17:14:30 <llunak> that's not the problem, the problems are:
17:14:36 <remur_030> and afterwards let's just try applying the branch updates, is that much trouble?
17:14:49 <llunak> - after factory is on 4.6 betas, somebody need to maintain :45
17:15:07 <wstephenson> meaning, do further point release updates
17:15:10 <wstephenson> fix breakages
17:15:13 <llunak> - IMO it should be maintained to the same level as with factory
17:15:29 <javier_> sounds good to me
17:15:32 <llunak> - until when is it maintained?
17:15:47 <wstephenson> what options do we have there?
17:15:57 <wstephenson> "until 4.6.0 comes out?"
17:16:04 <javier_> until a new version comes out
17:16:07 <remur_030> wstephenson: what breakages can be expected?
17:16:08 <llunak> - and, final question, if somebody is willing to do the, but not meeting these requirements, do we want to have such "official" repo?
17:16:12 <wstephenson> until an official opensuse release > 4.5.0 comes out?
17:16:36 <javier_> llunak: we could have a warning in the wiki
17:16:42 <remur_030> there isn't going to be any big breakages after 4.6 release anyway, why not just leave it for a few more months?
17:16:46 <wstephenson> remur_030: usually dealing with latent packaging bugs that were there the whole time
17:16:48 <llunak> javier_: nobody reads those anyway
17:16:55 <javier_> it could also be a place for learning to maintain kde packages
17:16:58 <wstephenson> like the missing soprano-backend-redland dep in 11.3
17:17:05 <javier_> :(
17:17:31 <remur_030> wstephenson: sounds like small fish, also the same would be true for kfd so could be collected in a 'please backport' list
17:17:32 <wstephenson> javier_: IMO playground is for learning, the people using KDE:45 want stability
17:17:54 <wstephenson> remur_030: yes
17:18:02 <wstephenson> basically the same level of work as we have for K:D:S
17:18:07 <llunak> but somebody still needs to do the work
17:18:11 <javier_> wstephenson: but playground doesn't have kde sc
17:18:17 <wstephenson> javier_: right
17:18:29 <cb400f> there's also the issue of user support.. and it means less people testing factory
17:18:38 <javier_> it could be something in between factory and unstable
17:18:44 <llunak> javier_: anybody can do submit requests for KDE:Distro:Factory if they want to work on KDE SC packages
17:18:45 <javier_> "it may break"
17:18:49 <remur_030> cb400f: can't we mark it unsupported?
17:19:04 <wstephenson> cb400f: it should be a link to KDF for quite some time
17:19:05 <javier_> right
17:19:07 <remur_030> for your convenience, don't sue us.
17:19:13 <cb400f> people will still fill the mailing list and irc with questions and issues
17:19:14 <llunak> remur_030: but do we want to do it "officially" then? KDF is already "unsupported"
17:19:31 <javier_> community supported? ;)
17:19:34 <bitshuffler> wstephenson: if they want "stability" they should stick with :stable imho
17:19:46 <javier_> bitshuffler: +1
17:19:50 <remur_030> llunak: if it's about the same as kfd let's just call it that way
17:19:53 <wstephenson> remur_030: and anyway ppl get it into their heads that KDE:KDE3 is "opensuse supported" ;)
17:20:46 <remur_030> I don't think we will succeed telling every user the support status of such a repo
17:21:04 <remur_030> mark it 'best effort' and be done with it
17:21:19 <bitshuffler> create a new repo and put the latest upstream kde release in there and make it clear it is community / volunteer supported only
17:21:24 <llunak> some people just don't listen and will complain anyway
17:21:38 <Beineri> is the point to volunteer? :-)
17:21:47 <javier_> this idea of having a KDE45x repo fits nicely with the Open-PC
17:21:52 <remur_030> Beineri: that's how I understood it ;-)
17:21:53 <bitshuffler> llunak: well, you can still point them to the docs and tell them to go where the sun doesn't shine ;)
17:22:09 <javier_> bitshuffler: their basements?
17:22:10 <javier_> ;)
17:22:14 <llunak> bitshuffler: and that's how we get all the opensuse@ flamewars
17:22:27 <arkascha> There have not been any more upgrades to the KDE4 factory during the last days. I know that KDE-4.5 has been delayed one week, but the reason was exactly last-minute-changes...
17:22:32 * Beineri would use KDE 4.5.x packages ;-)
17:22:32 <bitshuffler> imho it isn't only about 4.5 since that same problem will arise in the future as well
17:22:38 <wstephenson> javier_: can you explain your use for it at Open-PC?
17:22:42 <wstephenson> Beineri: would you maintain them?
17:22:50 <bitshuffler> llunak: sounds like I should read that list ;D
17:23:06 <Beineri> wstephenson: to a certain point (to make them useful for myself ;-), yes
17:23:26 <wstephenson> Beineri: we're only talking about very light maintenance anyway
17:23:28 <remur_030> arkascha: upstream requests no further updates to be published until final release
17:23:39 <wstephenson> Beineri: would it be useful to Basyskom at all?
17:23:52 <javier_> wstephenson: the idea is basically providing the latest stable KDE through a repo
17:24:08 * bitshuffler would be interested in a stable upstream repo too
17:24:27 <wstephenson> javier_: so Open-PC users would always want to update to that latest stable?
17:24:27 <remur_030> ugh, so if 11.4 releases with 4.6.2 you wan't that further patched?
17:24:43 <Beineri> wstephenson: does it matter? :-)
17:24:46 <remur_030> branch updated that is =)
17:24:53 <javier_> wstephenson: i don't know if all, but we would provide them the latest KDE
17:24:55 <wstephenson> or would you want to be able to keep users on the KDE SC they bought the machine with indefinitely?
17:25:00 <FL1SK> What are we deciding here
17:25:09 <wstephenson> (that's almost LTS territory...)
17:25:18 <remur_030> FL1SK: how to proceed with a stable kde release repo
17:25:19 <Beineri> wstephenson: dunno if 11.3+4.5 will be used at some time...
17:25:39 <FL1SK> i just always go with what factory is remur_030
17:25:43 <remur_030> hehe if they have someone they can poke directly it might lower the adoption bar =)
17:25:50 <wstephenson> Beineri: i get the impression basyskom wants a very stable but opensuse based kde desktop to use in house
17:25:52 <javier_> wstephenson: the initial idea is to provide the possibility to easily update to latest stable KDE
17:26:08 <remur_030> FL1SK: yeah but alot of people want to latest kde stable
17:26:11 <Beineri> wstephenson: so kde of 11.3 might be fine too?
17:26:15 <wstephenson> if i'm correct in that assessment you might want to keep KDE:45 around long after KDE:46 exists
17:26:18 <FL1SK> right
17:26:25 <FL1SK> I say go 4.5 when its released makes sense to me
17:26:47 <remur_030> FL1SK: it needs a maintainer for now and also needs to clarified what will happen later on
17:26:48 <cb400f> please put in in kde:tmp:sc45 or so .. to signify the uselessness of the repo
17:26:52 <wstephenson> Beineri: might be - i'm just fishing.
17:26:56 <FL1SK> wstephenson: why would you want to keep 4.5 around when stable 4.6 was released
17:27:17 <wstephenson> FL1SK: eg ppl who don't want to retrain users for any UI changes.
17:27:24 <llunak> because somebody might prefer the stability of 4.5.4 to 4.6.0
17:27:29 <Beineri> wstephenson: assume it will be supported by basyskom with some hours, and for the rest there is free time...
17:27:29 <wstephenson> and that
17:27:36 <FL1SK> ok
17:28:00 <remur_030> what do the people who suggest a 'latest stable' repo think of a KDS with 4.6.2 and further 46 repo?
17:28:03 <FL1SK> wstephenson: that seems like a very small amount of ppl
17:28:22 <cb400f> remur_030: factory would prolly get 4.6.3.. .4 etc.
17:28:22 <wstephenson> FL1SK: i don't know
17:28:24 <remur_030> hm bad description, but who will use/test kde:stable when there is a further 4.6 updates repo?
17:28:42 <wstephenson> i know there are guys like tigerfoot selling opensuse support that it might be useful to
17:28:50 <bitshuffler> remur_030: anyone who wants to stay on supported grounds
17:28:55 <FL1SK> really
17:29:07 <remur_030> bitshuffler: they won't just stick to 11.4-update?
17:29:08 <FL1SK> didn't know ppl sold opensuse support
17:29:19 <wstephenson> remur_030: probably KDE:Stable is just used by us for testing updates anyway
17:29:32 <tigerfoot> wstephenson: I will have look to the discussion, sorry to not be present to the meeting ...
17:29:33 <wstephenson> it appeals to a narrow segment of the kde user spectrum
17:29:34 <javier_> FL1SK: Open-SLX does as well
17:29:37 <bitshuffler> remur_030: dunno, as you know :stable contains kde of the latest release + some newer stuff
17:29:50 <cb400f> Stable appeals to all the 11.2 and 11.1 users :-)
17:29:52 <wstephenson> FL1SK: lots of small shops do
17:30:10 <remur_030> bitshuffler: nope it doesn't? it's the test ground for current opensuse stable kde patches
17:30:10 <cb400f> and sle users too I guess
17:30:21 <remur_030> so it's on 4.4.4 and will stick there currently
17:30:22 <wstephenson> sle cowboys
17:30:46 <bitshuffler> remur_030: that's what I meant
17:31:02 <Beineri> wstephenson: and have to do it also to justify my free openslx box ;-)
17:31:03 <wstephenson> or sle users supported by non-novell sources who can afford to break their novell support
17:31:15 <FL1SK> my thoughts are why not have diff repos for diff stable versions for people to choose from 4.4.4, 4.5, and 4.6
17:31:29 <FL1SK> that way they get the latest updates for all of them
17:31:32 <FL1SK> then they can choose
17:31:32 * cb400f almost faints
17:31:38 <remur_030> ehehe
17:31:39 <FL1SK> lol
17:31:48 <FL1SK> how about a maint. nightmare there
17:32:01 <javier_> why not having KDE:SC:Upstream (upstream as in whatever stable upstream version is released)?
17:32:13 <FL1SK> javier_: i like that idea
17:32:17 <remur_030> javier_: with opensuse patches?
17:32:24 <FL1SK> lets just stick with upstream
17:32:35 <javier_> hmm
17:32:42 <wstephenson> FL1SK: no! then we have 2 completely different codebases
17:32:44 <remur_030> well I doubt there is enough manpower for that
17:32:51 <FL1SK> bah!!
17:33:01 <javier_> remur_030: that's the main issue I guess
17:33:03 <wstephenson> FL1SK: i think we'll have your scenario anyway
17:33:10 <FL1SK> heh heh
17:33:15 <wstephenson> but only 1 repo for each y in KDE 4.y
17:33:20 <wstephenson> s/repo/project
17:33:20 <cb400f> let's create kde:tmp: and let people do whatever weird waste of build power they want there.. and let others focus on stable and factory
17:33:34 <Beineri> FL1SK: do you volunteer to split/differentiate patches into parts which make things "work" and those that "improve/extend"? :-)
17:33:37 <remur_030> why not have a moving pointer that points to the one that is most closely to the current kde release?
17:33:59 <wstephenson> remur_030: that's the zypp services idea
17:34:00 <javier_> better have openSUSE patches
17:34:05 <FL1SK> :-) i would have to tell my boss that i need to dedicate 2 hours a day to do that
17:34:06 <remur_030> and in some time slots when factory moves on and stable is too outdated keep it close to current kde with patches
17:34:26 <remur_030> wstephenson: can't we 'fake' that with a normal obs repo?
17:34:29 <wstephenson> FL1SK: think he'll say yes?
17:34:47 <FL1SK> with all the projects im on now; NO
17:35:00 <wstephenson> remur_030: it's harder to update that (lot of linking/aggregating) than a list of pointers to repos
17:35:15 <FL1SK> Maybe in a few months down the road
17:35:23 <FL1SK> I would love to do it
17:35:27 <llunak> I think this has been the brainstorming part and now we should sum up to see and discuss the possibilities
17:35:31 <wstephenson> agreed
17:35:38 <remur_030> hm right, every package has it's own _link, _aggregate
17:35:44 <cb400f> and extra and playground will need to build against those weird repos used by 10 people too :-(
17:35:54 <llunak> would somebody sum the options for the mailing list?
17:36:34 <llunak> hmm, or maybe rather I will, there are some non-obvious technical details I guess
17:36:53 * llunak checks his AI list so far ...
17:36:56 <llunak> ok, good
17:37:13 <remur_030> after that confusing discussion i am not sure there were really laid out options
17:37:25 <llunak> #action llunak sum up KDE:SC:45 discussion and possibilities on the mailing list
17:37:31 <llunak> no problem, I'll find them :)
17:37:50 <javier_> ok next topic
17:38:17 <javier_> * dissolving KDE:Community, KDE:KDE4:Community repositories
17:38:31 <FL1SK> dissolving
17:38:33 <FL1SK> really
17:38:37 <remur_030> #topic ;-)
17:38:39 <FL1SK> what have they turned into
17:38:43 <llunak> everybody from KDE:Community and KDE:KDE4:Community has been mailed
17:38:51 <llunak> titti has already said he's moved all his stuff :)
17:38:51 <javier_> #topic dissolving KDE:Community, KDE:KDE4:Community repositories
17:39:08 <FL1SK> where has it moved... EXTRA
17:39:14 <remur_030> FL1SK: mostly yes
17:39:18 <FL1SK> ok
17:39:25 <FL1SK> was noticing a few things missing
17:39:38 <remur_030> i guess some stuff would only qualify for the stricter playground rules but i don't know
17:39:42 <llunak> so I'll give it some more time and then nuke the repos (which in practice will be a copy somewhere to my home just in case, but don't tell anyone :) )
17:39:46 <cb400f> llunak: have they been told that orphaned packages are up for auction?
17:39:56 <llunak> cb400f: what do you mean?
17:40:20 <Beineri> cb400f: auction? or first come first serve?
17:40:27 <cb400f> so that if someone doesn't care about a package in kde4:community.. maybe someone else wants to adopt it
17:40:32 <llunak> ah
17:40:38 <remur_030> llunak: sounds good to me, if someone comes here hunting we can point him there
17:40:40 <llunak> cb400f: I think I haven't said that explicitly
17:40:55 <llunak> cb400f: well, feel like getting the AI of telling this to people?
17:41:47 <remur_030> rabauke could blog it and a new up for adoption mail could be sufficient eh?
17:41:50 <javier_> wasn't the idea to have those orphaned packages maintained by the kde team, which will do whatever they think is convinient (ie drop it/them)
17:41:56 <bitshuffler> how about we do wipebinaries on k:k:c so ppl note it automatically?
17:41:56 <FL1SK> wstephenson: http://picpaste.com/NM-missing-parts.jpeg
17:41:57 <remur_030> what happened to the opensuse kde blog anyway?
17:41:59 <cb400f> they'll just ask questions about the technicalities :-)
17:42:27 <llunak> cb400f: then you can point them to the list
17:42:27 <remur_030> javier_: I oppose that, it will leave the impression people care for that stuff
17:42:32 <wstephenson> remur_030: not sure, rabauke should know
17:43:00 <Beineri> bitshuffler: people will not note that the package they have installed/use is not reinstallable...
17:43:01 <llunak> remur_030: I think javier_ meant we should just decide right now to drop them :)
17:43:10 <remur_030> k, maybe we could get the omg suse guy =)
17:43:13 <javier_> llunak: not exactly ;)
17:43:18 <wstephenson> remur_030: i'm talking to rtyler
17:43:21 <cb400f> ok, I'll spam :-)
17:43:24 <bitshuffler> Beineri: well, they will note that something is wrong when they want a new one - -better that than nothing
17:43:50 <llunak> javier_: cb400f agreed to the AI of announcing the call for adoption of the packages, quick :)
17:44:37 <javier_> #action cb400f will announce the call for adoption of orphaned packages
17:45:04 <javier_> ok next topic
17:45:21 <javier_> #topic Fixing and polishing kde-four-live with KDE 4.5.0 and suggest the KDE people to include a link to it in the KDE SC 4.5.0 release announcement (Alin's idea).
17:45:27 <javier_> this one was already discussed
17:45:38 <javier_> wstephenson is working on it
17:46:19 <remur_030> the others don't do a kde4.5 respin? =)
17:46:30 <llunak> wstephenson: will you tell also upstream, for the announcement?
17:46:47 <javier_> that sounds like an #action item
17:46:51 <wstephenson> llunak: yes
17:47:14 <wstephenson> llunak: it's done, i've been working closely with upstream on this
17:47:24 <wstephenson> remur_030: i guess they will do packages
17:47:35 <javier_> #action wstephenson will tell upstream about the kde-four-live cd to include it in the kde sc release announcement
17:47:53 <wstephenson> done :D
17:48:00 <llunak> fastest AI in the world :)
17:48:03 <javier_> ah they already know :)
17:48:05 <javier_> yepp
17:48:56 <wstephenson> next?
17:49:01 <javier_> wstephenson: it would be good to know what changes you've done (patches, adding/removing packages, config... )
17:49:11 <wstephenson> javier_: i'll write a report ot the list
17:49:13 <wstephenson> you can AI me that.
17:49:17 <javier_> wstephenson: ok, thanks
17:49:48 <javier_> #action wstephenson will send to the list the changes made on kde-four-live
17:50:00 <javier_> ok guys, last item
17:50:11 <javier_> #topic Q&A, misc
17:50:29 <wstephenson> yay
17:50:31 <javier_> any questions?
17:50:41 <javier_> or answers? ;)
17:50:57 <wstephenson> javier_: Q. did KDE Espana get in touch?
17:51:19 <javier_> wstephenson: yes, they did.
17:51:23 <javier_> I'm in touch with them
17:51:26 <wstephenson> great
17:51:37 <javier_> yepp :)
17:51:38 <wstephenson> i hope we can start working better with our regions
17:51:49 <remur_030> I'd like to know how most people think about the kde proposal on the list, activly support, don't care, oppose? just like that, no big discussion or something, we can leave that to the project list
17:52:55 <remur_030> i dislike it as I fear it splits the opensuse community, but I am not going to comment on the list
17:52:59 <llunak> if it didn't mean gnome people would run away screaming (since they don't have kde's people with being treated as second class by fedora, ubuntu, etc.), I think I would support it
17:53:36 <wstephenson> i'm kind of split between supporting it and dismissing the entire strategy process
17:54:11 <wstephenson> i'm a bit sad that the gnomes have to make such a big deal out of it
17:54:12 <llunak> we could use a strategy, running in all directions like chipmunks doesn't work well apparently
17:54:19 <wstephenson> jan engelhart summarised it very well
17:54:34 <wstephenson> "exaggerated fear of decline"
17:54:54 <remur_030> well vuntz made a good point only one year ago it was agreed to leave it at this
17:54:57 <wstephenson> and it's the only strategy that might actually make a change, make us more possible
17:55:23 <wstephenson> remur_030: that's true, but then why did we start this strategy process?
17:56:02 <remur_030> wstephenson: i am not sure, the first proposals where outright useless i think
17:56:13 <llunak> uhm, btw, we are still in the meeting, so this is logged
17:56:19 <llunak> maybe we should wrap up first
17:56:32 <bitshuffler> I'm against it since it would be a kick in the face for the other desktops so I prefer the developer / poweruser one (should get added some lts)
17:57:48 <wstephenson> bitshuffler: the question is will developer/poweruser represent anything more than rearranging the deckchairs on the status quo?
17:58:34 <llunak> developer would, since then non-developer stuff could get secondary, and it is not now
17:58:35 <javier_> ok, I think the meeting is over
17:59:06 <bitshuffler> wstephenson: dunno. otoh would following the kde strategy change something? llunak made a good example yesterday with but is such stuff really worth being a "strategy"?
17:59:30 <llunak> javier_: #endmeeting
17:59:52 <javier_> I was waiting for some output :)
17:59:55 <javier_> ok
17:59:59 <javier_> #endmeeting